LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-05-2017, 12:10 PM   #1
Fardad74
Member
 
Registered: Jan 2016
Posts: 50
Blog Entries: 1

Rep: Reputation: Disabled
Question Cant's type right to left(Persian language) on centos7


Hello friends

I'd recently added persian language on my centos7, but when typing in persian the words become mess and in fact words are persian but align is english (left to right), it should be right to left, i didn't found any settings for it, how can i do this?

Last edited by Fardad74; 07-05-2017 at 12:11 PM.
 
Old 07-05-2017, 12:34 PM   #2
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,952

Rep: Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814
Quote:
Originally Posted by Fardad74 View Post
Hello friends

I'd recently added persian language on my centos7, but when typing in persian the words become mess and in fact words are persian but align is english (left to right), it should be right to left, i didn't found any settings for it, how can i do this?
What application are you typing in, and do you want this behavior to be for your entire desktop, or on an application-by-application basis?? I ask, because you can set things like vi/vim, LibreOffice, and others, to have the right-to-left, and leave others alone. Since you installed the language pack, have you changed the keyboard layout?
  • Gnome 2 - System >> Preferences >> Keyboard Preferences >> Layout tab >> Add >> *By language tab >> language: Persian >> Add
  • Gnome 3 - System Settings (click on the username on top right/left) -> Region and Language -> Layouts -> + -> Persian
  • KDE - System Settings, Regional and Language Section, Keyboard Layout
 
Old 07-05-2017, 01:03 PM   #3
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 3,384
Blog Entries: 9

Rep: Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893Reputation: 1893
Abiword is supposed to be very good on right-to-left languages.
 
Old 07-05-2017, 01:33 PM   #4
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
What application are you typing in, and do you want this behavior to be for your entire desktop, or on an application-by-application basis?? I ask, because you can set things like vi/vim, LibreOffice, and others, to have the right-to-left, and leave others alone. Since you installed the language pack, have you changed the keyboard layout?
  • Gnome 2 - System >> Preferences >> Keyboard Preferences >> Layout tab >> Add >> *By language tab >> language: Persian >> Add
  • Gnome 3 - System Settings (click on the username on top right/left) -> Region and Language -> Layouts -> + -> Persian
  • KDE - System Settings, Regional and Language Section, Keyboard Layout
i exactly done these recommendations but not worked, my problem is on all environments of my system
 
Old 07-05-2017, 01:42 PM   #5
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,952

Rep: Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814
Quote:
Originally Posted by Fardad74 View Post
i exactly done these recommendations but not worked, my problem is on all environments of my system
Ok, but you need to answer the questions asked. Are you trying to do this for all your applications and your desktop GUI, or just SOME of your applications?? And if you did those things (and logged out/rebooted) and its not working, you've got larger problems.

What desktop environment are you using? I listed three...do you have all of them installed, and you tried ALL of them??? With which applications did you try?
 
Old 07-05-2017, 01:58 PM   #6
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
Ok, but you need to answer the questions asked. Are you trying to do this for all your applications and your desktop GUI, or just SOME of your applications?? And if you did those things (and logged out/rebooted) and its not working, you've got larger problems.

What desktop environment are you using? I listed three...do you have all of them installed, and you tried ALL of them??? With which applications did you try?
My desktop is gnome and my problem is on command line, vi and all environments! i just switch between english and persian but my persian words become mess and strange, words exactly had english alignment (left to right), while should be right to left.
 
Old 07-05-2017, 02:02 PM   #7
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
Ok, but you need to answer the questions asked. Are you trying to do this for all your applications and your desktop GUI, or just SOME of your applications?? And if you did those things (and logged out/rebooted) and its not working, you've got larger problems.

What desktop environment are you using? I listed three...do you have all of them installed, and you tried ALL of them??? With which applications did you try?
i done for gnome 2.
 
Old 07-05-2017, 02:07 PM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,952

Rep: Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814
Quote:
Originally Posted by Fardad74 View Post
i done for gnome 2.
And again: did you log out and reboot??? Do you want this for ALL your applications or just some? If you're not going to answer questions, we can't guess.
 
Old 07-05-2017, 02:10 PM   #9
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
And again: did you log out and reboot??? Do you want this for ALL your applications or just some? If you're not going to answer questions, we can't guess.
Yes, i rebooted.
 
Old 07-05-2017, 02:20 PM   #10
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Fardad74 View Post
i done for gnome 2.
It's exactly like, suppose that you type "Hello" and you see "olleH" !!
 
Old 07-05-2017, 02:24 PM   #11
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by TB0ne View Post
And again: did you log out and reboot??? Do you want this for ALL your applications or just some? If you're not going to answer questions, we can't guess.
Oh, one thing that i didn't saw was the layout tab, i added persian language but not in layout tab, but in "region and language " then " + " button and added persian (with persian keypad).
 
Old 07-05-2017, 02:58 PM   #12
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,952

Rep: Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814
Quote:
Originally Posted by Fardad74 View Post
Yes, i rebooted.
...and...
Quote:
Originally Posted by Fardad74
It's exactly like, suppose that you type "Hello" and you see "olleH" !!
...and....
Quote:
Originally Posted by Fardad74
Oh, one thing that i didn't saw was the layout tab, i added persian language but not in layout tab, but in "region and language " then " + " button and added persian (with persian keypad).
So when you said "i exactly done these recommendations but not worked", you actually meant "I didn't do the things listed at all", right? If you don't follow the instructions, it's not going to work. If you're using Gnome 2, that tab will be there. And since you want to type right to left, and when you type "Hello" and get "olleH"...not really seeing what's wrong.

Good luck.
 
1 members found this post helpful.
Old 07-05-2017, 03:10 PM   #13
Fardad74
Member
 
Registered: Jan 2016
Posts: 50

Original Poster
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by Fardad74 View Post
Oh, one thing that i didn't saw was the layout tab, i added persian language but not in layout tab, but in "region and language " then " + " button and added persian (with persian keypad).
Quote:
Originally Posted by TB0ne View Post
...and...

...and....

So when you said "i exactly done these recommendations but not worked", you actually meant "I didn't do the things listed at all", right? If you don't follow the instructions, it's not going to work. If you're using Gnome 2, that tab will be there. And since you want to type right to left, and when you type "Hello" and get "olleH"...not really seeing what's wrong.

Good luck.
Please take a look at these photos, all settings is ok, even i added all 3 persian languages that were available, but any of them didn't worked well (right to left).
Attached Thumbnails
Click image for larger version

Name:	1.JPG
Views:	15
Size:	52.9 KB
ID:	25381   Click image for larger version

Name:	2.JPG
Views:	12
Size:	44.2 KB
ID:	25382  
 
Old 07-05-2017, 03:33 PM   #14
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 21,952

Rep: Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814Reputation: 5814
Quote:
Originally Posted by Fardad74 View Post
Please take a look at these photos, all settings is ok, even i added all 3 persian languages that were available, but any of them didn't worked well (right to left).
Again: you did not set the layout as you said you did. Installing the language packs only takes you so far. I'm done...good luck to you.
 
Old 07-05-2017, 03:36 PM   #15
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004Reputation: 1004
I don't think it will work in the terminal at a command prompt. And, in "Formats" you have "United States English". That format is left to right.
 
1 members found this post helpful.
  


Reply

Tags
alignment, keyboard


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
scim foreign language can't type space when switching type mode 7/24/2015 babbab Slackware 16 07-05-2016 04:23 AM
LXer: The twisted road through right-to-left language support LXer Syndicated Linux News 0 03-09-2016 06:40 PM
the English characters distorted after add a right to left language alwaystudent Red Hat 0 06-14-2015 01:48 PM
persian language support in salix travis82 Slackware 2 02-27-2014 12:47 AM
persian language on centos baranmatin Linux - Desktop 3 11-19-2010 04:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration