-   Linux - Newbie (
-   -   Cannot yum install mgp123 with missing (

brother.gabriel 06-09-2012 10:50 PM

Cannot yum install mgp123 with missing
Salvete! I want to install mpg123 on my new CentOS 6.2 installation, but I get a package resolution dependency error:


Now, I have libtool 2.2.6 installed, as well as the runtime libraries, libtool-ltdl.x86_64.

I tried putting a copy of in /lib and also in /lib64 and also in /usr/lib/ and also in user/lib64, but it didn't help.

How can I resolve the dependency? I already ran yum update, but it didn't accomplish what I want to do. Please help!

(there is no tag for CentOS6, by the way... and I can't create tags)

AwesomeMachine 06-09-2012 11:41 PM

do this:

$ locate libltdl | grep lib

observe the path,

$ ls -al /path/libltdl*

find the libltdl file that is NOT a symlink (doesn't point to another file).

then do:

$ ln -s /path/ /path/

That method is a cure-all for everything!

brother.gabriel 06-10-2012 07:12 PM

Thanks for helping me out! I see now that I have /usr/lib64/
That must mean that mpg123 wants an older version of libtool, right?

I downloaded the 3.1.4 package from this page, and was able to put libltdl.3.1.4 into /usr/lib64, but if I try to put the accompanying pointer (?) file, libltdl.3 into that folder, it says the file already exists - even though I don't see it (not even hidden) in the directory.

So then I saw that yum only retrieved mpg123 version 1.3, so I downloaded mpg123 version 1.9 from here, but that mpg123 package still seems to require libltdl.3!

Hmmm... Can I have both versions at the same time?

What do I do now?
I need mpg123 so that I can play mp3 files with Asterisk. The "Definitive Guide" for Asterisk 1.8 says to use mpg123.

brother.gabriel 06-10-2012 07:53 PM

Okay! I think I got it.

I downloaded mpg123-1.13.6-17.el6.x86_64.rpm from and it didn't give me the libltdl dependency. Instead, it gave me two others:

jack-audio-connection-kit-0.116.1-6_1.el6.x86_64.rpm which required libfreebob-1.0.11-6.el6.x86_64.rpm

After all of that, it worked! And what's better, the files are all from the rhel6 resource.

Anybody dealing with CentOS 6, make sure to visit this page:

All times are GMT -5. The time now is 03:59 AM.