LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2017, 07:18 PM   #1
Sefyir
Member
 
Registered: Mar 2015
Distribution: Linux Mint
Posts: 633

Rep: Reputation: 316Reputation: 316Reputation: 316Reputation: 316
Cannot use write


Using raspberry pi 3 Raspbian with Pixel

I'm getting a fairly common error with write

Code:
write: user has messages disabled
The solution is to check with mesg and ensure it shows y

But this doesn't seem to work... for all users but my admin one.

For example:

With user user
Code:
$ mesg
is y
$ write user
write: user has messages disabled
However, on my "admin" account (with sudo privileges) write does work. I'm not sure why?

With user admin
Code:
$ mesg
is y
write admin
Message from admin@hostname on pts/0 at 17:15 ...
What am I missing? Every guide focuses on getting mesg to be set to y, which it already is.
 
Old 04-20-2017, 07:41 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 17,494
Blog Entries: 28

Rep: Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433Reputation: 5433
I've not need to use "write," but you might take a look at man mesg.

From the mesg man page:

Quote:
DESCRIPTION
Mesg controls the access to your terminal by others. It's typically
used to allow or disallow other users to write to your terminal (see
write(1)).

OPTIONS
y Allow write access to your terminal.

n Disallow write access to your terminal.

If no option is given, mesg prints out the current access state of your
terminal.
 
Old 04-20-2017, 07:41 PM   #3
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,513

Rep: Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009Reputation: 1009
I think it says that because mesg is automatically set to "n" unless the other user is logged in. It also doesn't work with ssh users.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] usb drive: cannot remount block device /dev/sdb1 read-write, is write-protected schneidz Linux - Hardware 5 01-06-2015 03:15 PM
find files with at least read and write for user but not write for group (on Mac OS X) davedpss Other *NIX 11 09-09-2013 04:19 PM
read/write,write/write lock with smbclient fails swatidas11 Linux - Networking 1 03-10-2010 12:27 PM
NFS write problem, UID correct, rw in /etc/exports -but still cannot write polgard Linux - Networking 2 09-19-2008 03:14 AM
root unable to write on drive mounted with read/write perrmission aquash2000 Linux - Server 5 07-19-2008 12:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration