LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-21-2018, 03:20 PM   #1
FLpenguin
LQ Newbie
 
Registered: Dec 2016
Posts: 7

Rep: Reputation: Disabled
cannot update anything on Mint 17.3


For several weeks I have not been able to update anything. I have checked for similar threads, and I found a similar problem solved by crazypenguin. I tried all those suggestions and decided to update to Mint 18. But I cannot install the upgrade tool and cannot download the package upgrades. Is my only option to perform a fresh install of 17.3 and then update as suggested on page 4 of the "How to upgrade to Linux Mint 18?" I am a novice and didn't want to bother anyone. I would appreciate your suggestions.
 
Old 07-21-2018, 04:14 PM   #2
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
Hi FLpenguin, and welcome to LQ.

Are you able to access the internet on the computer (browse etc.?).
 
Old 07-21-2018, 04:29 PM   #3
FLpenguin
LQ Newbie
 
Registered: Dec 2016
Posts: 7

Original Poster
Rep: Reputation: Disabled
Yes, I can access the internet, usually use Firefox browser. I seem to be able to do everything but update. I can see the update notification. After the update doesn't run I get the message "E: linux image-extra-4.4.0-130-generic:subprocess installed post-removal script returned error exit status 1.
 
Old 07-21-2018, 04:37 PM   #4
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
Ok. Can you please paste the output of the following commands here (between CODE tags - see the # on LQ's advanced editor):

Code:
dpkg -l | grep -v "^ii"
Also:

Code:
dpkg -l "linux-*" | grep "^ii"
The former will list any packages that aren't properly installed. The latter will, among others, show your kernel packages.
 
Old 07-21-2018, 05:01 PM   #5
FLpenguin
LQ Newbie
 
Registered: Dec 2016
Posts: 7

Original Poster
Rep: Reputation: Disabled
lynn@lynn-Latitude-D830 ~ $ dpkg -l | grep -v "^ii"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===========================================-===================================================-============-==================================================================================================== =================
rc audacious 3.4.3-1 amd64 small and fast audio player which supports lots of formats
rc bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.2~lp1415880~1 amd64 Broadcom 802.11 Linux STA wireless driver source
iU cups 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
iF cups-bsd 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - BSD commands
iU cups-core-drivers 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - PPD-less printing
iF cups-daemon 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - daemon
rc devede 3.23.0~ds1-5ubuntu1 all simple application to create Video DVDs
rc hexchat 2.10.2-1~getdeb1 amd64 IRC client for X based on X-Chat 2
rc libavcodec54:amd64 6:9.20-0ubuntu0.14.04.1 amd64 Libav codec library
rc libclamav6 0.98.7+dfsg-0ubuntu0.14.04.1 amd64 anti-virus utility for Unix - library
rc libsvga1:amd64 1:1.4.3-33 amd64 console SVGA display libraries
rH linux-image-extra-4.4.0-130-generic 4.4.0-130.156~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
iF mime-support 3.54ubuntu1.1 all MIME files 'mime.types' & 'mailcap', and support programs
rc mplayer 2:1.1+dfsg1-0ubuntu3 amd64 movie player for Unix-like systems
ic opera 12.16.1860-1linuxmint amd64 Fast and secure web browser and Internet suite
iHR opera-stable 53.0.2907.110 amd64 Fast and secure web browser
rc virtualbox-5.0 5.0.2-102096~Ubuntu~trusty amd64 Oracle VM VirtualBox


lynn@lynn-Latitude-D830 ~ $ dpkg -l "linux-*" | grep "^ii"
ii linux-firmware 1.127.24 all Firmware for Linux kernel drivers
ii linux-headers-3.19.0-32 3.19.0-32.37~14.04.1 all Header files related to Linux kernel version 3.19.0
ii linux-headers-3.19.0-32-generic 3.19.0-32.37~14.04.1 amd64 Linux kernel headers for version 3.19.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-109 4.4.0-109.132~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-109-generic 4.4.0-109.132~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-111 4.4.0-111.134~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-111-generic 4.4.0-111.134~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-112 4.4.0-112.135~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-112-generic 4.4.0-112.135~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-116 4.4.0-116.140~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-116-generic 4.4.0-116.140~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-119 4.4.0-119.143~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-119-generic 4.4.0-119.143~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-121 4.4.0-121.145~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-121-generic 4.4.0-121.145~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-124 4.4.0-124.148~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-124-generic 4.4.0-124.148~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-127 4.4.0-127.153~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-127-generic 4.4.0-127.153~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-128 4.4.0-128.154~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-128-generic 4.4.0-128.154~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-130 4.4.0-130.156~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-130-generic 4.4.0-130.156~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-generic-lts-xenial 4.4.0.130.110 amd64 Generic Linux kernel headers
ii linux-image-3.19.0-32-generic 3.19.0-32.37~14.04.1 amd64 Linux kernel image for version 3.19.0 on 64 bit x86 SMP
ii linux-image-4.4.0-109-generic 4.4.0-109.132~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-111-generic 4.4.0-111.134~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-112-generic 4.4.0-112.135~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-116-generic 4.4.0-116.140~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-119-generic 4.4.0-119.143~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-121-generic 4.4.0-121.145~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-124-generic 4.4.0-124.148~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-127-generic 4.4.0-127.153~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-128-generic 4.4.0-128.154~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-3.19.0-32-generic 3.19.0-32.37~14.04.1 amd64 Linux kernel extra modules for version 3.19.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-109-generic 4.4.0-109.132~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-111-generic 4.4.0-111.134~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-112-generic 4.4.0-112.135~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-116-generic 4.4.0-116.140~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-119-generic 4.4.0-119.143~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-121-generic 4.4.0-121.145~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-124-generic 4.4.0-124.148~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-127-generic 4.4.0-127.153~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-128-generic 4.4.0-128.154~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-libc-dev:amd64 3.13.0-153.203 amd64 Linux Kernel Headers for development
ii linux-sound-base 1.0.25+dfsg-0ubuntu4 all base package for ALSA and OSS sound systems

I was not sure how to place these between code tags using LQ's Advanced Editor
 
Old 07-21-2018, 05:04 PM   #6
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
In that case, can you edit your post, click on "Go Advanced" at the bottom, select the text you want to go between CODE tags, and then click on the # symbol in the edit menu. Then save your post. Thanks.

Last edited by hydrurga; 07-21-2018 at 05:16 PM.
 
Old 07-21-2018, 05:06 PM   #7
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
If you are unable to do that, at least edit your post and remove all the equals signs so that we can go back to a normal-width thread. Thanks.
 
Old 07-21-2018, 05:23 PM   #8
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
If you're having problems with my instructions, don't worry, just let me know and I'll walk you through them.
 
Old 07-21-2018, 05:46 PM   #9
FLpenguin
LQ Newbie
 
Registered: Dec 2016
Posts: 7

Original Poster
Rep: Reputation: Disabled
I am having problems doing what you suggested. I do not use the advanced editor and do not know how to select the equal signs, delete and place between the tags
 
Old 07-21-2018, 05:54 PM   #10
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
Ok. No problem. On your post above (the one with all the output), click on the Edit button on the right-hand side at the bottom.

In the edit window that appears, use your mouse/trackpad to highlight all the equals signs. Then hit the Delete key to delete them.

Then click on the Save button in the right-hand side at the bottom of that window.
 
Old 07-21-2018, 06:00 PM   #11
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,572

Rep: Reputation: 210Reputation: 210Reputation: 210
Try running the following command in a terminal to fix stuff first:
Code:
sudo apt-get -f install
Then, if things are okay, run the following to update stuff in your 17 system:
Code:
sudo apt-get update && sudo apt-get dist-upgrade
Then, hopefully your Update Manager will be working to allow you to upgrade to Mint 18.
 
Old 07-21-2018, 06:22 PM   #12
FLpenguin
LQ Newbie
 
Registered: Dec 2016
Posts: 7

Original Poster
Rep: Reputation: Disabled
I ran Mark Alfred's suggested commands. The first generated many compilation errors and "cannot open lock file /var/lib/dpkg/lock - open (13: permission
denied)" then a second message "unable to lock the administration directory (/var/lib/dpkg)"
 
Old 07-21-2018, 06:26 PM   #13
FLpenguin
LQ Newbie
 
Registered: Dec 2016
Posts: 7

Original Poster
Rep: Reputation: Disabled
This is the output from Mark's first command "sudo apt-get -f install:

lynn@lynn-Latitude-D830 ~ $ sudo apt-get -f install
[sudo] password for lynn:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
opera-stable
Recommended packages:
pepperflashplugin-nonfree
The following packages will be REMOVED:
linux-image-extra-4.4.0-130-generic
The following packages will be upgraded:
opera-stable
1 upgraded, 0 newly installed, 1 to remove and 31 not upgraded.
7 not fully installed or removed.
Need to get 0 B/55.8 MB of archives.
After this operation, 154 MB disk space will be freed.
Do you want to continue? [Y/n] y
debconf: Perl may be unconfigured (Can't locate XSLoader.pm in @INC (you may need to install the XSLoader module) (@INC contains: /etc/perl /usr/local/lib/perl/5.18.2 /usr/local/share/perl/5.18.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.18 /usr/share/perl/5.18 /usr/local/lib/site_perl .) at /usr/lib/perl/5.18/IO.pm line 5.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO.pm line 5.
Compilation failed in require at /usr/lib/perl/5.18/IO/Handle.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/Handle.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/Seekable.pm line 9.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/Seekable.pm line 9.
Compilation failed in require at /usr/lib/perl/5.18/IO/File.pm line 11.
BEGIN failed--compilation aborted at /usr/lib/perl/5.18/IO/File.pm line 11.
Compilation failed in require at /usr/share/perl/5.18/FileHandle.pm line 9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
(Reading database ... 527944 files and directories currently installed.)
Removing linux-image-extra-4.4.0-130-generic (4.4.0-130.156~14.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.4.0-130-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-130-generic /boot/vmlinuz-4.4.0-130-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-130-generic /boot/vmlinuz-4.4.0-130-generic
Error! Bad return status for module build on kernel: 4.4.0-130-generic (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.59/build/make.log for more information.
Error! Bad return status for module build on kernel: 4.4.0-130-generic (x86_64)
Consult /var/lib/dkms/virtualbox/5.0.4/build/make.log for more information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-130-generic /boot/vmlinuz-4.4.0-130-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-130-generic
grep: /boot/config-4.4.0-130-generic: No such file or directory
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-apple.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-apple.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-cherry.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-cherry.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-logitech.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-logitech.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-logitech-dj.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-logitech-dj.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-microsoft.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-microsoft.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-a4tech.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-a4tech.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-belkin.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-belkin.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-chicony.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-chicony.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-cypress.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-cypress.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-ezkey.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-ezkey.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-gyration.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-gyration.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-monterey.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-monterey.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-petalynx.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-petalynx.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-pl.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-pl.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-samsung.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-samsung.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-sony.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-sony.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-sunplus.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-sunplus.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-tmff.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-tmff.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-zpff.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/hid/hid-zpff.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/fs/jfs/jfs.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/fs/jfs/jfs.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/fs/reiserfs/reiserfs.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/fs/reiserfs/reiserfs.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-ohci.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-ohci.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-sbp2.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-sbp2.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-ohci.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-ohci.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-sbp2.ko’: No such file or directory
modinfo: ERROR: Module /lib/modules/4.4.0-130-generic/kernel/drivers/firewire/firewire-sbp2.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-130-generic/kernel/fs/nls/nls_utf8.ko’: No such file or directory
E: /usr/share/initramfs-tools/hooks/casper failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.4.0-130-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-4.4.0-130-generic (--remove):
subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
linux-image-extra-4.4.0-130-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 07-21-2018, 06:31 PM   #14
hydrurga
LQ Guru
 
Registered: Nov 2008
Location: Pictland
Distribution: Linux Mint 21 MATE
Posts: 8,048
Blog Entries: 5

Rep: Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925Reputation: 2925
For anyone else coming in and helping the OP, they need to purge those incorrectly installed packages listed above.

For each package, try first apt purge package_name, then sudo dpkg --purge package_name, then finally sudo dpkg --purge --force-all package_name.

That with an update, should hopefully get the package manager working again.

Then they will have to reinstall cups, cups-bsd, cups-core-drivers, cups-daemon, and mime-support as all these are required by Mint.

Then another update, and finally an upgrade to 18, then on to 18.3.

I seem to be having communication problems with the OP, not helped by someone else jumping in with something that stood little chance of working, so will opt out at this point.

I would advise the OP only to carry out the above procedures with the help of someone on here.
 
Old 07-21-2018, 06:33 PM   #15
mark_alfred
Senior Member
 
Registered: Jul 2003
Location: Toronto, Ontario, Canada
Distribution: Ubuntu Linux 16.04, Debian 10, LineageOS 14.1
Posts: 1,572

Rep: Reputation: 210Reputation: 210Reputation: 210
Regarding the "code" tags, I never use the advanced editor. I just manually enter them. I type the following: [c0de]coded stuff[/c0de] <-- notice though that here I used a zero rather than a letter "oh", so that what I typed would appear here.

Anyway, here's your stuff from the fifth post within code tags:

Code:
lynn@lynn-Latitude-D830 ~ $ dpkg -l | grep -v "^ii"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-===========================================-===================================================-============-==================================================================================================== =================
rc audacious 3.4.3-1 amd64 small and fast audio player which supports lots of formats
rc bcmwl-kernel-source 6.30.223.248+bdcom-0ubuntu0.2~lp1415880~1 amd64 Broadcom 802.11 Linux STA wireless driver source
iU cups 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - PPD/driver support, web interface
iF cups-bsd 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - BSD commands
iU cups-core-drivers 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - PPD-less printing
iF cups-daemon 1.7.2-0ubuntu1.10 amd64 Common UNIX Printing System(tm) - daemon
rc devede 3.23.0~ds1-5ubuntu1 all simple application to create Video DVDs
rc hexchat 2.10.2-1~getdeb1 amd64 IRC client for X based on X-Chat 2
rc libavcodec54:amd64 6:9.20-0ubuntu0.14.04.1 amd64 Libav codec library
rc libclamav6 0.98.7+dfsg-0ubuntu0.14.04.1 amd64 anti-virus utility for Unix - library
rc libsvga1:amd64 1:1.4.3-33 amd64 console SVGA display libraries
rH linux-image-extra-4.4.0-130-generic 4.4.0-130.156~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
iF mime-support 3.54ubuntu1.1 all MIME files 'mime.types' & 'mailcap', and support programs
rc mplayer 2:1.1+dfsg1-0ubuntu3 amd64 movie player for Unix-like systems
ic opera 12.16.1860-1linuxmint amd64 Fast and secure web browser and Internet suite
iHR opera-stable 53.0.2907.110 amd64 Fast and secure web browser
rc virtualbox-5.0 5.0.2-102096~Ubuntu~trusty amd64 Oracle VM VirtualBox


lynn@lynn-Latitude-D830 ~ $ dpkg -l "linux-*" | grep "^ii"
ii linux-firmware 1.127.24 all Firmware for Linux kernel drivers
ii linux-headers-3.19.0-32 3.19.0-32.37~14.04.1 all Header files related to Linux kernel version 3.19.0
ii linux-headers-3.19.0-32-generic 3.19.0-32.37~14.04.1 amd64 Linux kernel headers for version 3.19.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-109 4.4.0-109.132~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-109-generic 4.4.0-109.132~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-111 4.4.0-111.134~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-111-generic 4.4.0-111.134~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-112 4.4.0-112.135~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-112-generic 4.4.0-112.135~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-116 4.4.0-116.140~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-116-generic 4.4.0-116.140~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-119 4.4.0-119.143~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-119-generic 4.4.0-119.143~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-121 4.4.0-121.145~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-121-generic 4.4.0-121.145~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-124 4.4.0-124.148~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-124-generic 4.4.0-124.148~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-127 4.4.0-127.153~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-127-generic 4.4.0-127.153~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-128 4.4.0-128.154~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-128-generic 4.4.0-128.154~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-4.4.0-130 4.4.0-130.156~14.04.1 all Header files related to Linux kernel version 4.4.0
ii linux-headers-4.4.0-130-generic 4.4.0-130.156~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii linux-headers-generic-lts-xenial 4.4.0.130.110 amd64 Generic Linux kernel headers
ii linux-image-3.19.0-32-generic 3.19.0-32.37~14.04.1 amd64 Linux kernel image for version 3.19.0 on 64 bit x86 SMP
ii linux-image-4.4.0-109-generic 4.4.0-109.132~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-111-generic 4.4.0-111.134~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-112-generic 4.4.0-112.135~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-116-generic 4.4.0-116.140~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-119-generic 4.4.0-119.143~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-121-generic 4.4.0-121.145~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-124-generic 4.4.0-124.148~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-127-generic 4.4.0-127.153~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-4.4.0-128-generic 4.4.0-128.154~14.04.1 amd64 Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-3.19.0-32-generic 3.19.0-32.37~14.04.1 amd64 Linux kernel extra modules for version 3.19.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-109-generic 4.4.0-109.132~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-111-generic 4.4.0-111.134~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-112-generic 4.4.0-112.135~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-116-generic 4.4.0-116.140~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-119-generic 4.4.0-119.143~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-121-generic 4.4.0-121.145~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-124-generic 4.4.0-124.148~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-127-generic 4.4.0-127.153~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-image-extra-4.4.0-128-generic 4.4.0-128.154~14.04.1 amd64 Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii linux-libc-dev:amd64 3.13.0-153.203 amd64 Linux Kernel Headers for development
ii linux-sound-base 1.0.25+dfsg-0ubuntu4 all base package for ALSA and OSS sound systems

Last edited by mark_alfred; 07-21-2018 at 06:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Update manger fails to update - Mint 17.2 Rob1911 Linux Mint 2 10-15-2015 10:42 AM
Update from MInt 17 to Mint 17.2 rossdorn Linux Mint 4 08-13-2015 01:36 AM
update mint 14 to 15 xiphib Linux - General 5 06-17-2013 07:48 AM
Mint Update has stopped loading the notification icon at startup (Mint 10) icekool Linux Mint 6 12-19-2010 07:49 AM
Mint 6 Update Causes Error in MInt Installer Novatian Linux Mint 0 10-19-2009 04:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration