LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cannot uninstall rpm (https://www.linuxquestions.org/questions/linux-newbie-8/cannot-uninstall-rpm-75466/)

jaina2 07-24-2003 08:09 AM

cannot uninstall rpm
 
Hi

I am running rh9 and am a total newbie (1 week old)

I am trying to install the drivers for my conexant hsfi v92 minipci modem

Initially i installed an rpm that did not seem to work with the modem, so I downloaded a new package from linuxant.com

Now I am trying to uninstall the old package using
rpm -e package name

but i get the message that the package is not present

when i try to intall the new package i get error messages saying that there is some conflict due to the old package

I went into System log and checked the rpms and found the old package listed..and thus it was not removed in the first place

I have checked my typing a number of times with rpm -e ..but still cant get to uninstall the package

I would appreciate some help

thanks

MasterC 07-24-2003 08:26 AM

Make sure packagename is all one work, assuming it was driver.1.2.3.4.i386.rpm then:
rpm -e driver.1.2.3.4
Should do it, but replace "driver" with the name of the package.

Cool

Mega Man X 07-24-2003 08:30 AM

Hi jaina2!!!

Welcome to LQ and Linux too. Well, I would like to ask which distro you are using, because there're plenty of tools for plenty of differents distro to help with installing/uninstalling of rpm's packages.

Anyway, try running

Code:

rpm -Uvh <package name here>
It should, instead of remove or install the previous package, update to the other one.

You can also run at the console:

Code:

whereis <package name here>
To see where it's installed.

Good luck.

fancypiper 07-24-2003 08:31 AM

Try leaving off everything past the dot (.) in the rpm name. If you post the actual downloaded file's name, I could be more specific.

You could also add the --force flag...

Maximum RPM

acid_kewpie 07-24-2003 09:06 AM

you are presum,ably usinfg the *FILE* name and not the package name. drop the .i386.rpm or similar from the name you are using.

jaina2 07-25-2003 12:41 AM

Thanks a lot

as you suspected a newbie mistake...i was using the file name and not the package name


All times are GMT -5. The time now is 01:58 AM.