LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-17-2018, 08:52 PM   #1
bkelly
Member
 
Registered: Jan 2008
Distribution: Centos 7-4
Posts: 205

Rep: Reputation: 13
cannot restart, cannot boot grub, cannot download live CD


Novice alert. Debian, just downloaded a few days ago.
I cannot shut the system down without using root. Says there is no command "shutdown." Account root has exactly the same password as my regular account but it will not let me in.

So I reboot and press left shift key, right shift key, escape, and minus key, each of them about once a second. No grub.

I boot from the install CD and it will only install. No grub.

Go to the Debian web site looking for a live CD. When I get to the download part, its an install cd. Not a live boot CD. (Is there a difference?) I already have that. Booted it. No grub.

How do I get into this thing so I can set the root password?

If you tell me how to get that DVD working, then please, also tell me how to mount the hard drive so I can make changes there. This is a system that was running Windows so I need to mount the C drive.

Please remember, Linux novice.

Last edited by bkelly; 04-18-2018 at 10:08 AM.
 
Old 04-18-2018, 03:13 PM   #2
snowman81
Member
 
Registered: Aug 2006
Location: Michigan
Distribution: Ubuntu
Posts: 282

Rep: Reputation: 30
Type
Code:
sudo shutdown
and then enter your password when it asks you.
 
Old 04-18-2018, 03:26 PM   #3
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 7,769
Blog Entries: 19

Rep: Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523
OK, let me explain to you about command paths. When you enter a command at a terminal, the bash shell (the command line processor) looks for a program of that name in a set of directories (folders) called the command path. If it finds such a program, it runs it. If not, it does nothing.

When you are root, the main directories on your command path are /bin, /sbin, /usr/bin and /usr/sbin. But when you are an unprivileged user, /sbin and /usr/sbin are not on your path, since they contain administrative commands that only root is supposed to use. The shutdown command lives in /sbin, which is why bash can't find it.

Graphical user interfaces have built-in tricks to allow any user to shut down the system by clicking an on-screen exit button. But to do it on the command line, you do need either to be root or to fake root by using the sudo prefix. Can you be a bit more specific about which of these two methods you were trying to use?

When you use sudo, you give your own password. When you use su to become root or log in as root, you use the root password. You were asked to set these passwords during installation. They should not be the same.
 
Old 04-18-2018, 04:27 PM   #4
bkelly
Member
 
Registered: Jan 2008
Distribution: Centos 7-4
Posts: 205

Original Poster
Rep: Reputation: 13
Command paths. Being a novice did not expect the two sets of path but makes perfect sense. Thanks.
GUI: Just got started and have not used any GUI so must be command line.

I tried: sudo shutdown followed by the password. Did not get anything. (At work right now but will try it at home. See next.)

User and root passwords should not be the same. Yeah, you are right. I write code at work and just moved into the Linux world. This is a home computer for the sole purpose of trying things out at home. I work on a government installation where the internet connection is horrible and many helpful pages are blocked. (Example: the link in your siggie is blocked and I get a message warning me that trying to access that site is being logged.) So I do some research at home. Got way too many passwords already so I’ll take that risk.

I think I tried: sudo shutdown but will try again when I get home.
 
Old 04-18-2018, 05:42 PM   #5
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,524

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
AFA the install DVD and no grub, true. But there is a menu. In one of the submenus is 'rescue'. That allows you to launch a root shell into the Linux installation, where you can set your passwords using, 'passwd'.
 
Old 04-18-2018, 09:49 PM   #6
bkelly
Member
 
Registered: Jan 2008
Distribution: Centos 7-4
Posts: 205

Original Poster
Rep: Reputation: 13
This is absurd. I booted from the DVD, found the help option, and making this short, selected "rescuegui"
Debian presented the option to select a disk. Among the options were:
/dev/sda1
/dev/sda2/
/def/sda5
Raid
do not use a root file system

I elected /dev/sda1. Eventually I had a black screen with a prompt. Enter the command "passwd" which was accepted. Wrote the password down then entered it and confirmed it. It was accepted and verified, exactly as I wrote it down. Entered the command:
Quote:
shutdown now -r
and received the response:
Quote:
Running in chroot, ignoring request.
That is a problem. I don't care WHAT you are running in. I own the system and when I enter the command shutdown then the only viable activity is to shut down. Maybe this is a hint that will clue someone in to what is going wrong.

Ok, dealing with reality, remove the DVD and force a reboot. When the start is complete I see my username for the log in account. Click on Not Listed and enter: root. Then enter the password I just wrote down, then typed in twice to confirm.
Quote:
Sorry, that didn't work. Please try again.
I just set that password.
Go through it all again and set that exact same password, the one I wrote down and entered twice and was verified.
Same result.
So what might I do to set the root password?
 
Old 04-19-2018, 12:52 AM   #7
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,524

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
Most distros won't allow root logins to the gui. If you're in a chroot environment, you have to exit, just type 'exit'. Then you can run shutdown. If you ran passwd by itself, then you changed the root password. That won't get you into the gui.

So, you must boot, and at the login screen press: CTRL+ALT+F2. Then, log in as root, and run passwd username, and change the users password. Then type logout. Then press CTRL+ALT+F7 to get back to the login screen, and use the username and password to login.
 
Old 04-19-2018, 02:10 AM   #8
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 7,769
Blog Entries: 19

Rep: Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523
Quote:
Originally Posted by bkelly View Post
I elected /dev/sda1. Eventually I had a black screen with a prompt. Enter the command "passwd" which was accepted. Wrote the password down then entered it and confirmed it. It was accepted and verified, exactly as I wrote it down. Entered the command:

and received the response: "Running in chroot, ignoring request"

That is a problem. I don't care WHAT you are running in. I own the system and when I enter the command shutdown then the only viable activity is to shut down. Maybe this is a hint that will clue someone in to what is going wrong.
It's simple! chroot stands for "change root". It's a very useful command which allows you to use another partition temporarily as your root partition. Of course that will only work if the partition you choose contains all the software that a functioning root partition needs. The installation disk did a chroot for you, allowing you to work from the root partition on your hard drive as if you had booted from it. It's a little bit like using a virtual machine (I'll probably get roasted for saying that because it's actually nothing like, but bear with me).

You can't use shutdown in chroot for the simple reason that the shutdown command only works on the host system (the booted CD in your case) and not inside a chroot jail. You have to exit from chroot to shut down the host.

PS: I don't know whether to be annoyed or flattered that the government apparently thinks my little website is dangerous for civil servants to browse. But I hope you'll explore it from your home machine.

Last edited by hazel; 04-19-2018 at 02:14 AM. Reason: Added PS.
 
Old 04-19-2018, 03:34 AM   #9
fatmac
LQ Guru
 
Registered: Sep 2011
Location: Upper Hale, Surrey/Hants Border, UK
Distribution: Mainly Devuan, antiX, & Void, with Tiny Core, Fatdog, & BSD thrown in.
Posts: 5,568

Rep: Reputation: Disabled
From the above, I would think that you did not install grub when you installed the system to your disk, otherwise you would have got a grub prompt if you couldn't boot into your newly installed system.

Try re-installing.
 
Old 04-19-2018, 06:07 PM   #10
bkelly
Member
 
Registered: Jan 2008
Distribution: Centos 7-4
Posts: 205

Original Poster
Rep: Reputation: 13
Quote:
Originally Posted by fatmac View Post
From the above, I would think that you did not install grub when you installed the system to your disk, otherwise you would have got a grub prompt if you couldn't boot into your newly installed system.

Try re-installing.
Ok, after reading all this, and running out of unflattering things to say to my computer, I will re-install and specifically look for any prompts for grub.
There are, I don't know, maybe five, options for the install. Some with GUI, some without, some that imply "expert." Any suggestion as to which install mode I should select?

Hazel wrote: PS: I don't know whether to be annoyed or flattered that the government apparently thinks my little website is dangerous for civil servants to browse. But I hope you'll explore it from your home machine.

I did, nice site. Disagree on a few items but mostly agree with your perspectives. I suggest that the blockage is neither annoying nor flattering. It is just a blanket indifference for sites that have not been categorized. I do have sympathy for government systems as they are a huge target for anyone looking to "check it out" with benign or malignant intent. If you or any other reader might have any interest look up Blue Coat Review Site and Blue Coat Site Review Process.

Last edited by bkelly; 04-19-2018 at 06:14 PM.
 
Old 04-20-2018, 01:00 AM   #11
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 7,769
Blog Entries: 19

Rep: Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523Reputation: 4523
That's hilarious! I went to the Blue Coat site and found a link to sitereview.bluecoat.com. When I clicked on it, it took me to a Symantec site where I was invited to enter an address. So I entered my web address and it said "This URL is categorised as a security risk". And I always thought that Symantec were a reliable firm.
 
Old 04-28-2018, 11:17 PM   #12
bkelly
Member
 
Registered: Jan 2008
Distribution: Centos 7-4
Posts: 205

Original Poster
Rep: Reputation: 13
To resume this thread:
I did a re-install. As GRUB was hot on my mind I saw it and installed. But I am having the same type of problem. I cannot shut down the computer. When I try using sudo it tells me I am not in the list.

Ok, have it your way! Log out and log back in with root.

It will not let me in. I used exactly the same password as my regular account. Yeah I should not, but I did anyway. Now I can clearly state that I have the password right and it will not grant me access.

I picked Debian 'cause I read about its reliability and just do not believe that most or even many users have this problem.

Now that this is the end of the day, and I am rather ticked off at this system, along with being frustrated, and it won't let me shut down, so,..., I will yank the power cord, give it the finger, and say: When I say shutdown, you WILL shut down!!! One way or another, this is one battle I will always win!!!!

Will someone please help me make this process a bit more graceful?

Last edited by bkelly; 04-28-2018 at 11:18 PM.
 
Old 04-29-2018, 02:36 AM   #13
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,524

Rep: Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015Reputation: 1015
I don't think Debian allows the same PW for the user and root. This probably disables the root PW, making the system unusable. Try installing with different user and root passwords.
 
Old 04-29-2018, 08:01 AM   #14
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: Slackware, Ubuntu, PCLinux,
Posts: 10,660

Rep: Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526Reputation: 2526
Quote:
I don't think Debian allows the same PW for the user and root.
That might be the problem. I"m not a Debian user but my past experience when I last used and installed it, the installation usb required 'sudo' to run system commands. After installing I expected the same but sudo was not configured and a root password was needed.
 
Old 04-29-2018, 04:31 PM   #15
bkelly
Member
 
Registered: Jan 2008
Distribution: Centos 7-4
Posts: 205

Original Poster
Rep: Reputation: 13
Quote:
Originally Posted by AwesomeMachine View Post
I don't think Debian allows the same PW for the user and root. This probably disables the root PW, making the system unusable. Try installing with different user and root passwords.
That is a significant problem on two counts. Where do the implementers get standing to simply declare that using the same password for both is not allowed? Its MY computer, not theirs!

And more important: It is really bad practice to change my password, or disallow it, and not give me a prompt as to what just happened. That is really crummy!!!

Back to the real world. I did a reboot, held down the shift key, got the option to boot into recovery mode, and there was a prompt to enter the root password or press control D. Note that the screen displayed upper case letter D. (Note also that there were several lines of something displayed after the line soliciting the control D. When the user is prompted for an input, it is rather bad practice to obscure it with a few more lines on the screen then wait for an input.) Note also that my keyboard will not turn on the caps lock light. So went through that several times and used shift-ctl-D a couple of times. Everytime it ignores that input and boots into the regular mode, jumping out of the rescue mode. I cannot get into the mode to change that password.

I have installed twice now and still not working. And I notice that GCC is not installed. Since I don't have root, I cannot fix that.

Enough of this crap. I am now looking for a download for Centos, the one we are using at work, but there is talk of leaving it and going to something else, as yet unspecified.

Last edited by bkelly; 04-29-2018 at 04:34 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Debian squeeze does not boot - grub restart loop - 64bit proc [Solution] O(V)eGA_l2el) Debian 1 10-08-2011 06:10 PM
Cant boot from Ubuntu live CD, no grub prompt cuco Linux - Laptop and Netbook 1 08-27-2007 07:57 AM
boot live cd or dvd with grub sharky Linux - Software 5 04-05-2005 02:23 PM
Ubuntu Warty Live CD grub error 21 on boot PBSchmidt Linux - Distributions 2 01-24-2005 11:20 AM
boot multiple Live CD distro's with grub bob_man_uk Linux - General 1 02-10-2004 09:54 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration