LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2005, 11:04 AM   #1
moonmoth
Member
 
Registered: Nov 2004
Location: Tallahassee, FL
Distribution: Fedora Core 15
Posts: 95

Rep: Reputation: 17
cannot resolve name


I run Windows XP and Redhat 10.0 Linux on the same machine. For a long time now I have only had internet access with the Windows part, because the computer has a winmodem and couldn't get on the internet with Linux. But at long last I have gotten a comcast high-speed internet connection, with a cable modem. I bought a router, and the computer connects to the router through the ethernet port (the router, of course, connects to the cable modem). So now I have three machines which connect to the internet through the router, all with Windows XP. So far, so good. But now I want to be able to sometimes boot up Linux on this machine and connect it to the internet also. I booted Linux up and started up the Internet Configuration Wizard, clicked on Ethernet Connection and clicked on forward, selected eth0 and forward, selected "automatically obtain IP address settings with DHCP" and forward, and then it said that eth0 was active.

This is the point where I had to quit, because I don't know what to put in for the DNS information (which I assume I have to do). Under Windows XP, which set everything up automatically (when I ran the setup program which came with the router), running ipconfig shows the following information:

Connection-specific DNS suffix: micske01.fl.comcast.net
IP address: 192.168.1.102
Subnet mask: 255.255.255.0
Default gateway: 192.168.1.1

How does this relate to setting the DNS information for Linux??

Thanks for any help,
John
 
Old 07-15-2005, 11:11 AM   #2
cuiq
Member
 
Registered: Aug 2004
Location: Philly
Distribution: Debian Lenny, FreeBSD
Posts: 577

Rep: Reputation: 30
DHCP should handle all of that for you. You MAY only have to enter an gateway address.
 
Old 07-15-2005, 02:40 PM   #3
cyber-worx
Member
 
Registered: May 2004
Location: England / Switzerland
Distribution: Gentoo, Ubuntu, Debian, Slackware
Posts: 138

Rep: Reputation: 15
Ususally you wouldnt even need to enter a gateway address as the router will reply to a DHCP Broadcast request.

Typical dhcp clients are:
dhcpcd
or
pump

see if you have either on your system, (just type in the name and see what happens) if you do then run it as root and you will most likely get web access.

if you get into trouble with the program then just use the man pages.

cheers
-Rob

ps i think redhat ships with pump, but im not sure
 
Old 07-15-2005, 03:02 PM   #4
moonmoth
Member
 
Registered: Nov 2004
Location: Tallahassee, FL
Distribution: Fedora Core 15
Posts: 95

Original Poster
Rep: Reputation: 17
I don't appear to have either of those programs (dhcpcd or pump). I've played around a bit more and modified the question, and then posted it to the network forum. I'm sure there is just some stupid thing that I am not doing. :-)
 
Old 07-15-2005, 03:14 PM   #5
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Can you post your configuration on linux:
ifconfig
route -n

Also, there is no RedHat 10 so which distro are you actually using?
 
Old 07-15-2005, 03:47 PM   #6
moonmoth
Member
 
Registered: Nov 2004
Location: Tallahassee, FL
Distribution: Fedora Core 15
Posts: 95

Original Poster
Rep: Reputation: 17
Gosh, the CD says Version 10 (Liberty) but the doc manual says Redhat 9. So I guess it must be RH 9, huh?? Sorry. My mistake.

ifconfig produces:

eth0 link encap: ethernet hwadd 00.01.02.5F.CE.7A
inet address: 192.168.0.43 bcast 192.168.0.255 mask 255.255.255.0
(lots of RX and TX errors - not listed)

lo Link encap: local loopback
inet addr: 127.0.0.1 Mask 255.0.0.0
(lots of RX and TX errors - not listed)

route -n produced

192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 etho
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 etho
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 0 lo

(I left off the headings of the columns)
 
Old 07-15-2005, 03:55 PM   #7
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
It looks like you haven't picked up an address by dhcp. Do you have a dhcp server on your network or built into the router?

su to root with "su -" then try running "dhclient eth0".
 
Old 07-15-2005, 04:13 PM   #8
anandj
Member
 
Registered: May 2004
Distribution: Fedora Core 4
Posts: 92

Rep: Reputation: 15
Actually the problem is that dhcp is not set to be automatic.
How did u setup the internet connection?

Its been a while since I used RH9. But I do remember they had a nice windows based network configuration tool. If thats what u used, then make sure you set the DNS setting to be 'automatic' instead of specifying any number by hand.
 
Old 07-15-2005, 04:32 PM   #9
moonmoth
Member
 
Registered: Nov 2004
Location: Tallahassee, FL
Distribution: Fedora Core 15
Posts: 95

Original Poster
Rep: Reputation: 17
OK, running "dhclient eth0" did the trick. All works fine now. Thanks much. Linux Questions comes through like a champ again!!

John
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
not able to resolve name mihunt Linux - Networking 3 09-29-2005 02:58 AM
Cannot resolve name uniko Linux - Networking 2 01-04-2005 06:08 AM
how to resolve this error? sensovision Linux - Software 3 07-07-2004 03:42 AM
how do i resolve this??? Lleb_KCir Linux - General 3 03-23-2004 03:10 PM
Can not resolve RH 9 oreng Linux - Networking 1 07-23-2003 07:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration