-   Linux - Newbie (
-   -   Cannot replace unbuntu 12.04 with Mint 14 ( 02-15-2013 06:41 AM

Cannot replace unbuntu 12.04 with Mint 14
Further to my original message below, when I switched my laptop back on this afternoon I discovered that I had removed somehow the Ubuntu operating system - I only had a blank screen. I ran the cd and Mint installed without problem.


I am struggling to remove Ubuntu 12.04 and replace it with Mint 14 and would appreciate some help.

Although I have been using Linux for 5 years I have no knowlege of commands to use in the terminal – I simply copy and paste suggestions from the Forum when I have a probem.


I have a 5 year old Dell laptop which shipped with Ubuntu (I think Hardy) and over the years I have installed the upgrades.

I have noticed recently when I install the updates that I get error messages:
Sorry Ubuntu 12.04 has experienced an internal error
Not all updates can be installed

The dropdown list of internal errors is huge (ApportVersion, Architecture, Date, Dependencies....)

I am also getting a message telling me to free up space as there is only 1.5GB left. I have emptied the trash but it does not make any difference.

Realising that my laptop may suddenly die, I removed all my photos, music and documents and put them onto a USB stick. There is nothing left on my laptop that I need.

In addition, I have an Acer Aspire One which I bought in 2009 with Linpus Lite – it has not been used for ages as the screen is too small for my permanent use. The software version of Firefox was out of date so I searched on the forum how to update it and spotted that someone had replaced Linpus Lite with Linux Mint 14. I followed the instructions and downloaded the ISO onto a memory stick and installed it on the Acer Aspire. It installed easily and works fine. So I now have a temporary laptop if my dies.

I was going to keep using my laptop (error messages and all) until it stopped working. However, it occured to me that if I removed Ubuntu 12.04 and installed Mint and started with a fresh slate so to speak, the problem of lack of space and the problem with the updates would be resolved and perhaps my laptop would limp along for a bit longer.

Problem installing Mint:
I have tried to use the USB to install Mint on my Dell laptop.
I tried to install from the USB but when I got to the installation type menu the only device listed for the boot loader was the 8GB USB.

I burnt the ISO onto a disk.

I began the install, I got to the partition menu and I had the following listed -

/dev/sda6 ext 4 34998MB used 10916MB
/dev/sda7 ext 4 41718MB used 32503MB
/dev/sda5 swap 3306MB 0MB

Your installation medium is on dev/sda6

Device for boot loader installation:
/dev/sda ATA FUJITSU MHY20803 (80.0GB)

I then got an error message saying 'No Root System is Defined'.

I searched on the Forum and found that I needed to select root as the mount point. I followed the instructions by highlighting a partition then clicking 'change'. I had to change 'Do not use this partition' to another option in order to follow the next instruction which was to click the down arrow to the right of the mount point and select the root symbol (/).

I have tried selecting dev/sda6 and dev/sda7 and a variety of the options after de-selecting 'Do not use this partition' and some allow me to get past this point others do not.

When I do get past this point and click 'install' I then get a further message saying that the cdrom needs to be unmounted in order to continue.

I cannot get past this point. If I am using the USB there is no cdrom to un-mount but I still get the error message.

This morning I noticed that there is an option Start Mint in the boot menu this time without the USB or the CD in the drive. I tried to install and I get to the same point saying that the cd needs to be unmounted. According to the command unmount/Volume/cdrom there is no cd to unmount.

To be honest I have copied and pasted so many things that I have no idea what I have or have not done.

I would be happy with any version of Linux on my Dell Laptop, if Mint is not an option.

kareempharmacist 02-23-2013 01:58 AM

command line skills are essential to using Linux
and also understanding the Linux filesystem..this was your problem since -in my opinion- no one complained about installing mint especially if he had nothing to lose on his hard disk after backup .I suggest you begin to read about the command line just in case you faced another problem. There are two types of books about Linux :free open source books and proprietary books. I can can help you in this process.If you are interested post here.we may begin with the Linux filesystem you may read and post your question here.Will be glad to read your posts.. 02-23-2013 01:00 PM

Thank you for your kind offer and yes, I agree that command line skills are essential to using Linux.

It would be very much appreciated if you could recommend some good books.

kareempharmacist 02-24-2013 01:20 AM

The Linux Command Line: A Complete Introduction

linux-newbie-8/confused-from-where-to-start 02-24-2013 09:33 AM

I have ordered the book. I think that it will be easier to work my way through a book and I will be able to annotate it with notes.

Thank you.

kareempharmacist 06-30-2013 11:16 AM

what is up ? what did u accomplish until now lol?

All times are GMT -5. The time now is 03:41 AM.