LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cannot read windows disk when booting from usb key (https://www.linuxquestions.org/questions/linux-newbie-8/cannot-read-windows-disk-when-booting-from-usb-key-4175597607/)

bruno labonté 01-16-2017 08:36 PM

Cannot read windows disk when booting from usb key
 
Hi,

Using rufus I created a bootable usb key with an iso image from linux Ubuntu 14.04.
I booted with the key with success but the Windows hard disk is not accesible.
The disk icon appears in the laucher but when I click on it Nothing happens.
My secondary disk with only data is accessible and my dvd as well.
Any help is appreciated.

Thank you

Bruno

jpollard 01-16-2017 08:45 PM

Possibly you are missing the appropriate filesystem kernel modules.

fat/fuse, and the ntfs-ng tools.

stanvan 01-16-2017 09:35 PM

First off, I'd recommend Ubuntu 16.04 instead of 14.04. Maybe you just mis-typed? Newer is usually better unless you have some limitation that needs an older version.

If you're using Windows 8, 8.1, or 10, it's possible that you're not able to access the Windows partition because it is in hibernation, although I think an error is usually presented. Windows can be left in hibernation if you choose Shutdown in Windows before booting your USB key. To rule this out, run Windows again, insert your Ubuntu USB key, and then choose Restart instead of Shutdown.

If this turns out to be the problem and you want a more permanent solution, check this out.

bruno labonté 01-16-2017 10:52 PM

Let me give some precisions:

My primary hard disk contains 3 partitions, the Windows loader 500mb partition, the Windows 10 partition and an ext4 partition with linux Ubuntu 14.04 on it.

The loader partition and the Ubuntu parttion are accessible but only the Windows 10 partition is not accessible.

I also tryed to boot from my Ubuntu usb key on an XP computer and the system partition is accessible

TheEzekielProject 01-16-2017 11:05 PM

It would be great if you responded concerning advice that's already been given to you. I have a feeling your answer is in post #2

bruno labonté 01-17-2017 04:31 AM

I tryed post 2,

I restarted my computer from Windows 10 and booted with my usb key, the Windows 10 partition is still unaccessible...

fatmac 01-17-2017 05:09 AM

Try to determine which file system your MS Windows installation is using, then check that you have the necessary supporting file system software on your Ubuntu system.

This command from Linux should show you.
Code:

sudo fdisk -l /dev/sda

bruno labonté 01-17-2017 08:00 AM

Thanks for the quick and numerous replys,

Here is the results of fdisk -l


Device Boot Start End Blocks Id System
/dev/sda1 * 63 1156679 578308+ 7 HPFS/NTFS/exFAT
/dev/sda2 1156680 358018694 178431007+ 7 HPFS/NTFS/exFAT
/dev/sda3 358019072 358938623 459776 27 Hidden NTFS WinRE
/dev/sda4 358940670 586072063 113565697 5 Extended
/dev/sda5 358940672 554252287 97655808 83 Linux
/dev/sda6 554254336 586072063 15908864 82 Linux swap / Solaris
ubuntu@ubuntu:~

I think sda2 is my Windows partition, is it the right file system for Ubuntu 14.04?
(I am not knowledgable enough in linux for knowing)

TheEzekielProject 01-17-2017 11:48 AM

Have you tried mounting the partition via terminal?

yancek 01-17-2017 12:07 PM

Quote:

My primary hard disk contains 3 partitions, the Windows loader 500mb partition, the Windows 10 partition and an ext4 partition with linux Ubuntu 14.04 on it.
Yet your fdisk output shows three windows partitions, a Linux partition and a swap partition. The windows partition are probably a boot partition, a system partition and the Recovery partition. You also have an Extended partition with two logical partitions including the Ubuntu and swap. You mention a 'primary hard disk' but the fdisk output only shows one hard drive?

Quote:

I think sda2 is my Windows partition, is it the right file system for Ubuntu 14.04?
I'm not sure what you mean by that. It's the right filesystem for windows.

I'm not sure why you are trying to boot the iso when you have Ubuntu installed. Can you not boot the installed Ubuntu? If you don't have the correct software mentioned in post 2, you could easily install it on Ubuntu. Maybe if you explained why you are trying to do this and what you want to accomplish someone would have a suggestion.

Downlaoding and running the bootinfoscript or boot repair and posting the output would give more details. Boot repair link is below and if you use it, select the option to Create BootInfo Summary and post a link here.

https://help.ubuntu.com/community/Boot-Repair

Brains 01-17-2017 01:49 PM

Windows 8 10 default to never actually shutting down, they go into hibernation so upon boot up they come up faster. Because my Windows 10 is on a SSD, to get the best lifespan from a SSD you should set the OS to minimize the amount of writes to the drive. So, in settings you can set it to actually shutdown when you choose to shut it down. Since I have newer SSD through PCIe bus, that did not slow down Windows ability to come up fast by much, maybe 2 or 3 seconds longer.

I just tried mounting my Windows 10 partition and needed to enter root password and I have access.

Also, Windows can be set to encrypt drives. If it is encrypted, this can pose a problem when trying to auto mount.

Brains 01-17-2017 02:43 PM

Also, in Windows 10 settings, you can set it to have default save directories in the data partition, again, this reduces the amount of writes to the SSD in my case. One click of the mouse and your user name appears in the data drive, in that folder are the other folders, such as: Documents, My Music, My Pictures, etc.

So, with one click of the mouse in Windows 10 settings, you won't need to mount the OS partition or drive.

bruno labonté 01-17-2017 04:13 PM

I understand the confusion,

what i'm trying to do is create a
boot key so that I can recuperate data on systems that are corrupted with viruses and won't boot anymore.
I encountered a problem with a pc that wouldn't boot in Windows because it was heavily infected
and then
my friend booted with a linux key and the data was recuperable.

I just wanted to create a boot key to do the same as my friend.

So, from the posts it seems that my problem is a hibernated system, anyone could tell me how to shutdown out of hibernation?
I tryed shutting down holding the shift key but I don't know if my system is out of hibernation.

Thanks to all for your'e patience... I am Learning still.

stanvan 01-17-2017 04:40 PM

In post #6 you said that you "restarted" your computer with the USB key. If in fact, you did restart, then hibernation is not your problem. Hibernation happens when you do a full "shutdown" from Windows 10.

If not careful, recovering files from virus-infected computer may bring the virus with it (although not really a danger to Linux). If this is your goal, you might Google for "bootable anti-virus usb" where there are many products to help Windows users with this trouble.

Peverel 01-17-2017 04:46 PM

I just checked that I can access a Windows 10 disk from Linux (Opensuse 13.2). Before recent updates (to both Windows and Opensuse), such an attempt failed with *disk busy* or some such error message. Maybe your software needs updating. For the record, I am currently running Linux from a memory stick with legacy boot: Windows is protected boot.


All times are GMT -5. The time now is 06:01 AM.