Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-25-2012, 12:00 PM   #1
LQ Newbie
Registered: Jul 2012
Posts: 17

Rep: Reputation: Disabled
cannot open port "default": Inappropriate ioctl for device

How does one resolve this ?
Old 07-26-2012, 06:39 AM   #2
Registered: Dec 2008
Location: Atlanta, GA, USA
Distribution: Ubuntu
Posts: 135

Rep: Reputation: 26
Please explain in details about the issue you are seeing.
Old 07-26-2012, 08:54 AM   #3
LQ Newbie
Registered: Jul 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
tc@box:~$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0x90320000 irq 46

tc@box:~$ cat /proc/asound/devices
1: : sequencer
2: [ 0- 1]: digital audio playback
3: [ 0- 0]: digital audio playback
4: [ 0- 0]: digital audio capture
5: [ 0- 2]: hardware dependent
6: [ 0] : control
33: : timer

tc@box:~$ cat /proc/asound/seq/clients
Client info
cur clients : 3
peak clients : 3
max clients : 192

Client 0 : "System" [Kernel]
Port 0 : "Timer" (Rwe-)
Port 1 : "Announce" (R-e-)
Connecting To: 15:0
Client 14 : "Midi Through" [Kernel]
Port 0 : "Midi Through Port-0" (RWe-)
Client 15 : "OSS sequencer" [Kernel]
Port 0 : "Receiver" (-we-)
Connected From: 0:1

tc@box:~$ # seems hooked up ?

tc@box:~$ amidi -S "90 3C 7F"
cannot open port "default": Inappropriate ioctl for device
Old 07-26-2012, 09:47 AM   #4
Registered: Mar 2012
Distribution: Scientific Linux
Posts: 147

Rep: Reputation: 36
I really don't know anything about this, but docs say default port is set in the configs and -p can be used to feed a port in.

-p, --port=name
Sets the name of the ALSA RawMIDI port to use. If this is not
specified, amidi uses the default port defined in the configura‐
tion file (the default for this is port 0 on card 0, which may
not exist).
amidi -p hw:0 -s my_settings.syx
will send the MIDI commands in my_settings.syx to port hw:0.

amidi -S F0 43 10 4C 00 00 7E 00 F7
sends an XG Reset to the default port.

amidi -p hw:1,2 -S F0411042110C000000000074F7 -r dump.syx -t 1
sends a “Parameter Dump Request” to a GS device, saves the
received parameter data to the file dump.syx, and stops after
the device has finished sending data (when no data has been
received for one second).

amidi -p virtual -d
creates a virtual RawMIDI port and prints all data sent to this

pulled these off of


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Perl error with "Inappropriate ioctl for device" bnutting Programming 9 03-12-2012 08:25 AM
"Inappropriate ioctl for device" on loopback after rebuild mk27 Linux - Kernel 2 12-02-2009 07:11 PM
chat and "inappropriate ioctl for device" MattFunke Linux - Software 3 01-29-2007 11:25 PM
kismet "channel get ioctl such device" fatblueduck Linux - Software 0 01-03-2006 02:51 AM
Getting error: "ALSA device "default" is already in use by another program." brynjarh Debian 7 02-04-2005 12:45 PM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 04:26 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration