-   Linux - Newbie (
-   -   Cannot mount remote filesystem. Error "Unable to find suitable address" (

alankenyon55 01-08-2012 03:11 PM

Cannot mount remote filesystem. Error "Unable to find suitable address"
I have a Linux box, running Fedora 16 and am trying to mount the C: drive from my Win XP box. I seem to have done everything by the book, but have obviously missed something. I have run out of ideas.

My Linux and XP boxes are connected to my home router, and can ping each other OK.
I have made my C: drive sharable.

I used the following command (and variations on it):

# mount -t cifs -o user=root,password=<mypassword>,rw // /mnt/Windows-C

and the error I get is: "Unable to find suitable address."

I have this entry in my /etc/fstab:
// /mnt/Windows-C cifs -o rw,guest,uid=1000,iocharset=utf8,codepage=unicode,unicode 0 0

What services should I be checking for? What else can I try?

Any help would be much appreciated. Thanks in advance.

T3RM1NVT0R 01-08-2012 03:17 PM

@ Reply
Hi alankenyon55

The command should read as follows:


mount -t cifs // /mnt/Windows-C -o user=name_of_windows_user_account
Where :

// is the remote share. Remember I am assuming that you have shared C drive with the share name C. If you have shared it with some other name then use that name.

/mnt/Windows-C is your local linux mount point

-o user=name of the windows user account. The user account that is there on your Windows XP box which has right to access C drive.

When you will hit enter it will ask you for the password for the windows user account. Enter the password and it should work. I hope your Fedora system is configured to be part of the same workgroup as that of your Windows system. If not then please paste the smb.conf file of your Fedora system here in this thread.

alankenyon55 01-08-2012 03:34 PM

Thanks for the quick reply.

I wasn't sure about the user/password. I had actually started with the Windows user/psw but with the same results.

I have checked the XP workgroup, which is "WORKGROUP". Here is a cutdown copy of my smb.conf.

#======================= Global Settings =====================================

workgroup = WORKGROUP
server string = Samba Server Version %v

; netbios name = MYSERVER

interfaces = lo eth0
hosts allow = 127. 192.168.2.

#============================ Share Definitions ==============================

comment = Home Directories
browseable = no
writable = yes
; valid users = %S
; valid users = MYDOMAIN\%S

comment = All Printers
path = /var/spool/samba
browseable = no
; guest ok = no
; writable = No
printable = yes
comment = Fedora-home
path = /home
; read only = yes
; browseable = yes
guest ok = yes

comment = for updating remotely
path = /home/alan/samba-writable
read only = no
browseable = no
guest ok = yes

T3RM1NVT0R 01-08-2012 03:41 PM

@ Reply
You're welcome.

Did you try the command that I mentioned. If yes, what was the result?

If it failed then try the same command again and paste the output of the following command:


tail /var/log/messages
Paste any error message that you see on your terminal after typing the command.

alankenyon55 01-10-2012 04:11 PM

Yes, I tried that command.
[root@fedora-1 ~]# mount -t cifs // /mnt/Windows-C -o user=owner

messages log tail as follows:

[root@fedora-1 ~]# tail /var/log/messages
Jan 10 20:52:44 fedora-1 systemd[1]: Failed to read PID file /run/ after start. The service might be broken.
Jan 10 20:52:44 fedora-1 systemd[1]: Startup finished in 1s 463ms 945us (kernel) + 2s 548ms 947us (initrd) + 2min 17s 227ms 892us (userspace) = 2min 21s 240ms 784us.
Jan 10 20:53:27 fedora-1 chronyd[841]: Selected source
Jan 10 20:56:22 fedora-1 kernel: [ 358.690185] TCP lp registered
Jan 10 20:57:13 fedora-1 kernel: [ 410.415053] CIFS VFS: Error connecting to socket. Aborting operation
Jan 10 20:57:13 fedora-1 kernel: [ 410.415123] CIFS VFS: cifs_mount failed w/return code = -111
Jan 10 20:59:56 fedora-1 chronyd[841]: Selected source
Jan 10 21:01:01 fedora-1 systemd-logind[814]: New user root logged in.
Jan 10 21:01:01 fedora-1 systemd-logind[814]: New session 3 of user root.
Jan 10 21:01:01 fedora-1 systemd-logind[814]: Removed session 3.
[root@fedora-1 ~]#

This doesn't mean much to me, and I couldn't find any reference to code= -111 in a google search.


T3RM1NVT0R 01-10-2012 05:04 PM

@ Reply


Are you sure your smb and nmb services are running. Check the status using the following command:


service smb status


service nmb status
If they are showing as stopped then start both of them using the following command:


service smb start


service nmb start
I would also like to know selinux status. Check your selinux status using the following command:


If sestatus output show as enabled and running in targeted mode then run the following command to check the booleans:


getsebool -a | egrep '(smb)|(nmb)|(winbind)|(samba)'
and look for the following booleans:

samba_export_all_ro --> off
samba_export_all_rw --> off

If they show as off then turn them on using the following command:


setsebool -P samba_export_all_ro on
setsebool -P samba_export_all_rw on

Give the above command sometime to execute do not cancel them using ctrl+z because setting up booleans on/off take sometime.

Once done restart smb and nmb service once again and then give it a try.

michaelk 01-10-2012 07:35 PM

FYI The server i.e. smbd and nmbd are independent of the client i.e. smbmount which is called by mount when using the cifs filesystem type.

In addition are you sure is the correct IP address for your windows computer?

The console command smbtree will find all computers running SMB on your LAN and display their shares.

T3RM1NVT0R 01-11-2012 12:59 AM

@ Reply
@ alankenyon55

Please ignore the stuff posted in my previous post. After posting I realized you are mounting via Windows server. Sorry was posting in another thread at the same time and thought you to be using samba on a linux server.

As this you have got shared configured on Windows machine you do not require to check selinux boolean stuff. This stuff is required when you are hosting samba share on a linux machine.

However, as michaelk said we need to check if is the IP address of your Widnows machine. Check if you are able to telnet Windows machine from linux machine on port 139 or not. Run the smbtree command as suggested my michaelk.

Another thing that you could try is specifying the workgroup in the mount command. The reason I am saying because it is required with some distributions like SuSE.

alankenyon55 01-14-2012 01:30 PM

The IP address certainly was, but today it is!

smb and nmb services were not running. Now smb is running, but nmb will not start:

[root@fedora-1 ~]# service nmb start
Redirecting to /bin/systemctl start nmb.service

[root@fedora-1 ~]# service nmb status
Redirecting to /bin/systemctl status nmb.service
nmb.service - Samba NMB Daemon
Loaded: loaded (/lib/systemd/system/nmb.service; disabled)
Active: failed since Sat, 14 Jan 2012 17:51:35 +0000; 8s ago
Process: 1902 ExecStart=/usr/sbin/nmbd $NMBDOPTIONS (code=exited, status=0/SUCCESS)
Main PID: 1903 (code=exited, status=1/FAILURE)
CGroup: name=systemd:/system/nmb.service

smbtree failed to find anything. I'm sure I don't need to start anything on my XP box - or do I?

the mount command now gives the following, and I am just investigating it:

# mount -t cifs -o user=root,rw // /mnt/Windows-C
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

T3RM1NVT0R 01-14-2012 01:41 PM

@ Reply
What is the name of the share on Windows. I doubt you shared it with the default name C. When you did smbtree did you not find Windows system and the device you shared?

As I can see in the command you are using user=root. As I mentioned before you need to mention the user name and the password of Windows user. Make sure that the user account that you are using with the mount command have access to the share.

Were you able to telnet Windows machine on port 139 from your linux machine?

Try the following command and see if it works:


mount -t cifs // /mnt/Windows-C -o user=administrator
If you could share the screenshot of how you have shared the directory from Windows it will nice.

alankenyon55 01-15-2012 11:55 AM

Oh dear! yes, you're right, I was entering ROOT again.

It's working now. My next task is to connect to my remote printer, which I don't expect to be simple, so lookout for a new thread!

Thanks very much for all your help.


T3RM1NVT0R 01-15-2012 01:57 PM

@ Reply
You're welcome. Enjoy linux!!!

arpegiator 12-03-2014 12:47 AM

Check Firewall settings
I received the same message when I tried to mount a drive from Linux to a windows server. It was working before and then stopped. I checked and realised that the anti-virus updated and enabled my firewall. After disabling the firewall the mount was working again.

All times are GMT -5. The time now is 03:17 AM.