Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 06-08-2014, 01:15 AM   #1
Registered: Dec 2009
Location: Berlin, Germany
Distribution: Ubuntu 16.10, Fedora 24
Posts: 79

Rep: Reputation: 1
Cannot Mount Logical Volume After Name Change

Hi all,

yesterday I changed the name of my ROOT-partition, a logical volume, as I had omitted the last "t" in its name from von 'LV-ROO' to 'LV-ROOT', but didn't think of updating GRUB. Now GRUB refuses to mount my ROOT-partition, as it can't find one with the old name.

How best to proceed? It won't suffice just to manually change the entry in /boot/grub.cfg via a live system I suppose. This is GRUB2, so if I remember correctly, it works by calling 'external' scripts to build its grub.cfg. Adjusting the initramfs will probably also be needed.

My system (Sabayon Linux) is set up as follows


Encrypted LVM:

ROOT-Partition (Logical Volume)
SWAP-Partition (Logical Volume)
HOME-Partition (Logical Volume)

Thanks a lot for your kind help, I'm sure this can be fixed.
Old 06-08-2014, 09:28 AM   #2
LQ Addict
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,893

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
Try booting a livecd. Then mount the root partition and edit /etc/fstab to change the name of the root partition there (it still has the old name). Then try to reboot.

For further reading on changing the name of a logical volume:
Old 06-09-2014, 02:37 AM   #3
Registered: Dec 2009
Location: Berlin, Germany
Distribution: Ubuntu 16.10, Fedora 24
Posts: 79

Original Poster
Rep: Reputation: 1
Wouldn't it be necessary to update GRUB settings, too?
Old 06-09-2014, 05:04 AM   #4
Senior Member
Registered: Dec 2012
Location: Washington DC area
Distribution: Fedora, CentOS, Slackware
Posts: 4,707

Rep: Reputation: 1270Reputation: 1270Reputation: 1270Reputation: 1270Reputation: 1270Reputation: 1270Reputation: 1270Reputation: 1270Reputation: 1270
For a quickie fix, edit the boot command line and replace the "root=LV-ROO" with "root=LV-ROOT"

It is also possible that the UUID changed and the boot command line has "root=UUID=....". but the edit to replace the "root=" above should work.

Last edited by jpollard; 06-09-2014 at 05:06 AM.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
LVM Mount Physical Volume/Logical Volume without a working Volume Group mpivintis Linux - Newbie 10 01-11-2014 07:02 AM
Persistent mount of a Logical Volume on a iscsi disk hup Red Hat 2 12-19-2012 03:46 PM
mount point of logical volume bilux Linux - Virtualization and Cloud 4 08-11-2011 10:46 AM
How to change the LVM logical volume owner in RHEL 5.3 srithi Linux - Newbie 3 12-31-2009 12:34 PM
external mount of a logical volume cygnus-x1 Linux - General 5 07-27-2006 10:56 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration