LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-14-2003, 02:57 AM   #1
dsuratman
Member
 
Registered: Nov 2003
Location: CA, USA
Distribution: Ubuntu 7.10
Posts: 31

Rep: Reputation: 15
Cannot Mount a Partition, wrong FS type, bad option etc.


Hello I am trying to mount my extended partition, but I got this error message:

root@oc:/# mount -t ext2 /dev/hda5 /mnt/data
mount: wrong fs type, bad option, bad superblock on /dev/hda5,
or too many mounted file systems

What did I do wrong? Below is the list of my partition from fdisk:

Disk /dev/hda: 13.0 GB, 13010264064 bytes
255 heads, 63 sectors/track, 1581 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 365 2931831 83 Linux
/dev/hda2 366 1581 9767520 5 Extended
/dev/hda5 366 851 3903763+ 83 Linux
/dev/hda6 852 1549 5606653+ 83 Linux
/dev/hda7 1550 1581 257008+ 82 Linux swap

what is the maximum number of file systems I can mount?

Thanks
 
Old 11-14-2003, 03:15 AM   #2
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
are you sure that it is ext2 FS??or is it ext3???try
Code:
mount -t ext3 /dev/hda5 /mnt/data
.make sure that there is /mnt/data directory.(just do 'ls /mnt/')
 
Old 11-14-2003, 03:17 AM   #3
arunshivanandan
Member
 
Registered: May 2003
Location: Kerala,India
Distribution: RedHat,Mandrake,Debian
Posts: 643

Rep: Reputation: 30
or this may be due to the fact that /dev/hda5 entry is present in /etc/fstab.check it.if yes just try 'mount /dev/hda5' or 'mount -a'
 
Old 11-14-2003, 06:32 PM   #4
dsuratman
Member
 
Registered: Nov 2003
Location: CA, USA
Distribution: Ubuntu 7.10
Posts: 31

Original Poster
Rep: Reputation: 15
thanks for the response. Yes, I listed the partition in the fstab, but eventhough I use "mount -a" I still get the same error. I guess I did not supply the correct parameters.

What I am going to try now is to delete those partition from fstab, and mount it manually from the command line.
 
Old 11-14-2003, 08:17 PM   #5
jnezezon
LQ Newbie
 
Registered: Oct 2003
Location: Kitchener, Ont.
Distribution: Mandrake
Posts: 11

Rep: Reputation: 0
I have this same exact problem (same error message and everything) I've tryed the manual mounting method with no luck either.

Any other suggestions?
 
Old 11-14-2003, 11:00 PM   #6
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,322

Rep: Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905
Is hda5 the correct partition your trying to mount?
 
Old 11-14-2003, 11:03 PM   #7
jnezezon
LQ Newbie
 
Registered: Oct 2003
Location: Kitchener, Ont.
Distribution: Mandrake
Posts: 11

Rep: Reputation: 0
actually... mine is hda6... so not EXACTLY the same... but does that make that much of a difference? (other then just another number..)
 
Old 11-14-2003, 11:06 PM   #8
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,322

Rep: Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905
Try using auto for the filesystem type. Mandrake usually configures everything during the install. Are you trying to mount a partition thats already mounted?
 
Old 11-14-2003, 11:24 PM   #9
jnezezon
LQ Newbie
 
Registered: Oct 2003
Location: Kitchener, Ont.
Distribution: Mandrake
Posts: 11

Rep: Reputation: 0
The partition was previously mounted, yes... but the problem is that with my experimenting with permissions with samba and winbind, I've rebooted the linux machine since and now it won't automaticly mount this partition anymore.

I really hope this can be fixed seeing as was able to get the samba working at one point and had moved a bunch of valuable data to it... of course.....
 
Old 11-14-2003, 11:58 PM   #10
dsuratman
Member
 
Registered: Nov 2003
Location: CA, USA
Distribution: Ubuntu 7.10
Posts: 31

Original Poster
Rep: Reputation: 15
Yes, I am trying to mount hda5 and hda6 actually. Do you think that my "extended" type is wrong? Should I make it "Linux Extended" instead?

I tried to delete my extended partition and change the type to Linux Extended, but FDISK failed. I guess since my /dev/hda1 is being used for the OS and kernel, it won't let fdisk repartition other partition on the same physical disk?
 
Old 11-15-2003, 08:18 AM   #11
captainstorm
Member
 
Registered: Jun 2003
Location: Oricola, Italy
Distribution: RH 9, so far
Posts: 261

Rep: Reputation: 31
Not know whether it does the job, but I suggest using "fsck.ext2" to check that partition manually and maybe you'll find something.
 
Old 11-15-2003, 11:44 AM   #12
jnezezon
LQ Newbie
 
Registered: Oct 2003
Location: Kitchener, Ont.
Distribution: Mandrake
Posts: 11

Rep: Reputation: 0
tryed the fsck.ext2 and it just says the that partition is clean... nothing else. and of course, the partition is still not mountable.
 
Old 11-16-2003, 02:04 AM   #13
dsuratman
Member
 
Registered: Nov 2003
Location: CA, USA
Distribution: Ubuntu 7.10
Posts: 31

Original Poster
Rep: Reputation: 15
I re-install my slackware from scratch because I thought I did not partition my hard drive correctly, this time I make sure I do it correctly and format those partitions. Guess what, now I can mount those partition with no problem. I believe first time I installed the OS, I did not format the hda5 and hda6.

What is Linux command to format a partition? I know it is not 'format' or 'fmt'.

Thanks
 
Old 11-16-2003, 07:07 AM   #14
michaelk
Moderator
 
Registered: Aug 2002
Posts: 16,322

Rep: Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905Reputation: 1905
See man pages for mkfs, mkreiserfs, mke2fs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: wrong fs type, bad option, bad superblock on /dev/hdc3 Lordandmaker Linux - Hardware 15 06-05-2011 09:55 AM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 06:50 PM
mount: wrong fs type, bad option, bad superblock...(cdrom,dvd and floppy) SpItoS Mandriva 14 11-12-2004 03:27 PM
mount: wrong fs type, bad option, bad superblock on /dev/sdb1 pmoreira Linux - Hardware 5 02-26-2004 11:31 AM
USB 2.0 memory stick mount: wrong fs type, bad option, bad superblock on /dev/sda1, o olivier.riff Linux - Hardware 2 11-12-2003 09:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration