-   Linux - Newbie (
-   -   Cannot install NVidia drivers after kernel upgrade (

MattZ 08-20-2005 08:16 PM

Cannot install NVidia drivers after kernel upgrade

I recently upgraded the kernel to 2.6.2 and I am having a rather dificult time reinstalling Nvidia drivers. I have the source and headers installed for the new kernel and also tried running the installer with the --kernel-source-path option but still a no go. Here is a copy of my log file. Any input greatly appreciated.

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Aug 20 20:26:43 2005

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : true
no questions : false
silent : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : /usr/X11R6
OpenGL install prefix : /usr
compat32 install prefix : (not specified)
installer install prefix: /usr
utility install prefix : /usr
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : /usr/src/kernel-source-2.6.8
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror :
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> You appear to be running in runlevel 1; this may cause problems. For exampl
e: some distributions that use devfs do not run the devfs daemon in runlevel
1, making it difficult for `nvidia-installer` to correctly setup the kernel
module configuration files. It is recommended that you quit installation no
w and switch to runlevel 3 (`telinit 3`) before installing.

Quit installation now? (select 'No' to continue installation) (Answer: No)
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
7667). As part of installing this driver (version: 1.0-7667), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (xxxxxxxxxxxxx)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Using the kernel source path '/usr/src/kernel-source-2.6.8' as specified by
the '--kernel-source-path' commandline option.
-> Kernel source path: '/usr/src/kernel-source-2.6.8'
-> Performing CC test with CC="cc".
ERROR: If you are using a Linux 2.4 kernel, please make sure
you either have configured kernel sources matching your
kernel or the correct set of kernel headers installed
on your system.

If you are using a Linux 2.6 kernel, please make sure
you have configured kernel sources matching your kernel
installed on your system. If you specified a separate
output directory using either the "KBUILD_OUTPUT" or
the "O" KBUILD parameter, make sure to specify this
directory with the SYSOUT environment variable or with
the equivalent nvidia-installer command line option.

Depending on where and how the kernel sources (or the
kernel headers) were installed, you may need to specify
their location with the SYSSRC environment variable or
the equivalent nvidia-installer command line option.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at.

Maestro485 08-20-2005 09:00 PM

Why don't you try switching to runlevel 3 like the installer suggests?

MattZ 08-20-2005 09:12 PM

Good question, but for some reason init 3 doesn't seem to work. The Nvidia installer still tells me that i'm running X, so the olny way was to run in single user mode, init 1. Originally, while using kernel 2.4, i have had the same issue with init 3 but i did manage to successfully install nvidia drivers while init 1.

Maestro485 08-20-2005 09:29 PM

Try booting to the command line rather than booting X then switching the run level. This way you can be sure that X doesn't start, and you are in runlevel 3.

How to do this:

At the grub boot menu, press 'E' to edit the boot parameters (at least I think it's E, but it tells you at the bottom of the screen, so double check).

Now, it will bring up the list of the boot commands. At the end of the line with all the initrd info, simply type: init 3

To boot from here, I think you have to just press B. Once again, the on screen instructions are right there so it shouldn't be a problem.

Then you can just login from the command line and go from there. Hopefully all goes well.

MattZ 08-21-2005 12:12 PM

Ok Maestro, I didexactly what you wrote but i still end up in X (gdm). This is how it looks in grub:

title Debian GNU/Linux, kernel 2.6.8-2-686
root (hd1,0)
kernel /boot/vmlinuz-2.6.8-2-686 root=/dev/sda1 ro acpi=off
initrd /boot/initrd.img-2.6.8-2-686 init 3

I also tried invoking init 3 through the termial again and used runlevel to check.
rogers:/home/matthew# runlevel
2 3

So, according to that, my previous runlevel was 2 and the current one is 3 but I'm still in X session.

Maestro485 08-21-2005 12:40 PM

Ah hell, I told you the wrong line. Put the 'init 3' on the kernel line, not the initrd line. This is what works for me, at least.

Sorry about that. Let me know if it works for you.

tshontikidis 08-21-2005 12:43 PM

I had the same problem and those are all good ways of stoping x, but here is one of the easiest ways i have seen.

after you boot and are in your gui, switch to you terminal the good old ctrl+alt+f1

now go with (as root) init 3

after this even though you are in a command line state your window manager and x come back so then you need to kill xdm or gdm, which ever you use.

/etc/init.d/[x|g|k]dm stop

pick a letter depending on which login manager you use and that worked for me because i had the same problem.

MattZ 08-21-2005 04:15 PM

Wow, what the heck is going on..

Maestro, same results. GDM still loads on startup, even though i'm in runlevel 3

tshontikidis, here's what i get running gdm stop : rogers:/home/matthew# gdm stop
gdm already running. Aborting!

It seems odd, considering i want to shut down gdm, not start it.

tshontikidis 08-22-2005 12:53 AM

try stoping it using the code i provided, /etc/init.d/[x|g|k]dm stop
not just, gdm stop

and after that maybe you should run: killall X

then even if you get the same message check to make sure X is down by ctrl+alt+f7
no login in screen, no X

MattZ 08-23-2005 08:41 PM

Ok, I managed to shut it down with the killall command, but unfortunately I am back to the original problem with nvifia driver. I am still receiving the error message.

corfe 08-23-2005 08:58 PM

I do this all the time with my own compiled kernel, and it just works. Make sure you have a symlink from /usr/src/linux to /usr/src/(your particular linux source folder), and make sure you stop gdm (/etc/init.d/gdm stop as root - if it doesn't work, try starting gdm then stopping it again, sometimes that fixes it). Then just run the installer, answer like you did.

I never even have to switch runlevels.

If the above doesn't seem to solve any problems for you, try this : run the installer with the "--extract-only" command line, cd into the newly created folder for the driver and get into the source directory. There are two different makefiles available to you - cp one to the name "Makefile" in the same folder and try typing "make", see what error you get. If it doesn't work, make clean, then cp the other Makefile to the name "Makefile" and try again.

If one of them does compile, try "make install". I believe that just installs the raw kernel driver and not all the required X libs - but it's a start. See if it works, if it doesn't maybe we can find out what error is going on here.

Also, what version of gcc are you using? Perhaps it doesn't work with gcc 4, or something silly like that. If you want to switch gcc versions, as root do an "rm /usr/bin/gcc" (don't worry, /usr/bin/gcc is just a symlink to a specific version of gcc). Then, "ln -s /usr/bin/gcc-x.x /usr/bin/gcc" to make a new symlink to the version you want to use, where x.x could be something like 3.4, 3.3, 4.0, etc.

Good luck!

By the way, there's a newer version of the nvidia driver out than what you have now (7676). It doesn't seem to fix your problem though.

All times are GMT -5. The time now is 02:09 PM.