-   Linux - Newbie (
-   -   Cannot install fedora core 1 or core 2: Initial setup crashes: "Unable to mount root" (

ovelasco 07-08-2004 11:06 AM

Cannot install fedora core 1 or core 2: Initial setup crashes: "Unable to mount root"
I'm trying to install either fedora core 1 or core 2, but i keep bumping to the same

problem during the initial setup process.

Im using a Pent III, with 128 RAM and a brand new HD (40 GB - IDE).

When I boot the pc with the 1st CD I get the initial setup message. So basically hit

ENTER and then a few lines appear on the screen. After maybe a couple of seconds the

pc freezes. THe last few lines appearing on the screen read like the following:
BLABLABLA.....(a lot of lines with no apparent error messages)

ACPI: (supports S0 S1 S3 S4 S5)
checking if image is isn't (ungzip failed); looks like an initrd
Freeing initrd memory: 2385k freed
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
RAMDISK: Compressed image found at block 0
crc error
VFS: Cannot open root device "<NULL>" or unknown-block(72,3)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(72,3)

Same happends when trying to install fedora core 1.

I've tried doing the same with a different machine (Pent IV, 256 RAM) - even a

different HD... but i keep getting the same message.

After i downloaded the ISO images for fedora core 2 and core 1, i verified that their

md5sum matched and they did. I then proceeded to burn those images to CDs.

Can anyone point my mistake. (It's probably a dumb one... but we're out of ideas down


linuXBOX 07-08-2004 11:12 AM

at boot pass this option to the kernel root=/dev/hda1 where hda1 is the first partition of the first drive of the first ide controller. I believe fedora uses hda as the cdrom drive now, but maybe thats after the install.

ovelasco 07-08-2004 11:19 AM

same error
tried booting : linux root=/dev/hda1
and got basically the same error, but instead of the original lines i get:
FS: Cannot open root device "hda1"or hda1
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on hda1"

the hd is brand new... so basically there are no partitions. Should i partition the hd first? How can i do that?

linuXBOX 07-08-2004 11:25 AM

try hdb1 and hdc1 too...try to cover several bases before moving on.

ovelasco 07-08-2004 12:10 PM

nop... didn't work out
tryied with hdb1 and hdc1 and similar error..

if i use the normal boot sequence (that is.. hit ENTER) one of the lines says:
"hda HT135153135 ATA disk"
"hdc CD ROM blablabla"

so i believe hda is the hard drive...

any other ideas?

scuzzman 07-08-2004 12:15 PM

maybe try /dev/hda as opposed to /dev/hda1

ovelasco 07-08-2004 12:28 PM

nahhh.. still same error
already tried that...

but the lines change....

"crc error
Kernel panic: VFS: Unable to mount root fs on hda "

(it skips two lines )

by the way... i believe the hard drive has no partitions whatsoever. Do i need to create a linux partition first?? Or should the setup process take care of that?

Vlad-A 07-08-2004 12:39 PM

well try following boot options:

ide=nodma acpi=off noapic

How can you mount root from hda when you do *not* have installed Linux ?
Root FS is not there.

Plus CRC errors means that there is a corrupted Block in the media or the transfer (cable)
is not OK!

The initial root filesystem (during install) shall be mounted from the inital RAM disk.
Seems that this one is corrupted.

Partitions will be created during installation procedure. You do not
need to create them.

ovelasco 07-08-2004 01:05 PM

so... what should i do..?
I've tried running:
"linux ide=nodma acpi=off noapic"
but i end up with the same error.

That is my point... why is it asking for a fs if the hard drive is brand new?

I've tried installing the hard drive in a different CPU (that is.. different cables, motherboard, etc etc) and the same error comes out.

I've also tried using a different HD (older one... not new) and the same error appears.

What should I do?? I there a possibility that the CDs are corrupted?? I did a md5sum on all images after download and they were ok. I then proceeded to burn them to CDs.

After failed attempts with core 2 i tried core 1... but a very similar error comes out.

What the hell??

Vlad-A 07-08-2004 02:34 PM

Well you have checked the ISO Images. But you do not know if those were transferred/burned correct to the CD Media. Do you ?
Wenn you boot from CD Fedora let's you to check the media.

You may consider to use a lower write/record speed and higher class CD Media.

ovelasco 07-15-2004 08:19 PM

Apparently, the iso images where burned with errors.

Downloaded ISO images were ok, but they where burned using Nero and a HP cd-writer with an uncompatible firmware with that specific version of Nero. (What are the odds??).

Anyway, thanx everyone.

Im now figuring how to use fc2. Seems fun.

All times are GMT -5. The time now is 02:00 AM.