Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 07-08-2017, 11:02 PM   #1
LQ Newbie
Registered: Mar 2011
Location: New England
Distribution: Slackware
Posts: 19
Blog Entries: 6

Rep: Reputation: 11
Cannot get out of sleep mode

I'm using Slackware 14.2 (kernel 4.4.75, I tried updating to the latest nvidia drivers).

I use KDE, and I haven't used sleep since 14.1, but I just put it in "sleep mode" (suspend to RAM).

What happens is that the graphical login kdm runs, I login, the KDE wheel spins for a second, and then I get no signal on my monitor. But I am able to switch to other terminals with alt+ctrl+F1. The OS itself is fine, I'm online, and processes (like dropbox) which run after logging into KDE are also running.

I am able to use X as root. (Or any other user I would imagine?)

I could not find a process like pm_suspend or some sort of sleep mode to kill. I don't know if perhaps X is being run with an option to disable the video card or turn on sleep mode...

I have attached the tail of a handful of logs from /var/log/

I thought I would just hit the power button to return from sleep but it did not seem to work. Or if it did, it didn't turn video back on...

Thanks in advance
Attached Files
File Type: txt ohboy.txt (47.6 KB, 4 views)
Old 07-09-2017, 11:26 AM   #2
LQ Guru
Registered: Jan 2006
Location: Ireland
Distribution: Slackware, Slarm64 & Android
Posts: 15,436

Rep: Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160Reputation: 2160
I have 14.2, hit the power button, and it comes back. Do your fans start on the power button?

If so, treat it as a video fault.
Old 07-09-2017, 03:18 PM   #3
LQ Newbie
Registered: Mar 2011
Location: New England
Distribution: Slackware
Posts: 19

Original Poster
Blog Entries: 6

Rep: Reputation: 11
I've just cross-posted this in the Slackware forum.

What I've learned from looking at the Xorg logs is that nvidia sets the mode to "Null" after kde starts. I am able to run xfce, and root is able to run KDE just fine (setting mode nvidia-auto-select). But for my main user, when running KDE, I get no signal right after the login.


Edit: I ended up just removing my .kde folder entirely, then it did not crash on my next login.
(Well, I moved it to .kde-OLD, in case I wanted to use any of my previous settings.)

See "Sleep mode permanently turned video off" in the Slackware forum:

Last edited by zapwai; 07-09-2017 at 04:41 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
disable sleep mode, away mode standby, etc. ZiGz Linux - General 4 06-19-2016 01:15 PM
how to disable sleep/hibernate mode in runlevel 3 mode libin88 Linux - General 1 11-23-2008 04:54 AM
Where's sleep mode in RH 8.0? bobterri Linux - Distributions 4 11-26-2002 11:13 PM
Sleep mode mrsolo Linux - Hardware 4 11-26-2002 08:05 PM
sleep mode Linux - General 2 12-29-2001 09:43 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:54 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration