-   Linux - Newbie (
-   -   Cannot eject CD in Slackware 10 (

pcd007 09-29-2004 02:04 PM

Cannot eject CD in Slackware 10
I am using Slackware 10 with kernel 2.4 (default).I have a LG CD writer which is having problems with eject in KDE, i think. It all works well before I start X-server. I can eject CD using "eject" command; even mounted CDs are ejected by simply using "eject". But when I start KDE using startx I can no longer eject the CD but I can still mount and unmount it. Whenever I try to eject the CD I get a KDE eject error "Eject /dev/hdc failed!". Initially I had 2 entries in my fstab one for /dev/hdc and other for /dev/cdrom. I removed one entry as I have only one CD-writer. This is how my fstab looks like:

/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/hda5 /data2 reiserfs defaults 1 2
/dev/hda6 /data1 ext3 defaults 1 2
/dev/hdc /mnt/cdrom iso9660 noauto,users 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

The problem has become more complicated as sometimes I can eject in KDE from the shell using "eject". But if I mount it from Konqueror and then try to eject it from the terminal I get the error "eject: unable to eject, last error: Invalid argument". If I try again after sometime from the terminal(Konsole) using eject will eject the CD, only leaving me wonder more! SOMETIMES EVEN KONQUEROR WILL EJECT THE CD, but only sometimes. I am really clueless about the cause of the problem. :(

I tried Google but I couldn't get much help. Can someone provide me with some hint in the right direction so I can just eject the CD from the KDE, using Konqueror?

Tinkster 09-29-2004 05:44 PM

First things first :)

Which kernel are you using?


pcd007 09-30-2004 07:48 AM

I am using the default kernal provided with Slackware 10 i.e. Ver. 2.4.26
And the KDE version is 3.2.3

Biased turkey 09-30-2004 10:13 AM

First, shouldn't /dev/cdrom be a link pointing to /dev/hdc ?

What I would try first is to remove the autorun for the cdrom ( I think it's in the "start here " directory.
Or maybe you have an application ( maybe konqueror ) accessing your cdrom directory.

JNK 09-30-2004 10:16 AM

Same thing happens to me! I just mount the drive and unmount it again then eject and it seems to free everything up again. Beats me whats causing it though.

pcd007 09-30-2004 02:33 PM


Originally posted by Biased turkey
I think it's in the "start here " directory.

I think "start here" directory is for gnome, I tried " file:/home/UserName/.kde/Autostart/" though but the directory is empty. What bugs me is the inconsistency, sometimes Konquerror will eject the CD other times it won't giving a nice little error "Eject /dev/hdc failed!". I'll look for an application accessing the CDROM but why would an application Lock the unmounted CD-ROM? I've learned that CD-ROMs are locked when mounted, i wonder why that lock is not being removed after unmounting the CD.

I tried mounting and unmounting CD again as suggested by JNK but no luck.

I am still clueless about what is causing this problem.

user_of_slack 10-01-2004 12:08 AM

I wanted to write and convey I too am having this problem. I had 11 disks of data I wanted to transfer to my system and it was a pain in the butt. During initial Slack install, the CD popped out, asked me to insert another disk and there was no problem.

When I wanted to add my data later via CD that is when I had problems. Maybe this is just a general permissions issue?

I changed my fstab file to various configurations based on information I found on this site and the Internet, I rebooted I tried again. I tried many many things.

I logged on as root and logged on as a user.

I could access the CD if the CD is in the drive with any user. Choosing to eject it fails. Most times. Other times, from the terminal, in a KDE enviorment, I could eject it with eject /dev/cdrom

Other times it would fail. SOMETIMES it works. I can mount and then unmount it but usually eject always fails. Here is another aspect. I was having this problem ejecting and then I installed k3b Burner ( Using that program as root, I can eject, burn and load another disk From command prompt, from KDE alone choosing device eject, failure.

I also logged in in terminal only, and other options, not just KDE.

Back to what I was saying about loading the disks... I ended up, most times, logging out, and pushing the cd button, sometimes it would eject, other times it wouldn't so I rebooted, as the system came back up I ejected the disk and put another one in. Then as any user, I could access it via the command line or via KDE. I could copy the disk. But then trying to eject and put another disk in.. No Go. I would reboot and do the same procedure.

It really is the only issue I have. I moved all my data from CD to my system. IF want to burn, k3b works fine so it is not an issue I am that concerned about but it is an annoyance and like others have posted, it is just frustrating not knowing what is the issue.

JNK 10-01-2004 05:03 AM

I seem to be getting consistant results when I unmount twice the second time it says the cd is already unmounted and then I can eject the cd. Can anyone confirm this?

pcd007 10-01-2004 06:12 AM


Originally posted by JNK
I seem to be getting consistant results when I unmount twice the second time it says the cd is already unmounted and then I can eject the cd. Can anyone confirm this?
no luck here; when I try to unmount it twice I get an error "/dev/hdc is not mounted (according to mtab)" but eject would fail."

pcd007 10-01-2004 08:08 AM

Is that Audio CD Browser in the services tab causing the problem? I am gonna find out a way to disable it and then check if I can eject the CD or not. Any suggestions on how to disable the Audio CD Browser?

justin_p 10-01-2004 10:52 AM

if you are using kde, go into the control center and check the boxes to have the unmounted and mounted cdrom icons on the desktop. This is under Control Center under appearance I think (sorry DLG user). It should now be as easy as right click to mount or unmount. You may have to eject by hand.

pcd007 10-02-2004 12:25 AM

Thanks justin_p, the mount and unmount CD-ROM icons on the desktop seem to work.But I think I found a way to eject CDs in Konqueror.

I think the problem was caused by "Audio CD Browser" in the Services tab of the navigation panel. The services tab is the default tab in the konqueror. I made Devices tab my default tab by clicking on it and then by saving the profile, option for saving the profile is under Settings menu. Now every time I start konqueror I get Devices as the default tab and the CD ejects properly.

I tried to verify this by clicking on the services tab and yes, the eject failed!

I think I solved the problem for now. But I am looking for a way to disable Audio CD Browser permanently. Any suggestions on how to do that will be appreciated.

All times are GMT -5. The time now is 02:01 AM.