LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cannot delete existing folders (https://www.linuxquestions.org/questions/linux-newbie-8/cannot-delete-existing-folders-603893/)

yusufs 12-02-2007 06:13 AM

cannot delete existing folders
 
Hai all,

Help me out with the following scenario :


test server : test.com.su
production server : prod.com.su

I mounted a nfs /d05 drive from the test server


etc/fstab from test :
/dev/sda5 /d01 ext3 defaults 0 0
/dev/sda6 /d02 ext3 defaults 0 0
/dev/sda7 /d03 ext3 defaults 0 0
/dev/sdb /d04 ext3 defaults 0 0
/dev/sdc1 /d05 ext3 defaults 0 0


etc/exports from test :

[root@oracle /]# cat /etc/exports

/d03 prod.com.su(rw)
/d02 prod.com.su(rw)
/d05 prod.com.su(rw)


I mounting the drive d05 (test) to production(d08) as follows :

B]etc/fstab from prod :[/B]

test:/d05 /d08 nfs defaults 0 0


command : mount -t nfs test:/d05 /d08
this gets the drive mounted in the prod server as d08 and it works fine.. but the root user in the prod server doesnt have access to delete the files in d05 which was created by the root user in test
root in prod can read , and create any files.. he cannot delete the existing files or write to the exisitng files

I need the root user to write to the existing folder created by the root user in test

is this possible ?.. if so , how ?

please guide

Yusuf

jschiwal 12-02-2007 07:02 AM

I think someone already provided an answer in a similar message you posted. The root user is squashed to user nobody.

You need to add the "no_root_squash" option.

See the manpage for "exports" and "idmap.conf".

You didn't post the permissions of the directories being shared. That is another part of the equation. For example, suppose that the permissions are
rwxrwxrwt. In this case, one user will not be able to delete another users files.
These are the permissions you want for a globally writable share. However, you would want it mounted on a partition with the "noexec" and "nodev" options for security reasons.


All times are GMT -5. The time now is 04:02 PM.