LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cannot connect to the Internet (https://www.linuxquestions.org/questions/linux-newbie-8/cannot-connect-to-the-internet-594863/)

boygenuis 11-03-2007 04:14 PM

Tink,
you are the Man. This is what I get when I type in your command -
root 7167 7123 0 15:57 pts/0 00:00:00 /bin/grep -E (dh|pump)
and when I try to access "http://64.179.4.146" I get the return "www.linuxquestions.org could not be found. Please check the name and try again." What should that tell me?

Tinkster 11-03-2007 04:33 PM

That means that the entire network set-up isn't quite right. :}

For some reason you're getting reverse lookups but not the normal
ones which is quite bizarre.

The output of the grep tells us that all it found is the grep
itself, in other words no dhcp-client I know of is running, that
is no pump, no dhclient, no dhcpcd ... I'd suggest checking out
YaST2's packages and installing one of the those (my personal
preference if you get all of those would be dhcpcd).



Cheers,
Tink

jschiwal 11-03-2007 05:10 PM

You can check with the command "rpm -q dhcpcd" to see if you have the dhcp client installed.

Also, run through the "yast2" setup again. It should have installed the dhcp client for you and opened a port for it in the firewall. Be sure you select "dhcp". The dialogs changed with SuSE10.3. It may in one of the advanced selections on the bottom of the dialog.

You could also manually edit the /etc/sysconfig/dhcp file changing a line:
Code:

## Type:        yesno
## Default:    yes
#
# Should the DHCP client modify /etc/resolv.conf at all?
# If not, set this to "no". (The default is "yes")
#
# resolv.conf will also stay untouched when MODIFY_RESOLV_CONF_DYNAMICALLY
# in /etc/sysconfig/network/config is set to "no".
#
DHCLIENT_MODIFY_RESOLV_CONF="yes"

DHCP needs to be selected for the interface as well:
/etc/sysconfig/ifcfg-wlan0:
Code:

...
BOOTPROTO='dhcp'
...

However doing these through YaST would be easier. YaST will edit them for you. You do have the hardest part accomplished. Your wireless device works!

boygenuis 11-04-2007 06:35 PM

jschiwal,
dude, thanks for the help! When I type the command 'rpm -q dhcpcd' I get the return 'dhcpcd-1.3.22p14-20' Does this mean that I'm running the package dhcpcd? I guess, since when I tried to search for the package from the installation disk there was an icon indicating that it was currently installed. I also tried to edit the sysconfig/dhcp file by 'cd /etc' then 'more /sysconfig/dhcp' but was told 'no such file or directory' What should this tell me? I didn't try your /etc/sysconfig/ifcfg-wlan0 because the other file didn't exist, is that correct?

jschiwal 11-06-2007 01:59 AM

Yes, it is installed.

From your previous post:
Code:

rausb0 Link encap:Ethernet HWaddr 00:0C:41:69:FD:5A
inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0

The wireless device is working. Having both eth0 and rausb0 active at the same time, on the same subnet is not a good idea. Use either one or the other.

Try the command: "cat /etc/resolve.conf". If you get a permission denied error, there is something wrong with the permissions on this file.
Code:

ls -l /etc/resolv.conf
-rw-r--r-- 1 root root 1306 2007-11-05 23:29 /etc/resolv.conf

If you cant read it, a program calling several glibc functions will fail to read it as well. This could be the problem not being able to resolve hostnames.

Also post the contents of /etc/nsswitch.conf. It is the host: line thay you want to check. Does it contain "dns" on the right hand side of the colon?

boygenuis 11-07-2007 06:20 PM

Here's what I got's, yo! for the command cat /etc/resolv.conf I'm told "no such file or directory"
when I type in /etc/nsswitch.conf "permission denied" and when I cd /etc then more /nsswitch.conf "no such file or directory"
did I fuck this up?

Tinkster 11-07-2007 06:49 PM

Only entering the commands ...

You can't run it (/etc/nsswitch.conf) ... and when you cd /etc
and then cat /nsswitch.conf it looks for it in the wrong place
(your systems root file systems rather than in /etc).



Cheers,
Tink


All times are GMT -5. The time now is 12:57 AM.