LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cannot connect to the Internet (https://www.linuxquestions.org/questions/linux-newbie-8/cannot-connect-to-the-internet-594863/)

boygenuis 10-26-2007 02:59 PM

Cannot connect to the Internet
 
I recently loaded SuSE 10.0 on my laptop, which is dual-booting XP, and when I attempt to connect to the Internet via Wireless and LAN, I get the message, "Cannot find page 'www.novell.com'." This also happens when I try to connect to other sites like Google or BlackwaterUSA.com and it only happens on the SuSE partition. I am, to put it gently, computer illiterate and have a strictly rudimentary knowledge of computer terms, so I may have to ask for lots of clarification. One more thing, SuSE reads my wireless adapter, a Linksys WUSB54G ver. 4, and says that the signal strength is good. What step in the installation process did I miss? If there are any other threads that cover this I'd appreciate a link.

Tinkster 10-26-2007 03:33 PM

Check whether the adapter has been assigned an IP address.
Open a terminal, do
ifconfig


If it has chances are that you don't have name resolution working.
In that case you'd need to edit /etc/resolv.conf and add your ISPs
nameserver(s)' ip addresses to it.

If it doesn't someone else will need to look at the wireless set-up ;}
with you because I don't use wireless at all.


Cheers,
Tink

boygenuis 10-26-2007 04:50 PM

Thanks, Tink! I'll give that a whirl and see what happens.

amitabhishek 10-27-2007 05:29 AM

I also faced similar issue in Suse. Goto YaSTand configure network first.Choose static IP config. Put the values such as gateway IP, PC IP,subnet mask etc. and first try to connect to the website of your service provider. Pls keep me posted on this.

boygenuis 10-27-2007 02:49 PM

Quote:

Originally Posted by amitabhishek (Post 2938523)
I also faced similar issue in Suse. Goto YaSTand configure network first.Choose static IP config. Put the values such as gateway IP, PC IP,subnet mask etc. and first try to connect to the website of your service provider. Pls keep me posted on this.

So, I tried that but I still don't get on the Internet. I can get SuSE to read my wireless adapter and also my Ethernet card, which I guess is a step in the right direction, however, when I plug directly into my router via Ethernet cable and also when I'm using my USB Wireless adapter, I get the same message of "The page www.novell.com cannot be found. Please check to make sure you have typed in the correct address." The same still happens with sites like google and yahoo and others. I'm trying to figure out a way to post what shows up when I type "ifconfig" or "iwconfig" in the Terminal. I'll get that here shortly, God willing. Thanks for all the feedback!

icedlightblue 10-27-2007 03:49 PM

is there a network manager in suse 10,if there is,set it to dhcp,save and restart your computer
.see if it works.

boygenuis 10-27-2007 05:22 PM

IcedLightBlue,
I get the same thing when I set it to DHCP. Eh? What can you do, I guess. The following is what my ifconfig and iwconfig commands return:

linux:~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:12:3F:F1:7C:54
inet addr:192.168.2.4 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::212:3fff:fef1:7c54/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1331 errors:0 dropped:0 overruns:0 frame:0
TX packets:1331 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:134212 (131.0 Kb) TX bytes:134212 (131.0 Kb)

rausb0 Link encap:Ethernet HWaddr 00:0C:41:69:FD:5A
inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0
inet6 addr: fe80::20c:41ff:fe69:fd5a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1115680 (1.0 Mb) TX bytes:267570 (261.2 Kb)

linux:~ # iwconfig
lo no wireless extensions.

sit0 no wireless extensions.

eth0 no wireless extensions.

rausb0 RT2500USB WLAN ESSID:"linksys"
Mode:Managed Frequency=2.412 GHz Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality=0/70 Signal level:-79 dBm Noise level:-195 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Can anyone make more sense out of this than I can?

icedlightblue 10-27-2007 06:06 PM

ok, you see on the first paragragh,in the begining where it says inet addr,that's your ip and where it says mask,that's your mask address.You will need them to connect to the internet.But I think if it's detected,it detected your modem and,you can go on the internet.

I had this problem yesterday,what I did was on my xfce 4 desktop I went to the settings manager
and went to network settings,then set my modem to dhcp,saved,restarted my computer and it worked.Man,I was afraid that my grandmother was going to kill me

Tinkster 10-27-2007 06:23 PM

Quote:

Originally Posted by boygenuis (Post 2939137)
IcedLightBlue,
I get the same thing when I set it to DHCP. Eh? What can you do, I guess. The following is what my ifconfig and iwconfig commands return:


Can anyone make more sense out of this than I can?

The ifconfig output looks quite sane.

Did you check /etc/resolv.conf as I suggested in my first
reply? What does it look like? And which dhcp-client is
running on your system?
ps-ef | grep dhcp



Cheers,
Tink

boygenuis 10-29-2007 11:57 AM

IcedLight,
I'm not exactly sure what the xfce4 desktop is. Is that a command that I'm running in the Terminal? I'm glad your Grandmother didn't kill you. I mean, how would I get help otherwise?

Tink,
You are a god among men. Thank you. I'll check those two commands and see what pops out.

boygenuis 10-30-2007 11:10 AM

When I type in the /etc/resolv.conf command, it replies that my permissions are denied. When I type in ps-ef|grep dhcp, I am told that the command "ps-ef" is not found. Does that tell anyone anything? Is there some way to use that Live CD as a repair disk as well?

tedpottel 10-30-2007 11:14 AM

sorry, i wish I had some info to help

Tinkster 10-30-2007 11:30 AM

Quote:

Originally Posted by boygenuis (Post 2942357)
When I type in the /etc/resolv.conf command, it replies that my permissions are denied. When I type in ps-ef|grep dhcp, I am told that the command "ps-ef" is not found. Does that tell anyone anything? Is there some way to use that Live CD as a repair disk as well?


It's not a command - it's a text-file.

cat /etc/resolv.conf

And that's not
ps-ef
it's
ps -ef
with a space in between.


Cheers,
Tink

boygenuis 10-31-2007 12:33 PM

So, I think this is the info you asked me to find.

linux:~ # ps -ef|grep dhcp
root 7506 7477 0 12:05 pts/0 00:00:00 grep dhcp
linux:~ # ps -ef | grep dhcp
root 7518 7477 0 12:05 pts/0 00:00:00 grep dhcp
linux:~ # more /etc/resolv.conf
domain site
linux:~ # find /etc/resolv.cong
find: /etc/resolv.cong: No such file or directory
linux:~ # find /etc/resolv.conf
/etc/resolv.conf

Umm, when I open Firefox I can at least get to my Router's webpage, which I'm taking as a step in the right direction, I'm connected via ethernet cable, and I have my settings on dhcp...oh, and even when I typed in the /etc/resolv.conf in the browser window I get the message "domain site." I thought it meant I could access it via the web, clearly I am mistaken. What wisdom can you impart on me?

Tinkster 10-31-2007 02:34 PM

Ok ... maybe my grep was too restrictive ...

Code:

ps -ef | egrep "(dh|pump)"
Anyway, whichever client you're using - it doesn't update resolv.conf,
which is why you can't browse anything by name.

Try http://64.179.4.146



Cheers,
Tink

boygenuis 11-03-2007 04:14 PM

Tink,
you are the Man. This is what I get when I type in your command -
root 7167 7123 0 15:57 pts/0 00:00:00 /bin/grep -E (dh|pump)
and when I try to access "http://64.179.4.146" I get the return "www.linuxquestions.org could not be found. Please check the name and try again." What should that tell me?

Tinkster 11-03-2007 04:33 PM

That means that the entire network set-up isn't quite right. :}

For some reason you're getting reverse lookups but not the normal
ones which is quite bizarre.

The output of the grep tells us that all it found is the grep
itself, in other words no dhcp-client I know of is running, that
is no pump, no dhclient, no dhcpcd ... I'd suggest checking out
YaST2's packages and installing one of the those (my personal
preference if you get all of those would be dhcpcd).



Cheers,
Tink

jschiwal 11-03-2007 05:10 PM

You can check with the command "rpm -q dhcpcd" to see if you have the dhcp client installed.

Also, run through the "yast2" setup again. It should have installed the dhcp client for you and opened a port for it in the firewall. Be sure you select "dhcp". The dialogs changed with SuSE10.3. It may in one of the advanced selections on the bottom of the dialog.

You could also manually edit the /etc/sysconfig/dhcp file changing a line:
Code:

## Type:        yesno
## Default:    yes
#
# Should the DHCP client modify /etc/resolv.conf at all?
# If not, set this to "no". (The default is "yes")
#
# resolv.conf will also stay untouched when MODIFY_RESOLV_CONF_DYNAMICALLY
# in /etc/sysconfig/network/config is set to "no".
#
DHCLIENT_MODIFY_RESOLV_CONF="yes"

DHCP needs to be selected for the interface as well:
/etc/sysconfig/ifcfg-wlan0:
Code:

...
BOOTPROTO='dhcp'
...

However doing these through YaST would be easier. YaST will edit them for you. You do have the hardest part accomplished. Your wireless device works!

boygenuis 11-04-2007 06:35 PM

jschiwal,
dude, thanks for the help! When I type the command 'rpm -q dhcpcd' I get the return 'dhcpcd-1.3.22p14-20' Does this mean that I'm running the package dhcpcd? I guess, since when I tried to search for the package from the installation disk there was an icon indicating that it was currently installed. I also tried to edit the sysconfig/dhcp file by 'cd /etc' then 'more /sysconfig/dhcp' but was told 'no such file or directory' What should this tell me? I didn't try your /etc/sysconfig/ifcfg-wlan0 because the other file didn't exist, is that correct?

jschiwal 11-06-2007 01:59 AM

Yes, it is installed.

From your previous post:
Code:

rausb0 Link encap:Ethernet HWaddr 00:0C:41:69:FD:5A
inet addr:192.168.2.5 Bcast:192.168.2.255 Mask:255.255.255.0

The wireless device is working. Having both eth0 and rausb0 active at the same time, on the same subnet is not a good idea. Use either one or the other.

Try the command: "cat /etc/resolve.conf". If you get a permission denied error, there is something wrong with the permissions on this file.
Code:

ls -l /etc/resolv.conf
-rw-r--r-- 1 root root 1306 2007-11-05 23:29 /etc/resolv.conf

If you cant read it, a program calling several glibc functions will fail to read it as well. This could be the problem not being able to resolve hostnames.

Also post the contents of /etc/nsswitch.conf. It is the host: line thay you want to check. Does it contain "dns" on the right hand side of the colon?

boygenuis 11-07-2007 06:20 PM

Here's what I got's, yo! for the command cat /etc/resolv.conf I'm told "no such file or directory"
when I type in /etc/nsswitch.conf "permission denied" and when I cd /etc then more /nsswitch.conf "no such file or directory"
did I fuck this up?

Tinkster 11-07-2007 06:49 PM

Only entering the commands ...

You can't run it (/etc/nsswitch.conf) ... and when you cd /etc
and then cat /nsswitch.conf it looks for it in the wrong place
(your systems root file systems rather than in /etc).



Cheers,
Tink


All times are GMT -5. The time now is 01:34 AM.