-   Linux - Newbie (
-   -   cannot connect to overhead projector (

bolaoi 09-23-2011 09:19 AM

cannot connect to overhead projector

I have a Dell Precision M4500 64-bit laptop.
I am using Gnome on Linux Mint 10, Julia.

I can't get it to work with an overhead projector.

There is no problem with windows – I simply use <Fn> and <F8>.

I have asked on the linux mint forums.

I have been directed to use xrandr, but it does not seem to detect the projector, even though it is on and connected to the laptop.

I paste the output of xrandr below:

# xrandr -q
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 175, current 1600 x 900, maximum 1600 x 900
default connected 1600x900+0+0 0mm x 0mm
1600x900 50.0* 51.0
1440x900 52.0
1360x768 53.0 54.0
1152x864 55.0 56.0 57.0
1024x768 58.0 59.0 60.0 61.0 62.0
960x600 63.0
960x540 64.0
896x672 65.0
840x525 66.0 67.0 68.0 69.0 70.0
832x624 71.0
800x600 72.0 73.0 74.0 75.0 76.0 77.0 78.0 79.0 80.0
800x512 81.0
720x450 82.0
720x400 83.0
700x525 84.0 85.0 86.0 87.0
680x384 88.0 89.0
640x512 90.0 91.0 92.0
640x480 93.0 94.0 95.0 96.0 97.0 98.0
640x400 99.0
640x350 100.0
576x432 101.0 102.0 103.0 104.0 105.0 106.0 107.0
512x384 108.0 109.0 110.0 111.0 112.0
416x312 113.0
400x300 114.0 115.0 116.0 117.0 118.0
360x200 119.0
320x240 120.0 121.0 122.0 123.0
320x200 124.0
320x175 125.0

Can anyone help?

Simon Bridge 09-23-2011 09:44 AM

System > Preference > Monitors ... xrandr will try to make it a dual head system.
This is something that normally "just works" unless you have configured it not to somehow.
Sometimes you have to boot with the data projector plugged in (what kind is it?)
I'm guessing you are connected via VGA cable.

You don't say if the output from xrandr is with or without the projector plugged in.

bolaoi 09-24-2011 12:11 PM


It is a Sony VPL-EX1 LCD Projector .

It supports XGA (1024 x 768) and SXGA (1280 x 1024).

I tried booting with the projector plugged in and on.

I also tried connecting the projector after starting up the laptop and logging on.

I connect via the HD D-sub 15 pin cable that came with the projector.

I did
<Menu> <Preferences> <Monitors>

and I get the following error message:

It appears that your graphics driver does not support the necessary extensions to use this tool. Do you want to use your graphics driver vendor's tool instead?

When I answer “No”, I get monitor:unknown, resolution: 1600x900, refresh rate 50Hz

If I answer “Yes”, I get an NVIDIA X Server settings screen.

rahulkya 09-24-2011 12:23 PM

you can install jupiter to make your life easier.
Jupiter works most of the time in my laptop..
Try to find it in repo or go to its

Hope it works for you..

Simon Bridge 09-25-2011 07:17 AM

You are using nvidia graphics.
Make sure the proprietary nvidia driver is installed.
Use the vendor tool to configure dual head.

Simon Bridge 09-26-2011 03:11 AM

If you don't want to use the proprietary drivers, there is a way to get dual head with nv.

bolaoi 09-28-2011 03:27 AM

I'm having trouble getting this dual-head monitor to work.
(I had never heard of this before>)
When I do
Menu | Administration | NVIDIA X Server Settings
I see one screen only.
I know from my research that I should see two, and then I should configure the second.

The following is my xorg.conf:
$ cat /etc/X11/xorg.conf

Section "Screen"
Identifier "Default Screen"
DefaultDepth 24

Section "Module"
Load "glx"

Section "Device"
Identifier "Default Device"
Driver "nvidia"
Option "NoLogo" "True"

How do I get the two monitors?

Simon Bridge 09-30-2011 03:31 AM

The nvidia driver is proprietory - I don't know how it is supposed to work.
xorg.conf is no longer useful for graphics setup ... it is taken over by xrandr.
You may need to enable the external monitor manually.

All times are GMT -5. The time now is 01:42 PM.