LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2009, 09:21 PM   #1
windstory
Member
 
Registered: Nov 2008
Posts: 486

Rep: Reputation: 36
cannot browse internet on virtualbox


I installed centos 5.3 x86 at vrtualbox on windows 7 x64 as host.

The ping answers "network is unrecheable", ifconfig has an ip "192,168,51,100".



At control panel, I seleted intel PRO/1000MT Desktop Host only.

Is this centos's problem?
Attached Thumbnails
Click image for larger version

Name:	centos_ifconfig.png
Views:	11
Size:	43.8 KB
ID:	1250  
 
Old 08-16-2009, 09:57 PM   #2
foodown
Member
 
Registered: Jun 2009
Location: Texas
Distribution: Slackware
Posts: 611

Rep: Reputation: 219Reputation: 219Reputation: 219
In the settings for the machine, under the Network section, what do you have selected for 'Attached to'?

If you have "Bridged Adapter" selected, this will provide what I imagine is the function that you want, enabling you guest machine to function as if it were on the same subnet as the host.

The default is "NAT," which is different altogether and could result in what you describe if your host were not properly configured.

Try switching from "NAT" to "Bridged Adapter."
 
Old 08-16-2009, 10:05 PM   #3
neonsignal
Senior Member
 
Registered: Jan 2005
Location: Melbourne, Australia
Distribution: Debian Stretch (Fluxbox WM)
Posts: 1,389
Blog Entries: 52

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
Just to add to the previous comment, the inbuilt 'Bridged Networking' was only added to VirtualBox in version 2.1.0. If you are running an older version of VirtualBox, you will need to do the bridging yourself in the host.

Last edited by neonsignal; 08-16-2009 at 10:07 PM.
 
Old 08-17-2009, 01:52 AM   #4
windstory
Member
 
Registered: Nov 2008
Posts: 486

Original Poster
Rep: Reputation: 36
Thanks for comments.

I resolved this problem by adding "host only" adapter.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
not able to browse internet vvnslm Linux - Newbie 4 11-12-2008 02:43 AM
not able to browse internet. gautampunhani Linux - Newbie 5 06-23-2008 12:44 PM
How can I browse the internet? ctroyp Linux - General 5 11-22-2005 01:51 AM
internet is connected but cannot browse internet?!?!? myk3 Linux - Newbie 3 11-17-2003 06:57 AM
cannot browse internet circle454 Linux - Newbie 3 11-09-2003 02:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration