-   Linux - Newbie (
-   -   Cannot boot or install from ANY distro or livecd. Compaq d220 desktop - standard. (

splenda 08-19-2010 06:30 AM

Cannot boot or install from ANY distro or livecd. Compaq d220 desktop - standard.
Please help me out.

This is mysterious, and I cannot find a case
like it out there.

I use XP pro, sp3 mostly and dabble in a bunch of different
types of linux. Almost like I use each distro for what it is
strongest in.

This machine will NOT RUN anything natively.

So it hangs/crashes when trying some live - install linux cds.
No Ubuntu/Kubunto/Gentoo - all hang in boot. Variety of errors.
"kernel panic" huge spamming of error messages - scrlling up forever.

Tried all "safe modes" - turned off device detection, "no apic" etc etc.Got earlier versions of kernel, earlier distros. Knoppix back to 3.1
Thought it was some HW vs: ANVIN issue.

Then the hardware odyssey began.

I thought it was the Cdrom, changed to a sony dvd/cdrw.
No dice. Changed the HDD. Changed the ram. Flashed all BIOS/MB/DEVICES to factory norms or latest bios. Attached an external HP dvd - won't boot. Created flash drive versions of several installs. Same hanging.

I can run DSL embedded fine, substitute Puppy iso use the same script
it runs fine - (but very slow)

Tried andlinux - installs fine - won't do anything.

I actually think that this machine has been modified in some way as a prototype to prevent linux from being installed.

Any dos based boot is fine, I made a winPE with barts - it runs great - another winPE
i have boots up fine.

So I tried my old familiar mint, then knoppix, then sabayon, then backtrack, then austrumi, then puppy - getting progressively
'different' - all of them hang or crash.

I can get arachne working under freedos, and the GEM desktop runs fine,
but I have an ST emulator already...

I just tried jolicloud because it was a web install - i didn't realise it's a "cheat method" and uses isolinux anyway... but i got some different messages - non-errors - this is the hang screen...

So it's an:

HP/compaq d220 760 MB ram, p4 2.80 ghz processor,
intel 82845g chipset, radeon 9200 se 128

I will get another beater box soon as I can afford it
but I would love to SOLVE THIS ONE!!

Please help.


onebuck 08-19-2010 07:03 AM


Welcome to LQ!
You stated the ' noapic'. What about 'noapic' & 'noapci' together as parameters to the kernel?

Do you have something to swap the 'radeon' card with?

I would try some older distributions to see how things work out;



Customers worldwide may choose Mandrake Linux 9.1, while customers in Asia-Pacific have as a second option TurboLinux Inc.'s operating system, according to the spokesperson.
The above is circa 2003. Legacy hardware can be an issue with some modern distributions. Most hold your hand distributions have a lot of difficulty with legacy hardware. I personally would use slackware-10.2-iso/ and troubleshoot from there. You could use a early Knoppix 5.1 to see how things are recognized and setup.

It's hard to diagnose something without the 'logs', screen shots alone are not necessarily helpful at this point when troubleshooting.

thorkelljarl 08-19-2010 08:23 AM

This Knoppix if you have not already tried...

As suggested, if you use an older Knoppix live-cd(5.1.1) there are extensive cheatcodes that should help you to trouble shoot your system.

The list of cheatcodes is in a .txt file on the live-cd, that is upon reading the CD, not upon booting.

The linux reason for the existence of cardboard boxes is that they are to be filled with an assortment of old, well supported hardware components ready for substitution for anything that does not or will not boot.

jefro 08-19-2010 04:02 PM

I can't say what your issue is. That system ought to boot to any modern linux if only command line to start. I also can't say about the state of the system. Things like memtest should be run as well as setting bios to default or failsafe settings may help. Using best quality ide drive cables and burning CD's at the very slowest speeds as well as using best quality (I prefer black cd's) tend to help. I have never had an issue with the black cd's dunno why they just seem to always work.

I used to work on a major computer line doing repair and diag work for boards. One may think that because some version of dos or windows runs therefor linux/bsd/PS/2/QNX or some other OS MUST work. That is not the case. There are just too many variables that were never factory tested. A simple timing circuit off or firmware on some chip or the list goes on. If you try every suggestion offered, you may end up never getting that system to boot to linux. I can assure you it was never designed to NOT run linux.

Try what I suggested and might try BSD or other OS live disk too. It may be new enough (should be) to boot to usb. Might try that too.

For grins you could boot to bko or

splenda 08-20-2010 04:47 AM

Thanks for looking into this - latest tries and minor success
I have been working on this problem, and I have found a solution,
just by chance. I can boot into an older version of DSL from CD.
I will get to that - it may work for anyone else who has this
problem. And it hangs even just booting to CLI, it's a basic
issue - I just can't say what.

First, the old faithfuls that perished on the way:

> This Knoppix if you have not already tried...

I almost ran to that one first.
5.1.1 is in the words of Knopper himself, "the last useful version of knoppix." :-)

Expert mode, Failsafe mode, turning off hw-detection, workarounds for broken bios ++

(it still draws the bar, just faster) - hangs right after that.
I tried all - tried versions from 3.9 - didn't mention yesterday because of etourdie. (3.9 has the best codec set - why I keep it)

> Try what I suggested and might try BSD or other OS live disk too. It
> may be new enough (should be) to boot to usb. Might try that too.

I tried that too - forgot to mention it, thought BSD bootstrapping and device detection might be different enough. No dice. Booting = same problems, sometimes different errors.

> If you try every suggestion offered, you may end up never getting
> that system to boot to linux. I can assure you it was never designed
> to NOT run linux.

No I think that EVIL MEN with EVIL PLANS have customized my motherboard.
Just kidding.

MEMTEST and defferent diagnostics all normal. Internal temperatures within or below stress ranges. Yes just last week tried the Radeon out, Intel chipset re-activated - tried all shared mem amounts still no go.

Here are some images of different tries last night. Each distro gives slightly different errors. I will get the screens from more standard distros Redhat, plain Ubuntu - Velutinous Vole or just earlier...

Again thanks all of you for your time and your expertise.
I am like that man of La Mancha - I am driven to fix this.
I am Ahab, I am Ishmael, I am Azazel with screwdriver in hand.

(yes I tried pulling the cr2032 out, disconnecting each piece of H-W, drive etc. as well!)

I don't know if these images help - but since we have a team of experts here it can't hurt. Sorry if they are a little too big, I was hasty with a new f/w imager. Will compress more next time. Name of image will tell which cd it is etc. I used a global method so these images can be shared outside forum if necessary. DreamLinux9 Gentoo or Mandriva Knoppix 5.1.1 DVD Knoppix 4.x

Okay then to my solution: Damn Small Linux.

Wasn't my OS of choice, but now my knight in shining armor.
It hangs the same as all the others with an unattended boot.

Boot with Knoppix cheatcode EXPERT, it prompts you during boot
for several things - keyboard - mouse - load drivers from floppy,
then goes through - script runs startx - voila! use the menus to
select FLUXBOX if you want something more familiar, select "util" - "enable APT" - gets package list and build up to what you need.

I am playing with it. Flashdrive install does NOT boot.
I don't even want to THINK about security yet...

BTW I tried the same EXPERT mode with other knoppix flavors - still hangs. Oh yeah, I tried an early slackware (2008ish) - but not a recent one. Will do that as per your recommend tonight.

What I want:

I want a full featured distro with a a good iptables front end,
decent newsreader and torrenting software, audio editing capability,
a media player with wmv and divx and a cottage on the mountain with
a pretty young wife and three kids.

Tomorrow I find a high protein diet and personal trainer for myDSL.
k3B.dsl package is 43.3 mb (size of compressed iso itself)

Any more ideas - suggestions? Please post I am happy to comply.

splenda 08-20-2010 08:42 AM

> excerpt

gary i only just read the article, i skipped to the work & the puter was tied up in iso downloads

that article is perfect, just perfect:
the humor in the situation, all things considered is that of curious irony

alas there are no logs - it is live cd land, but there is a little more info in a couple of these shots
the hard drive is a strange piece of work

in a few days when all is backed up - i will move to the "full" installs
and see how they fare

be well all

jefro 08-20-2010 06:35 PM

Might try slitaz, puppy or austrumi. The only problem with dsl is that is have been abandoned for about 2 years.

splenda 09-17-2010 05:26 PM


Originally Posted by jefro (Post 4072799)
Might try slitaz, puppy or austrumi. The only problem with dsl is that is have been abandoned for about 2 years.

i am grateful for the help jefro, guys

in case anyone in the future has this weird problem:
dsl was working, i was able to install firefox and all
it's a great little OS, and it's developers worked
hard on making a lot of packages fully compatible
i am sad to hear that it's not moving forwards

i used occam's razor and REPLACED the computer
used comps are so inexpensive now
that's why i was gone so long

i guess i can close this thread :-)

thanks again

All times are GMT -5. The time now is 12:46 AM.