LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Cannot Activate network device (https://www.linuxquestions.org/questions/linux-newbie-8/cannot-activate-network-device-247714/)

XYNaPSE 10-26-2004 10:28 PM

Cannot Activate network device
 
Hello,

Im a serious Linux newb. Iv tried Redhat 7 and 9 a while ago and now I installed FC2 64 bit version. The problem I am having is after the installation I open up mozilla to see if I have iNet. I type in google address and cant find the server. So I try to configure the networking. I deleted the old network device in the netwrok configurations window because it wouldnt activate or do anything and re-detected it. I try to activate it and get this error.

Cannot activate Network device eth0
does not seem to be present
delaying initialization.

I go to the hardware tab and it says

Device eth0
IRQ unknown

During the installation I said yes to the firewall if that means anything. I tried looking for a program to configure the firewall but couldnt find anything. I have an OnBoard Lan. also sound doesnt work. Iv searched the forum and cant find anything.

Heres my hardware specs


AMD64 3000+
1 gig of ram

EPOx 8kda3j mobo
Onbboard 10/100 Ethernet
Onboard Sound

ATI Radeon 9800 pro
SATA 200gig Maxtor Diamond plus

Thanks in advance

XYNaPSE 10-26-2004 11:00 PM

I also have a d-link router with cable access

homey 10-26-2004 11:39 PM

What's it look like when you type /sbin/ifconfig

XYNaPSE 10-27-2004 12:14 AM

Link encap:Local Loopback
inet addr:127.0.0.1 Mask 255.0.0.0
inet6 addr: :: 1/128 Scope:Host
UP Loopback RUNNING MTU: 16436 Metric:1
RX packets: 1475 errors:0 dropped:0 overruns:0 frame:0
TX packets: 1475 errors:0 dropped:0 overruns:0 frame:0

Collisions: 0 txqueuelen: 0
RX bytes: 1405076 (1.3mb)
TX bytes: 1405076 (1.3mb)

I was also looking up some stuff on Fedora and ethernet problems and noticed that some people were having problems with the new kernel and installing the drivers for the Onboard nic. Sounds like the same problem im having not sure.

XYNaPSE 10-27-2004 12:32 PM

Anyone know what the problem is and how I can fix it? :D

WhiteChedda 10-27-2004 12:53 PM

Quote:

Originally posted by XYNaPSE
Anyone know what the problem is and how I can fix it? :D

Looks like you need to load a module driver for the NIC.

try issueing the following commands,

modprove forcedeth
then
dhcpcd

then

ifconfig

If you see an eth0 card, you are in business.

XYNaPSE 10-27-2004 01:06 PM

Thanks for the help. Am I supposed to type thosee comands in the terminal? I tried them in the terminal but the commands were not found. Sorry Im a newb. :newbie:

homey 10-27-2004 01:14 PM

Quote:

modprove forcedeth
then
dhcpcd
Just a little typo there. :) Try modprobe forcedeth

Yes you do type those commands in the terminal. Likely need to be root user first so type the command: su - then enter the root password.

XYNaPSE 10-27-2004 02:10 PM

Ok same thing. I type su and password to get to admin and type in modprobe forcedeth and it says modprobe is not a command.

homey 10-27-2004 02:16 PM

Try it with the full path : /sbin/modprobe forcedeth

XYNaPSE 10-27-2004 02:30 PM

Ok. That time the /sbin/modprobe forcdeth command worked but the others did not. I tried /sbin/dhcpcd and dhcpcd. I also tried doing a search fo dhcpcd and couldnt find anything. :confused:

homey 10-27-2004 02:50 PM

Try the command: service network restart and if that works ok, you should see something like Bringing up interface eth0 [ok] .
If that worked ok, then try to ping something on the net like
ping -c 3 yahoo.com

XYNaPSE 10-27-2004 05:29 PM

ok.. that did not work. I did what you said and it did this

shutting down loopback interface [ok]
Setting network parameters [ok]
Bringing up loopback interface [ok]

Then I pinged yahoo.com and it said unknown host yahoo.com

mermxx 10-27-2004 05:30 PM

U can also try going into bios at start up and see if u have ur network card enabled/disabled and amend ( u will find this in Plug and Play for your mobo) it would seem to me that this is the problem if NIC and sound are both onboard and both are not working :-)

XYNaPSE 10-27-2004 05:33 PM

I know its enabled cause im using the same computer to type this message. I am dual booting with WinXP and Fedora Core 2. :Pengy:


All times are GMT -5. The time now is 01:33 AM.