LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-16-2002, 11:34 PM   #1
amadeuss
LQ Newbie
 
Registered: Nov 2002
Location: Chicago
Distribution: suse pro 8.2 ,mandrake 9.0, Win XP pro, win2000 adv server
Posts: 11

Rep: Reputation: 0
Unhappy Cannot access the internet from mandrake 9


ok...the thing is that I am using the wizard from the control center->network & Internet -> Connection..wow.I'll tell you step by step maybe you'll give me a fast and precise answer I click on wizard and i choose profile default check use autodetection and expert mode .after that I choose LAN connection and it asks me the IP adress which is 192.168.0.196 ( cause I have a router ) the netmask I set it at 192.168.0.1 and check start at boot.
Next host name I say localhost.localhost.org
And here is another problem..It asks me DNS server.I put 192.168.0.1
after that Gateway which I put the same IP as in DNS.
after that click Finish but it won't connect to the internet..i cannot visualize any web pages with the web browser or anything...
ok
now in Win XP i tried to see some things....and it shows me
Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . : Sperantza
Description . . . . . . . . . . . : SMC EZ Card 10/100 PCI (SMC1211TX)
Physical Address. . . . . . . . . : 00-10-B5-DB-5C-A9
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 192.168.0.124
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.0.1
DHCP Server . . . . . . . . . . . : 192.168.0.1
DNS Servers . . . . . . . . . . . : 63.240.76.4
204.127.198.4
In linux when i type route it says that destinations I got two : 192.168.0.0 and 127.0.0.0 with gateway * and the first one has the genmask 255.255.255.255 flags uh iface eth0
and the second one is gateway * genmask 255.0.0.0 flags U and is interface lo

in my router conf I got the followings:
IP Address 12.249.86.170
Subnet Mask 255.255.255.0
Gateway 12.249.86.1
Domain Name Server 63.240.76.4, 204.127.198.4
LAN IP Address 192.168.0.1

If you can help me..I appreciate....thanks a lot ppl
Amadeuss



 
Old 11-17-2002, 01:46 AM   #2
g0dzuki99
Member
 
Registered: Jan 2002
Posts: 56

Rep: Reputation: 15
OK... here we go.

Lets start with the host name. change it to something like "zaxxon" or "joe" anything but localhost.org... in your /etc/hosts you should have 2 lines:

127.0.0.1 localhost.localdomain localhost
192.168.0.196 <yourcomputername>

You may as well make that 192 address static while your at it too.

For your DNS server, get that address from your ISP. Use 63.240.76.4 if thats what XP says it is.

Your default gateway will be the internal IP address of your router... 192.168.0.1

No need to set up any routes within Linux.

Hope that helped!

~g0dzuki

Last edited by g0dzuki99; 11-17-2002 at 01:48 AM.
 
Old 11-17-2002, 11:23 PM   #3
amadeuss
LQ Newbie
 
Registered: Nov 2002
Location: Chicago
Distribution: suse pro 8.2 ,mandrake 9.0, Win XP pro, win2000 adv server
Posts: 11

Original Poster
Rep: Reputation: 0
Sorry I have to disturb again with an unsuccesful post...I tried everything you said and i thank you for the answer but it still shows me connection failed..i have a d-link 704p router though (maybe this info will help )and dhcp enabled in it....i tried the conf in mandrake to set up automatically with dhcp server...it said it connected me but still I tried the net it didn't... when I pressed again connect lan it said disconnecting...and after a few seconds connecting...with a connection complete message..but the problem..is still there ohh. I changed my hostname into linux server....thx again for your post
Amadeuss
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet Access/Mandrake and VMWare martinsmith100 Linux - Networking 0 09-26-2005 05:37 PM
cant access internet on Mandrake 10.1 birdofprey Linux - Networking 1 05-07-2005 03:31 AM
internet access in mandrake 9.2 aalavic Linux - Newbie 1 10-15-2004 03:40 PM
Internet access mandrake 9.1 rjilb Linux - Networking 1 03-28-2004 11:37 PM
How to get internet access in Mandrake 9.2 pte Linux - Newbie 1 01-25-2004 02:02 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration