LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   cannnot update (https://www.linuxquestions.org/questions/linux-newbie-8/cannnot-update-4175625461/)

BSnow 03-12-2018 10:59 PM

cannnot update
 
Hello, I have been with mint 18.3 for about 6 weeks now and since last week it will not refresh to install updates. I may be getting to deep for myself due to my lack of knowledge of computer skills or anything about programming. Should i take it to Tech. or could someone take me with baby steps thru some test ect. Did read some other post on this subject and did learn what the terminal is and tried some of the wordings it said to write in.My computer terminal refuse to accept anything i wrote on the terminal. Thanks ahead for your time. Barry

frankbell 03-12-2018 11:26 PM

More information would help.

What steps precisely are you taking to update your install?

BSnow 03-13-2018 02:29 AM

Thanks, there is a shield icon at bottom of screen and when it is red it means to install updates, and so hit shield and security page pops up there are a refresh button an a install updates button ,so at that point not sure where to hit refresh button first or install updates first and then refresh so i just hit either one and hope for best and up until a week ago it updated fine but not now. The shield icon at bottom on screen is red and when i hit refresh and it begins and fails and it says another program is running and cannot refresh because the other program is running and it would have to be finished and then i could refresh it and hopefully the problem would be solved. Thanks for reading, willing to learn as we go, Barry

AwesomeMachine 03-13-2018 02:49 AM

What is the exact message that there is another program running.

ondoho 03-13-2018 03:09 PM

always hit the refresh button first.

BSnow 03-13-2018 09:58 PM

When i try to install updates it 45 10 seconds it says another synaptic is running in non-interactive mode:Please wait for it to finish. I have waited for 1 hour for it to finish but it never did not. On the install list it list in green a level 2 that says friendly recovery while the tiny round circle keeps turning.Will from no own hit refresh 1st.

killingthemonkey 03-13-2018 10:21 PM

Barry,
When you say that you tried via the terminal, did you try the following?

Code:

sudo apt-get update
sudo apt-get upgrade

If so, please post the errors you receive in the terminal.

(Also, take a look at How to Ask a Question
I just stole this from ondoho's sig.)

Using the question strategies in that article will make it easier for us to help you.

scasey 03-13-2018 10:24 PM

Not a mint user, but have seen this in CentOS where there is a yum update daemon running in the background and the GUI interface gives a similar message.
How does one check for that in mint? ...

BSnow 03-14-2018 02:27 AM

terminal
 
At your advise i went to terminal and wrote in sudo apt-get update. After 2 hours it says there is still a process running in terminal.

killingthemonkey 03-14-2018 10:56 PM

Barry,
I'm going to take you into strange territory. Where we're going is that part of the map where it says, "Here thar be dragons."
Please read all instructions, and print them if you don't have another screen to read them from.


1. Open a terminal
2. Type
Code:

sudo systemctl isolate multi-user.target
---- This will close the GUI altogether. You are now in the land of the command line.
3. Type
Code:

sudo apt-get update
4. Type
Code:

sudo apt-get upgrade
5. Type
Code:

sudo systemctl isolate graphical.target
---- This will restart the GUI

See if that works for you.

JJJCR 03-15-2018 02:21 AM

Quote:

Originally Posted by ondoho (Post 5830641)
always hit the refresh button first.

or simply reboot the system, pray hard that the logic programming will do its job. :)

ondoho 03-15-2018 03:08 AM

Quote:

Originally Posted by killingthemonkey (Post 5830764)
Code:

sudo apt-get update
sudo apt-get upgrade


one should not do this on Linux Mint because it will mess up Mint's own upgrade logic: it's picking "safe" upgrades from some testing repos afaiu - using apt upgrade will simply upgrade ALL those packages, even if they're marked red.

hydrurga 03-15-2018 04:04 AM

Quote:

Originally Posted by ondoho (Post 5831131)
one should not do this on Linux Mint because it will mess up Mint's own upgrade logic: it's picking "safe" upgrades from some testing repos afaiu - using apt upgrade will simply upgrade ALL those packages, even if they're marked red.

I would have to disagree with this, ondoho.

The various Update Manager security settings are purely a Mint construct created for more newbie users who may not be confident about upgrading packages in Mint. It is just as safe as in other distros to carry out apt update and apt upgrade, with the usual proviso that the user should be making occasional system snapshots so that they can roll back if anything goes awry (TimeShift is an excellent way of doing that). Doing so does not in any way mess up Mint's own upgrade logic, it merely bypasses Update Manager's security settings. All of Mint's standard repos contain tested software.

beachboy2 03-15-2018 04:12 AM

1 Attachment(s)
BSnow,

Since your updates appear to have been working perfectly until a week ago, I would be inclined not to waste further time and backup all your documents, photos, bookmarks etc and then do a fresh installation of Linux Mint 18.3.

When you reboot after installation you will be asked whether you wish to switch to a different (faster) Main mirror.

Click on Yes and then select the one with the fastest speed of those displayed.

Next, click on Update the cache (see attached screenshot) and continue with updating Mint.

This old link about changing mirrors is still relevant:
https://unlockforus.com/why-you-shou...-mirror-today/

BSnow 03-15-2018 10:34 AM

As of now my system is up to date it saids. I tried again last night and at 1st for 1st time i hit new updates i believe it says on the top right side instead of just hitting the one that is in the middle that saids to ininstall updates. Surprised I am. Will write down when i have the time what you guys and ladies i wrote down tonight and this morning. This bunch is really special with the will to help other user. Thanks again. Respectfully, Barry


All times are GMT -5. The time now is 01:11 AM.