-   Linux - Newbie (
-   -   Can you trick Wine into reading cdrom from hard drive? (

Dragon 2075 08-28-2005 10:01 PM

Can you trick Wine into reading cdrom from hard drive?
Edit - Perhaps it's best if I only leave the long version. The short one seems to take things out of context.

I'm trying to run Diablo II on my Xbox. In theory I'll be able to run it in wine, and so I've got Xebian running on my Xbox with wine installed. However, if you've ever tried using Linux on the Xbox, then you know it's very picky about which disks it will read. So, I FTP'ed the disks on to the hard drive, and even tricked it for the first part of the install. (as in I clicked it and it just worked) However, I can't get it to find the expansion disk to finish the install or the play disk to test what I have so far. So, I was thinking that there should be something I can edit in wine to point to a folder as where it gets the cdrom info, right?

If you need any more info, just let me know. Also, I might as well add that my knowledge of Linux is very scattered; I just sort of look up comands as i need them.

Edit - Hmm... the topic merge seems to have swiched the title. Perhaps an edit will fix it?

Tinkster 08-28-2005 10:18 PM

[edit]Thread reopened after users explanation[/edit]


Dragon 2075 08-28-2005 11:46 PM

Can you trick Wine into reading cdrom from hard drive?
Edit - Thank you for reopening this topic. Forgive me if I sounded a little harsh; I've been going at this all day, and I should really get some sleep.

Please accept my apologies.


Tinkster 08-29-2005 12:10 AM

That's cool mate ... take the copied CD out of the first post, too,
and we'll be good as gold :}


Dragon 2075 08-29-2005 12:15 AM

Does that work? I just took out the first part, since it doesn't really tell the whole story.

Also, is there anything we can do about the topic title? It's a little misleading at this point.

scuzzman 08-29-2005 03:34 AM

LOL - yes, topic title is very misleading.

As for the predicament (and I'm just throwing out ideas here) what if you mount the cd, will it read it then?

xucaen 09-26-2005 02:31 PM

Hi, I am trying to install Diablo from CD. The installation begins, then asks me to insert the CD rom! well, it's already in there! So I had an idea (that doean't work). I noticed that in ~/.wine/dosdevices there is a ~c and a ~z. So I figured I would add a ~d and symlink it to my mount folder. Unfortuantely wine does not see this new device. How can I get wine to see ~d as my cdrom drive?


larrydag 09-27-2005 08:56 AM

This link from Frank's Corner may help you getting Diablo to work.

Frank's Corner Diablo 2 howto

xucaen 09-27-2005 11:56 AM

Hi, I solved the problem.. but I think it's not very stable....
You see, I first installed Wine (on debian testing) and ran a program using Wine from the command line. This seemed to have set up for me a C: drive and a Z: drive. Later when I wanted to install Diablo 2, I figured that I probably need to run the Wine configuration. But when I did that it said I needed to install winesetuptk. So, I installed winesetuptk and ran the configuration. Now something weird happened. I found that I had a mix of drives! I had 2 C: drives defined, 2 Z: drives defined, and all of my CD roms drive and my floppy. Ok, so I tried to run the Diablo 2 install again, but for some reason Wine could only see the original C: and Z: drives. After about an hour of playing with the Wine configuration I uninstalled it, deleted my .wine directory and reinstalled Wine. This time I ran the Wine configuration first before attempting to run the installation. This time it not only correctly set up my drives, but also set up my com ports and printer ports. (those weren't set up last time!) After that Diablo 2 found my CD rom.. funny thing is that I had to mount and unmount each disk that it asked for. That's OK, but it seems that even though I have a drived letter mapped to /dev/scd0, Wine still needs me to mount the drive. Ah, but now I see that I have two CD roms! one mapped to /dev/scd0, the other mapped to my mount point /cdrom! It seems that everytime I run Wine it changes the drives a little. must be a bug somewhere. But anyways, I am very happy! I was able to play Diablo 2 for about an hour. :-D


All times are GMT -5. The time now is 01:39 PM.