LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Can not install Fedora 17 (https://www.linuxquestions.org/questions/linux-newbie-8/can-not-install-fedora-17-a-4175417276/)

luckytiger 07-17-2012 04:14 PM

Can not install Fedora 17
 
I have a dual boot (FC16 & Windows XP), Pentium 4, 2.8 GHz, 992 MiB memory laptop. I have tried to upgrade to FC17 using preupgrade. The process just stops, no error message (not sure where to look), tried a commercial DVD, process starts, checksum OK, then when starting install, the process freezes at line "Started NetworkManager". I tried a live CD, process freezes at a message "rpcbind: rpcbind terminating on signal, Restart with rpcbind-w". I have tried connecting to internet via Cat5 cable and wifi without any difference. I suspect something to do with Network Manager but not sure how to determine what is stopping the installation. I tried the commercial DVD on another computer it worked OK.

Kustom42 07-17-2012 04:33 PM

This could be an issue with the new biosdevname feature implemented in FC17 for your network cards. It will attempt to rename them to something like p3p71 or whatever the bios sees them at in regards to the PCI location.

You can disable this feature via adding the following line to grub.conf:

Code:

biosdevname=0
See if that does anything for you, if not you should be able to switch to altnerate terminals during the upgrade/install process via alt+f2, f3, f4, etc... and see the acutal stderr/stdout that is reporting on the tasks that are happening. This can give us more insight into the root cause.

Kustom42 07-17-2012 04:34 PM

You can also pass the option directly on the kernel command line in grub.

luckytiger 07-17-2012 04:48 PM

I have grub2 in FC16. I does not contain the file grub.conf. However, I do have file grub.cfg but it states:
DO NOT EDIT THIS FILE
# It is automatically generated by grub2-mkconfig using templates from /etc/grub.d and settings from /etc/default/grub.


I will try the alt+f2 etc to see what light that sheds.

luckytiger 07-17-2012 05:11 PM

I tried the preupgrade installation of Fedora 17 and using alt-f screens saw the following errors:
Show plymouth boot screen failed
Warning Network Manager trying to remove non-existant call id
warning kernal ath5k phy0: too many interrupts, giving up for now (this line continue to repeat until the computer is powered down).
As a note, I had problems with FC 16 after kernel upgrades above 3.1.9-1 with network manager which related to this same ath5k. I was hoping F-17 would solve whatever issue it was.
If I removed network manager and start using wicd, could I use the commercial DVD to install FC17? or would the liveCD install if I made this change? Thanks

luckytiger 09-14-2012 04:52 PM

Work around
 
I was able to install FC17 by blacklisting module ath5k using command modprobe.blacklist=ath5k

It is necessary to also use this command when booting FC17 (by editing the grub command). Wireless is not available using the installed Atheros wireless card, I am able to use a wired connection and able to use a USB wireless dongle.

unSpawn 09-14-2012 07:20 PM

Thanks for posting your solution, and that after nearly two months.


All times are GMT -5. The time now is 03:08 PM.