LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-25-2004, 10:06 PM   #1
danahata
Member
 
Registered: Aug 2003
Posts: 30

Rep: Reputation: 15
can mount with smbmount but not with fstab


SMbmount works, but mount samba shares from fstab doesn't. When I run 'mount -a', I get -

19857: session setup failed: ERRSRV - ERRbadpw (Bad password - name/password pair in a Tree Connect or Session Setup are invalid.)
SMB connection failed

This exact setup works fine on another system, I've no idea why it fails here.

Any ideas? I've looked around, but to no avail.

Thanks, Dana

*** Here's the fstab -->

//deathvalley/7200wdcav80 /mnt/dv_7200wdcav80 smbfs credentials=/etc/samba/auth.deathvalley.danahata 0 0
//deathvalley/maxtor160 /mnt/dv_maxtor160 smbfs credentials=/etc/samba/auth.deathvalley.danahata 0 0

*** /etc/samba/auth.deathvalley.danahata -->
username=myusername
password=mypwd

*** Here's the smb.conf for "deathvalley" -->

# Global parameters
[global]
workgroup = MSHOME
netbios name = DEATHVALLEY
server string = Deathvalley
encrypt passwords = Yes
[homes]
comment = Home Directories
read only = No
browseable = No
[printers]
comment = All Printers
printable = Yes
printing=LPRNG

[dv_7200wdcav80]
path = /mnt/dv_7200wdcav80
guest only = Yes
guest ok = Yes

[dv_maxtor160]
path = /mnt/dv_maxtor160
guest only = Yes
guest ok = Yes
 
Old 02-25-2004, 10:38 PM   #2
danahata
Member
 
Registered: Aug 2003
Posts: 30

Original Poster
Rep: Reputation: 15
I changed the credentials line in fstab, and replaced it with username=xxx,password=xxx, and now it orks. Don't know why the credentials file broke it, it works on another machine.

Anyone know why?

Dana

P.S. I realize my share names didn't match on my initial post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fstab problem: mount: can't find dvd in /etc/fstab or /etc/mtab Nikon01 Slackware 5 11-17-2006 07:15 AM
why can't I mount with smbmount if i'm able to connect with smbclient? eantoranz Linux - Networking 3 12-17-2004 01:41 PM
smbmount is messing with mount point permissions Sohni Linux - Networking 1 04-06-2004 11:37 AM
add smbmount drives to fstab? woja Linux - Newbie 1 11-07-2003 04:14 PM
mount windows share smbmount dc2447 Linux - Newbie 1 09-08-2002 10:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration