LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2009, 12:42 PM   #1
qqoel
LQ Newbie
 
Registered: Jun 2009
Location: Tokyo
Distribution: OEL
Posts: 2

Rep: Reputation: 0
Smile Can I install an application on OEL5 when the pre-req is OEL5 Update 1?


Hi,
I have installed OEL 5 from media and by typing uname -r, I get:
2.6.18-53.el5 -> Q1oes this mean that my OS version is OEL5?

I need to install an application where it has the following as pre-req:
'Update 1 (5.1) or higher of Oracle Enterprise Linux (OEL) 5 is required',
but I do not have enough time for downloading OEL5.1 which is quite huge.
Q2: Is there a small download which can be applied on top of OEL5.0?

In the release notes of the application, it states that
the following i386 packages must be installed:
compat-glibc-2.3.4-2.26
gcc-4.1.2-14.el5
gcc-c++-4.1.2-14.el5
glibc-devel-2.5-12
libXp-1.0.0-8.1.el5

I cannot find the RPM on the above for OEL distribution.
Q3: Can I download the above which is for other distribution, like RHEL
for example and apply to my OEL5?

Any answers to any question is greatly appreciated.
Thanks in advance.
 
Old 06-19-2009, 02:38 PM   #2
tekhead2
Member
 
Registered: Apr 2004
Distribution: slackware/FreeBSD/Vector
Posts: 291

Rep: Reputation: 52
I've never used Oracle's Linux before, but I heard it's binary compatible with Red Hat. The only issues you may have with installing the needed files from a Red Hat RPM would be files being located in the wrong place. I would try it and see what you get. I'd definitely backup before you do that though. Also if your paying for support you maybe voiding your warranty by introducing code not from them.
 
Old 06-20-2009, 08:31 PM   #3
qqoel
LQ Newbie
 
Registered: Jun 2009
Location: Tokyo
Distribution: OEL
Posts: 2

Original Poster
Rep: Reputation: 0
Hi tekhead2,
Thanks for your quick input. I will try it with RHEL RPM.

In general, is there any small patches to move 5.0 Linux systems to 5.1?
There is a full 5.1 OEL to download but it is huge, and I was looking for
a small 5.1 patch but there doesn't seem to be one.

Any ideas?
Thanks.
 
Old 06-21-2009, 08:50 PM   #4
chrism01
LQ Guru
 
Registered: Aug 2004
Location: Sydney
Distribution: Centos 6.9, Centos 7.3
Posts: 17,411

Rep: Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397Reputation: 2397
You should just be able to use something like

yum update

to get the system updated ... actually, that may bring you up to 5.3 (current).
If you've paid for OEL I'd recommend asking them. I believe support is included.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
PCIe External Firewire 800 IDE drive not detected on OEL5.3 frqs37 Linux - Hardware 2 03-24-2009 09:50 PM
RocketRaid 1720 does not show drive w/ OEL5.3 & mobo XFX GeForce 8200 frqs37 Linux - Hardware 2 03-22-2009 10:56 PM
Need suggestions before install OEL5.0 on IBM3400 masatheesh Linux - Server 1 12-06-2008 04:47 PM
Update OpenGeu application menu after installing an application silencer07 Linux - Desktop 0 10-20-2008 10:19 PM
how do I revert back to a solid working pre-update version EricNewb Linux - Newbie 4 10-02-2008 03:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration