LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-19-2010, 01:04 PM   #1
grob115
Member
 
Registered: Oct 2005
Posts: 540

Rep: Reputation: 32
Can't send mail from my FC11


Am trying to configure the default sendmail program to send mail from command line but failed. Here are the steps I did while following http://www.sendmail.org/~ca/email/auth.html#authconf

cd /etc/mail
mkdir auth
chmod 700 auth
cd auth
Create a file called client-info with the following:
AuthInfo:smtp.spamarrest.com "U:<spamarrest.com's login>" "I:<spamarrest.com's login>" "P:<spamarrest.com's password>"
makemap hash client-info < client-info
chmod 600 clien-info*
cd ..
Edit the file sendmail.mc with the following:
define(`SMART_HOST',`smtp.spamarrest.com')dnl
define(`confAUTH_MECHANISMS', `EXTERNAL GSSAPI DIGEST-MD5 CRAM-MD5 LOGIN PLAIN')dnl
FEATURE(`authinfo',`hash /etc/mail/auth/client-info')dnl
make
service sendmail restart

With yum, I can confirm I have the following installed:
Name : sendmail
Arch : i586
Version : 8.14.4
Release : 3.fc11

Name : sendmail-cf
Arch : noarch
Version : 8.14.4
Release : 3.fc11

And here's what got logged in my /var/log/maillog
Code:
Jun 20 01:19:58 devsvr sendmail[3067]: o5JHJwUx003067: from=root, size=232, class=0, nrcpts=1, msgid=<201006191719.o5JHJwUx003067@devsvr.domain>, relay=root@localhost
Jun 20 01:19:58 devsvr sendmail[3068]: o5JHJwLq003068: from=<root@devsvr.domain>, size=491, class=0, nrcpts=1, msgid=<201006191719.o5JHJwUx003067@devsvr.domain>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
Jun 20 01:19:58 devsvr sendmail[3067]: o5JHJwUx003067: to=xxxxx@hotmail.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30232, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (o5JHJwLq003068 Message accepted for delivery)
Jun 20 01:23:58 devsvr sendmail[3070]: o5JHJwLq003068: to=<xxxxx@hotmail.com>, ctladdr=<root@devsvr.domain> (0/0), delay=00:04:00, xdelay=00:04:00, mailer=relay, pri=120491, relay=smtp.spamarrest.com. [67.228.25.86], dsn=4.0.0, stat=Deferred: Connection timed out with smtp.spamarrest.com.

Any idea why I can't send mail? Have I missed any steps?

Last edited by grob115; 06-19-2010 at 01:25 PM.
 
Old 06-19-2010, 01:44 PM   #2
grob115
Member
 
Registered: Oct 2005
Posts: 540

Original Poster
Rep: Reputation: 32
Just recall that smtp.spamarrest.com uses port 587. Added the following two lines to sendmail.mc
Code:
define(`RELAY_MAILER_ARGS', `TCP $h 587')dfl
define(`ESMTP_MAILER_ARGS', `TCP $h 587')
I then run "make", and "service sendmail restart", then got the following when I attempted to send mail.
Code:
Jun 20 02:36:54 devsvr sendmail[3298]: o5JIasDR003298: from=root, size=232, class=0, nrcpts=1, msgid=<201006191836.o5JIasDR003298@devsvr.domain>, relay=root@localhost
Jun 20 02:36:54 devsvr sendmail[3300]: o5JIasVX003300: from=<root@devsvr.domain>, size=491, class=0, nrcpts=1, msgid=<201006191836.o5JIasDR003298@devsvr.domain>, proto=ESMTP, daemon=MTA, relay=localhost.localdomain [127.0.0.1]
Jun 20 02:36:54 devsvr sendmail[3298]: o5JIasDR003298: to=xxxx@hotmail.com, ctladdr=root (0/0), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30232, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (o5JIasVX003300 Message accepted for delivery)
Jun 20 02:36:55 devsvr sendmail[3302]: STARTTLS=client, relay=smtp.spamarrest.com., version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Jun 20 02:36:56 devsvr sendmail[3302]: o5JIasVX003300: to=<xxxx@hotmail.com>, ctladdr=<root@devsvr.domain> (0/0), delay=00:00:02, xdelay=00:00:02, mailer=relay, pri=120491, relay=smtp.spamarrest.com. [67.228.25.94], dsn=5.0.0, stat=Service unavailable
Jun 20 02:36:56 devsvr sendmail[3302]: o5JIasVX003300: o5JIauVX003302: DSN: Service unavailable
Jun 20 02:36:56 devsvr sendmail[3302]: o5JIauVX003302: to=<root@devsvr.domain>, delay=00:00:00, xdelay=00:00:00, mailer=local, pri=31741, dsn=2.0.0, stat=Sent

Last edited by grob115; 06-19-2010 at 02:39 PM.
 
Old 06-19-2010, 08:39 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,239

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
the first thing i would do is install fedora 13
fedora 11 will hit End of life in about 2 weeks . No updates after that.

then get sendmail to work . it is set up by default on install for system error massages .
 
Old 06-19-2010, 11:01 PM   #4
grob115
Member
 
Registered: Oct 2005
Posts: 540

Original Poster
Rep: Reputation: 32
But I have sendmail came with my FC11 I thought. Anyway, I updated it to the latest version with yum. I mean, even if it gets out of life, it should still work as sendmail has been around much longer than FC11.
 
Old 06-19-2010, 11:19 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,239

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
Quote:
it should still work as sendmail has been around much longer than FC11.
work ,yes but the OPERATING SYSTEM will NEVER have any more updates .
and sendmail WILL NEVER get any more updates.


if you are going to use fedora then stay current!!!
http://forums.fedoraforum.org/faq.php
http://docs.fedoraproject.org/en-US/index.html
https://fedoraproject.org/wiki/Fedora_Project_Wiki
 
Old 06-19-2010, 11:52 PM   #6
grob115
Member
 
Registered: Oct 2005
Posts: 540

Original Poster
Rep: Reputation: 32
Okay this appears to be something to do with the message being blocked at either spamarrest or hotmail. Check this out from /var/spool/mail/root

----- The following addresses had permanent fatal errors -----
<xxxx@hotmail.com>
(reason: 554 <xxxx@hotmail.com>: Relay access denied)

----- Transcript of session follows -----
... while talking to smtp.spamarrest.com.:
>>> DATA
<<< 554 <xxxx@hotmail.com>: Relay access denied
554 5.0.0 Service unavailable
<<< 554 Error: no valid recipients

--o5K3dpRR002582.1277005191/devsvr.domain
Content-Type: message/delivery-status
 
Old 06-20-2010, 02:22 AM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by John VV View Post
work ,yes but the OPERATING SYSTEM will NEVER have any more updates .
and sendmail WILL NEVER get any more updates.


if you are going to use fedora then stay current!!!
http://forums.fedoraforum.org/faq.php
http://docs.fedoraproject.org/en-US/index.html
https://fedoraproject.org/wiki/Fedora_Project_Wiki
John,
while I agree with your assessment it's not what he asked for,
and most likely won't help his problem, either.

That, and the "tone" (bold & font-size) is uncalled for.


Cheers,
Tink
 
Old 06-20-2010, 03:27 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,239

Rep: Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522Reputation: 2522
Quote:
That, and the "tone" (bold & font-size) is uncalled for.
my apologize

but seeing as 11 is about to hit EOL ,13 should be installed THEN the sendmail issue should be looked at
it might "just work" on a current install?
 
Old 07-03-2010, 02:19 PM   #9
grob115
Member
 
Registered: Oct 2005
Posts: 540

Original Poster
Rep: Reputation: 32
bathory helped me found the problem here,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Send mail to root but it send to other email smart_jija Solaris / OpenSolaris 5 07-01-2009 02:33 AM
can mail command be used to send mail onto global mail servers like yahoo etc dale_chip Linux - Newbie 4 08-12-2008 09:33 AM
Postfix : mail cannot send to send outside ( can send/receive locally) bobbinsupport Linux - Networking 3 12-15-2007 11:40 PM
with the linux proxi, backend pop3 mail client can not receive mail and send mail rubin823 Linux - Networking 0 12-21-2006 11:06 PM
Server does'nt send mail until shutdown and LAN can't send or receive. Wolfy Linux - Networking 0 08-02-2004 08:31 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 06:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration