LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-08-2017, 03:36 PM   #16
rubankumars
Member
 
Registered: Oct 2010
Location: india
Distribution: debian 8,debian 9,slackware 14.2
Posts: 158

Rep: Reputation: 12

Just boot using yout live cd (ubuntu one)
Select try ubuntu
Open My computer or computer
click on the drive you want to mount from file explorer
go to etc/fstab in that drive and copy the path of file (Right click > Properties> copy the path) for example:
/media/1265qe-8776-878t/etc

Open terminal and enter cd <path copied>
i.e
cd /media/1265qe-8776-878t/etc

sudo nano fstab

properly correct and save the file.
If you don't know how to edit or what to change ,post the file here as Rickkkk said.
We would be happy to help
 
Old 08-08-2017, 04:18 PM   #17
ilsen
Member
 
Registered: Jul 2017
Posts: 51

Rep: Reputation: Disabled
Unhappy

Quote:
Originally Posted by AwesomeMachine View Post
Try
Code:
$ sudo nano /etc/fstab

Can you help the subject?
link: http://www.linuxquestions.org/questi...em-4175611397/
 
Old 08-08-2017, 10:51 PM   #18
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Thanks Rickkkk,
I am going to try to remove what I added but to clarify: I haven't as yet installed xubuntu. I was trying to partition my main partition [/dev/sda2] in mint in order to install xubuntu. Using Gparted I created the new partition[ /dev/sda4] then I tried to mount it. I tried to mount on /dev/mnt/DATA as follows:

sudo mount /dev/sda4/xubuntu* /mnt/DATA/

*I named the partition xubuntu

I received the following message:
"special device /dev/sda4/xubuntu does no exist (a path prefix is not a directory)"

I then tried /mnt/dev and it mounted temporarily. Then the trouble started when I tried to make it permanent.
 
Old 08-08-2017, 10:59 PM   #19
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Thanks rubankumars and ilsen. Sorry I didn't see your posts only Rickkkk's. I think I have to first remove the faulty entry.
 
Old 08-09-2017, 12:11 AM   #20
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Thanks Rickkkk,
I am going to try to remove what I added but to clarify: I haven't as yet installed xubuntu. I was trying to partition my main partition [/dev/sda2] in mint in order to install xubuntu. Using Gparted I created the new partition[ /dev/sda4] then I tried to mount it. I tried to mount on /dev/mnt/DATA as follows:

sudo mount /dev/sda4/xubuntu* /mnt/DATA/

*I named the partition xubuntu

I received the following message:
"special device /dev/sda4/xubuntu does no exist (a path prefix is not a directory)"

I then tried /mnt/dev and it mounted temporarily. Then the trouble started when I tried to make it permanent.
 
Old 08-09-2017, 12:37 AM   #21
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Hi,
Here is what I did.
A.] I typed "sudo nano etc/fstab" as awesome machine suggested and got the following:

"File /etc/fstab"

And below:

"overlay/overlay rw 0 0
tempfs/tmp tmpfs nosuid, nodev 0 0"

B. I typed: "lsblk -f" and got the following:

"NAME FSTYPE LABEL UUID Mountpoint
sda
-sda1 vfat 7525-7C23
-sda2 ext4 672....a1
-sda3 swap 7c7....08 [SWAP]
-SDA4 EXT4 32E3 93
SR0 ISO9960 Linux Mint 18 Mate 64 bit

2016-06-28-13-48-35-00 /cdrom
loop0 squashf roms"

C. I typed "Gedit /path-to-fstab"

I got the same as in A.

Never got to see the faulty line but I didn't want t monkey around in case I made the problem worse!
 
Old 08-09-2017, 01:23 AM   #22
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Hi,
I got into my etc/fstab file but it was read-only. Anyway I printed a copy because I couldn't save it to file. For some reason I don't have the hash key so I will use + instead.

+<file system> <mount point> <type> <options> <dump> <pass>
+/was on /dev/sda2 during installation
UUID=b72def8d...d84a1/ ext4 errors=remount-ro 0 1
+/boot/efi was on /dev/sda1 during installation
UUID=7525-7C23 /boot/efi vfat umask=0077 0 1
+swap was on /dev/sda3 during installation
UUID=7c738...c08 none swap sw 0 0
+<file system> <mount point> <type> <options> <dump> <pass>
+/ was on /dev/sda4 when post installation
UUID="32e3a....b93" /data ext4 0 2"

Last 3 lines deal with my attempt to mount the new partition.
 
Old 08-09-2017, 01:09 PM   #23
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec and Dartmouth, Nova Scotia CANADA
Distribution: Arch
Posts: 1,253

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
Quote:
Originally Posted by RenH View Post
Hi,
I got into my etc/fstab file but it was read-only. ... Last 3 lines deal with my attempt to mount the new partition.
Hey RenH,

OK thanks for the clarification concerning Xubuntu. A couple of comments:
  • The output of your lsblk -f command confirms what you explained: You have an existing install on sda2 and are using sda3 as swap.
  • The output also shows the existence of the sda4 partition you created on which you wish to install Xubuntu
  • Looking at the contents of your fstab file, I agree that those last 3 lines are likely the problem. Either delete them or "comment" them out by placing a "#" caracter at the beginning of each of those lines.
  • You should be able to save the changes to fstab if you have opened it with sudo privlileges. Can you confirm that this is what you have done ?

Also, when posting output from commands or file contents, please use code tags to preserve formatting. This means enclosing your output between the following 2 "tags" (excluding quotation marks) : ["code"] and ["/code"].

Last edited by Rickkkk; 08-09-2017 at 01:15 PM.
 
Old 08-09-2017, 02:14 PM   #24
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Hallelujah! I commented out the last line and re-booted. Thank you.

I used the command:
[code] sudo gedit /etc/fstab [code] and got into the file for my system instead of for the live Disk.

But I still don't understand what I did wrong.
My goal was to divide the main partition [sda2], which I did [sda4]. Then I tried to mount sda4. And that is when the trouble started. I want to install xubuntu on sda4. Can you explain to me what is wrong with what i did?

Thank you for your help, and the others too.

I also think it's time I got my hands on Linux for Dummies.
 
Old 08-09-2017, 03:24 PM   #25
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec and Dartmouth, Nova Scotia CANADA
Distribution: Arch
Posts: 1,253

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
Quote:
Originally Posted by RenH View Post
Hallelujah! I commented out the last line and re-booted. Thank you.

I used the command:
[code] sudo gedit /etc/fstab [code] and got into the file for my system instead of for the live Disk.

But I still don't understand what I did wrong.
My goal was to divide the main partition [sda2], which I did [sda4]. Then I tried to mount sda4. And that is when the trouble started. I want to install xubuntu on sda4. Can you explain to me what is wrong with what i did?

Thank you for your help, and the others too.

I also think it's time I got my hands on Linux for Dummies.
Hey RenH,

Glad to hear you were able to edit your fstab and boot your system again - nice going.

For your questions, now:

What was the problem with your fstab entry ?

Could be a couple of things:
  • Error in the uuid you specified ... If it doesn't exist, the process will halt.
  • Mount point doesn't exist ... When you specify a permanent mount in fstab, the mount point (an empty directory) has to have already been created.
  • Invalid options ... You don't seem to have specified any ... Depending on the filesystem being mounted, there are usually a set of standard options, or the use of the catchall term "defaults".

Concerning what you need to do before installing Xubuntu
  • You don't need to mount anything before installing another distro. All you need is to have created a partition of the required size, which you have done (I am assuming the size part is right ...). You can even tell the installation to use any block of contiguous unallocated (unpartitioned) space if you want - it will create the partition (and then the filesystem ...).
  • You will specify during the Xubuntu installation that you want to install to sda4 - that's it. There are other more particular options available for those that want to create multiple partitions for /home and /var and such .. I don't recommend it for your situation.
  • The installation routine should detect that you already have an existing linux swap partition and set itself up to use that.

Concerning your boot loader
  • You will be asked at one point during the installation if you want to install a boot loader. This is a personal choice, but you should read up on the subject to understand what you are getting into.
  • You already have a boot loader installed from your existing linux system, and this can be edited to offer the choice of booting your 2nd linux system once it is installed.
  • If you choose to install a new boot loader during the Xubuntu installation, this one will prevail and depending on the options you used and the helper programs you had installed or not (namely os-prober), your initial boot after install may no longer show your previous linux system. Again, this can be corrected by editing the appropriate boot loader files.
  • I personally choose to not install additional boot loaders and simply edit my existing one to include the choice of the new OS in its menu.

Hope this helps. Please feel free if any explanation is required.

... OH ! and by the way, you have to add the forward slash before the word "code" in your closing code tag ...

Last edited by Rickkkk; 08-09-2017 at 03:53 PM.
 
1 members found this post helpful.
Old 08-11-2017, 02:44 PM   #26
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Thank you and I am sorry for the belated reply but I was busy Wednesday and Thursday and then I discovered that I couldn't use my password for the forum!

This is where it stands:

I noticed that the second partition appears under Devices on my home directory as "242 gig volume". I right clicked and it showed that it was not mounted. The mounting appears to be temporary because I mounted it yesterday. Also, yesterday when I tried to install Xubuntu it got to the point where it stated that the partition was not mounted. So it seems I'm back where I started. How to mount the second [242 gig] partition permanently.

It was at this point that I went to the web and followed instructions on how to mount and ended up hanging my system!
 
Old 08-12-2017, 02:08 AM   #27
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 5,594
Blog Entries: 16

Rep: Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318Reputation: 3318
Well, as you know, you need to put the device into fstab in order for it to automount at boot. And, as you also now know, syntax errors in fstab can prevent the system from booting properly. So you must find a way to navigate between these two possibilities. Be guided by the following principles:

1) Use the man page for fstab as your main authority on syntax rather than something you read on the Web. There's a lot of unreliable stuff posted out there.
2) Use a syntax-checking editor like gvim or gedit to do the actual editing. That way you will be able to see at once by the colours if you have edited a syntax error into the file.
3) Use the simplest possible syntax for your initial try. For example: don't use a UUID, use the device name /dev/sda4. Use "defaults" for the options. If it boots like that, you can pimp it up later.
4) Always save a copy of the original configuration file. I use the suffix .orig for the file that came with the system and .old for a previously edited copy that I know works.

Have fun!
 
Old 08-16-2017, 02:59 PM   #28
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Hi Hazel,
I was sidetracked with guests, but probably also willingly avoiding the issue! Anyway, after reading up on files, and /etc/fstab I did the following. Using Gedit I removed the offending entry, rebooted after saving to see that all was OK. So I was back to square one. Next, I mounted the second partition dev/sda4 on /mnt/DATA. Then to make it permanent I used Gedit again and made a new fstab file, which I called fstab.new In this I entered:
[code]/dev/sda4 /mnt/DATA /ext4 defaults[code/]
and saved.
I rebooted but the new partition was not mounted. So my question is I now have two fstab files: original and fstab.new. How do I get the system to use the new file [I'm assuming it used the original file since nothing has changed]?
 
Old 08-16-2017, 03:49 PM   #29
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec and Dartmouth, Nova Scotia CANADA
Distribution: Arch
Posts: 1,253

Rep: Reputation: 467Reputation: 467Reputation: 467Reputation: 467Reputation: 467
Quote:
Originally Posted by RenH View Post
Hi Hazel,
I was sidetracked with guests, but probably also willingly avoiding the issue! Anyway, after reading up on files, and /etc/fstab I did the following. Using Gedit I removed the offending entry, rebooted after saving to see that all was OK. So I was back to square one. Next, I mounted the second partition dev/sda4 on /mnt/DATA. Then to make it permanent I used Gedit again and made a new fstab file, which I called fstab.new In this I entered:
[code]/dev/sda4 /mnt/DATA /ext4 defaults[code/]
and saved.
I rebooted but the new partition was not mounted. So my question is I now have two fstab files: original and fstab.new. How do I get the system to use the new file [I'm assuming it used the original file since nothing has changed]?
Hi RenH,
  • Just so I understand, why is it that you want to mount your sda4 partition before installing your 2nd distro (Xubuntu) ? See my above (rather long .. sorry ..) post ...
  • You can't have more than one fstab file. If you want your changes saved as fstab.new to be used, rename your original fstab file (.. as fstab.original, for example ... your choice ...) and then rename your fstab.new file to fstab. This has to be done as root or with sudo or su. Needless to say, the fstab file must stay in the /etc/ directory. Furthermore, be sure your syntax is correct or you will end up with same problem, not being able to boot your system .. (at least now you know how to solve that ...).

Cheers,

Last edited by Rickkkk; 08-16-2017 at 03:52 PM.
 
1 members found this post helpful.
Old 08-17-2017, 01:27 AM   #30
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 158

Original Poster
Rep: Reputation: Disabled
Hi Rickkkk,
I can't explain why I wanted another partition except I was "following orders" -- had read somewhere to put my second distro (Xubuntu) in a separate partition. So I made a separate partition [/dev/sd4], made a new file /mnt/DATA as instructed, and tried to mount the second partition in /mnt/DATA.

Tried to install Xubuntu in /dev/sd4 but the system would announce that /dev/sd4 was not mounted. Realised that I had not made a permanent mount, hence my misadventure with /etc/fstab in my effort to make a permanent mount.

In my fstab.new I have this added entry:
[/code]/dev/sda4 /mnt/DATA ext4 defaults [code/]

This was copied from the file, so if it is correct then the entry should be correct. The next step would be to convert the fstab.new to fstab but I am hesitant. Is the entry correct? [I need someone to stand behind and give me a push...]

If you think I am going about it the wrong way, i.e., don't need a new partition, do let me know.

My goal is to see if 64-bit Xubuntu works as well as the 32-bit does on my laptop. I love Mint Sarah/Mate but I find it flaky.

Reasons:
1. Can't use VLC -- it hangs-- even worse now than before.
2. If I move a window too quickly across or down the screen the system hangs.
3. If I scroll too quickly within a window it hangs.

Someone said it was the graphic chip, and a friend suggested installing a new graphic card, which I intend to do.

If 64-bit Xubuntu works I would download another distro of Mint and see if it works because no one else seems to be having these problems. If all this does not work I will just stick to Xubuntu.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB boot menu does not appear after installation of Mint 15 mikebaiduu Linux - Newbie 2 12-30-2013 07:01 PM
Mint not appearing on the boot menu (Dual with Windows) Fruffles Linux - Newbie 2 07-14-2013 05:50 AM
Linux mint 12 freezes on grub boot menu Traversalan15 Linux - Newbie 1 10-25-2012 04:42 PM
To get back linux mint boot menu Debashis@Mint Linux Mint 2 04-29-2010 06:03 AM
Select boot options in shutdown menu? dominik81 Mandriva 7 02-21-2004 03:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 10:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration