LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-04-2017, 05:33 PM   #1
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Rep: Reputation: Disabled
Can't open Mint 18 and can't select e in boot menu


I partitioned my main partition in order to install Xubuntu, but the new partition sda4 was not mounted. [I thought I had written in on asking how to mount but it obviously did not go through]. After researching how to mount I learnt that mounting was pointing the partition to a directory. So I followed instructions and tried to mount to /mnt/DATA/ but the system rejected it stating that a path prefix is not a directory. [what is the prefix here?] So I tried mounting on /mnt and it mounted. I later discovered that it was a temporary mount.

So I followed instructions and used
getedit: gksU getedit /etc/fstab and entered UUID=32e.... ect4 defaults 0 2 and saved.

Well that was the last time I could open my computer! I got instructions on how to view system logs etc, but nothing happened. The telling message was:
[23.536179] EXT4-fs (sda4) Unrecognized mount option "0" or missing value.

I tried to follow two articles. The first advised to get into Boot menu and select "E" but nothing happens.

I was hoping to boot in and delete the offending line -- realized I should have used Save As. But I can't move the cursor down the list. I then tried a live disk of Mint18 Mate but the boot menu still ended up inert.

Please help!
RenH
 
Old 08-04-2017, 06:16 PM   #2
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 656

Rep: Reputation: 190Reputation: 190
Sounds like you have a misconfigured fstab. Boot from a live cd, mount the / partition, then re-edit fstab. If you can post it here, we may be able to help. Also, verbatim errors are very helpful.

Just to give you an idea, my entry in /etc/fstab for the root partition looks like so
Code:
UUID=uuid     /    ext4    errors=remount-ro        0       1

Last edited by TheEzekielProject; 08-04-2017 at 06:21 PM.
 
Old 08-05-2017, 12:42 AM   #3
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Thanks for replying. From memory, when I looked at the partitions with Gparted the / was with sda2. This was the original partition of 970 Gb or so. Using Gparted I divided it with a secondary partition of 200+ GB. I was trying to mount it, and got as far as seeing it mounted temporarily as /mnt/sda4 [or /mnt/dev/sda4] and yes I think I screwed up in /etc/fstab.

I was trying to "mount" the partition by following instructions [really don't know what I was doing].
I tried the live DVD but it took me to the Boot menu where the cursor froze on the top item. I'll try again and let you know.
Ren
 
Old 08-05-2017, 12:59 AM   #4
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Hi,
Even with Live boot I get to the boot menu and am then frozen. I can hear the DVD working but I can't select E or go down the menu. The same message comes up:
Welcome to Emergency Boot. After logging in type... but I can't log in.
What if I tried a Live xubuntu disk?
 
Old 08-05-2017, 01:02 AM   #5
TheEzekielProject
Member
 
Registered: Dec 2016
Distribution: Devuan+lxde
Posts: 656

Rep: Reputation: 190Reputation: 190
Quote:
Originally Posted by RenH View Post
Hi,
Even with Live boot I get to the boot menu and am then frozen. I can hear the DVD working but I can't select E or go down the menu. The same message comes up:
Welcome to Emergency Boot. After logging in type... but I can't log in.
What if I tried a Live xubuntu disk?
The fact that you are still getting an Emergency Boot message makes me think it's not booting your live cd and is instead still trying to boot the problematic install. How did you go about making the live cd? Is it the same one you tried installing from originally?

EDIT: any live disk should work fine. It does not have to be the same distro that's installed.

Last edited by TheEzekielProject; 08-05-2017 at 01:04 AM.
 
Old 08-05-2017, 08:16 PM   #6
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
It sounds like the keyboard isn't working during boot. You can try to enable, "legacy USB" in the BIOS setup program. You enter the BIOS setup by hitting either "delete", "F1", or "F2" right after powering on the machine. Usually it's the delete key, Is it a USB keyboard?
 
Old 08-07-2017, 07:00 PM   #7
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Oh my stupidity! The reason I couldn't move the cursor or anything was that the usb plug from my new keyboard had come loose!

I have booted in from lIVE DISK but I am not sure what to do next. I tried typing /etc/fstab but the computer wouldn't recognise it.

Earlier through the boot menu I managed to get this information:
"wrong fs type, bad option, bad [can't read my own writing]...block on /dev/sda4, missing codepage or helper program or other error"

It also asks for root password, but I am sure I only have my password [as superuser] but it does not recognise it.

I know I need to go in and delete the faulty entry for sda4 and then remount and save but how?
 
Old 08-07-2017, 09:14 PM   #8
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
Boot from a live DVD and edit /etc/fstab from there.
 
Old 08-08-2017, 01:53 AM   #9
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Hi and thanks. I tried cd /etc/fstab and it comes back saying /etc/fstab is not a directory. I tried going to /etc and typing fstab with no luck. What am I doing wrong?
 
Old 08-08-2017, 01:58 AM   #10
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Hi again. when I did a list on etc it showed fstab listed in white -- a file?
 
Old 08-08-2017, 07:59 AM   #11
AwesomeMachine
LQ Guru
 
Registered: Jan 2005
Location: USA and Italy
Distribution: Debian testing/sid; OpenSuSE; Fedora; Mint
Posts: 5,511

Rep: Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006Reputation: 1006
Try
Code:
$ sudo nano /etc/fstab
 
Old 08-08-2017, 08:36 AM   #12
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,234

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Just a precision here, RenH - when booting from a live CD or DVD, once you're in your live session, you must mount the hard disk partition on which you installed your linux system (unless the live session has already done this for you ...) and then edit the fstab on the hard disk and not the one from your live session.

If this makes no sense to you, just say so and we'll give you a hand.

Cheers :-)
 
Old 08-08-2017, 12:24 PM   #13
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware, OpenBSD
Posts: 3,918
Blog Entries: 11

Rep: Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171Reputation: 2171
Quote:
Originally Posted by RenH View Post
Hi and thanks. I tried cd /etc/fstab and it comes back saying /etc/fstab is not a directory. I tried going to /etc and typing fstab with no luck. What am I doing wrong?

Hi again. when I did a list on etc it showed fstab listed in white -- a file?
Yes, fstab is a file, located in the /etc directory. Since it's a file, you can't cd to it. cd stands for "change directory" so it has to take a directory name as its argument, not a filename.

To list a (small) file, use the cat command followed by the filename. For a large file, use more and it will list screen by screen.
 
Old 08-08-2017, 02:17 PM   #14
RenH
Member
 
Registered: Oct 2015
Location: Vancouver, BC Canada
Distribution: U of Manitoba - not sure
Posts: 154

Original Poster
Rep: Reputation: Disabled
Thank ye all!

Rickkkk I understand what you are saying, but I don't know how to mount the hd partition. It was [is] mounted to "/" but I assume that is for the mint on my hard drive.

It was "mounting" that got me into all my trouble. I had divided the hd partition [/dev/sda2] but then I had to mount the new partition [/dev/sda4], which I finally managed to after reading several articles on the web, but then I had to make it a permanent mount, and the trouble started... I now understand fully the maxim, "a little knowledge is a dangerous thing"!
 
Old 08-08-2017, 03:55 PM   #15
Rickkkk
Senior Member
 
Registered: Dec 2014
Location: Montreal, Quebec, CANADA
Distribution: Arch
Posts: 1,234

Rep: Reputation: 451Reputation: 451Reputation: 451Reputation: 451Reputation: 451
Quote:
Originally Posted by RenH View Post
Thank ye all!

Rickkkk I understand what you are saying, but I don't know how to mount the hd partition. It was [is] mounted to "/" but I assume that is for the mint on my hard drive.

It was "mounting" that got me into all my trouble. I had divided the hd partition [/dev/sda2] but then I had to mount the new partition [/dev/sda4], which I finally managed to after reading several articles on the web, but then I had to make it a permanent mount, and the trouble started... I now understand fully the maxim, "a little knowledge is a dangerous thing"!
Hey RenH - no worries - the good thing is that almost all problems can be fixed (some easier than others ..).

Making a mistake in editing fstab can indeed result in a non-bootable system, as you have found out. Happily, as others have suggested, it's relatively easy to boot a live system and edit the fstab on your hard disk so that it boots normally again.

I may have needlessly contributed to the confusion by telling you you had to make sure the partition on which you had installed Xubuntu was properly mounted somewhere after you booted up a live system. It is likely that this is done automatically. I'm afraid that as a user of Arch Linux, primarily, I've gotten used to doing most things manually. With most current popular distros, their live ISOs probably automatically mount any recognizable partitions on your hard disk.

After booting your live session, run the following command to determine which partition your Xubuntu system is on and what its mount point is:

Code:
lsblk -f
If you are comfortable interpreting the output of this command and are able to identify the above-mentioned partition and its mount point, you can go ahead and edit fstab:

Code:
<your text editor> /path-to-fstab
.. remove the changes you made (that are causing the problem), save and try rebooting from your hard drive.

If you aren't comfortable with the output of the lsblk -f command, post its output here and we'll give you a hand.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GRUB boot menu does not appear after installation of Mint 15 mikebaiduu Linux - Newbie 2 12-30-2013 08:01 PM
Mint not appearing on the boot menu (Dual with Windows) Fruffles Linux - Newbie 2 07-14-2013 06:50 AM
Linux mint 12 freezes on grub boot menu Traversalan15 Linux - Newbie 1 10-25-2012 05:42 PM
To get back linux mint boot menu Debashis@Mint Linux Mint 2 04-29-2010 07:03 AM
Select boot options in shutdown menu? dominik81 Mandriva 7 02-21-2004 04:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration