LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-26-2015, 02:37 PM   #1
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 193
Blog Entries: 16

Rep: Reputation: 33
Can't mount my CD/DVD drive


Somewhere along the line, LinuxMint has lost the ability to mount my CD/DVD drive. I've burned ISOs on this machine in recent memory, but I went to burn one today and it could detect but not mount my drive.

After doing a lot of searches on this subject, I tried this:

zaivala@zaivala-Inspiron-518:~ > sudo mount -t iso9660 /dev/scd0 /media/cdrom
[sudo] password for zaivala:
mount: mount point /media/cdrom does not exist
zaivala@zaivala-Inspiron-518:~ >

When I put a blank disk in my drive, the computer detects this fact and tells me to click to mount the drive, but the drive does not mount.

Any ideas what now?

I'm running a Dell Inspiron 518 00, 4 GB RAM, and am running LinuxMint 17.1 Rebecca 32-bit with KDE.

Last edited by zaivala; 11-26-2015 at 02:55 PM.
 
Old 11-26-2015, 05:31 PM   #2
jailbait
LQ Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Linux Mint 17, Debian 8
Posts: 7,865

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
In order to mount a CD/DVD it must have a file system on the CD/DVD. Therefore a blank CD/DVD is not mountable. The way that you burn a CD/DVD is to start the burn program and then insert a blank CD/DVD when the burn program asks you to.

-----------------------
Steve Stites
 
Old 11-26-2015, 11:44 PM   #3
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 193

Original Poster
Blog Entries: 16

Rep: Reputation: 33
Um, no. If this were the case, you'd never burn an ISO again. And I've burned several ISO disks on this computer, as stated previously.
 
Old 11-27-2015, 12:22 AM   #4
crazy-yiuf
Member
 
Registered: Nov 2015
Distribution: Debian Sid
Posts: 119

Rep: Reputation: 51
post edited a bunch because I'm dumb:
please post your /etc/fstab. here's the line for my cd:
Code:
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
If you want to keep trying to manually mount it, make sure /dev/scd0 is the correct device, then maybe try
Code:
mkdir /mnt/cd
mount -t udf,iso9660 -o user,noauto /dev/scd0 /mnt/cd

Last edited by crazy-yiuf; 11-27-2015 at 08:15 PM. Reason: dumbness
 
Old 11-27-2015, 07:18 PM   #5
tomwest
Member
 
Registered: Aug 2013
Posts: 58

Rep: Reputation: Disabled
Quote:
mount -t iso9660 /dev/scd0 /media/cdrom
....
mount: mount point /media/cdrom does not exist
If LinuxMint uses /media, or directories under that, as a mount point for it's auto mounts, I would use another mount point for manual mounting. You can make your own by creating as root something like:
/mounts/cdrom
and then mount your cdrom to that point. Nothing else will use it or know about it. The "does not exist" output may mean that the directory is not there. Mount points under /media may be tmpfs filesystems which means they don't persist over boots and only get created when needed. This contrasts with making your own mount point whose persistence and location in the filesystem you can pretty much fully control.

Last edited by tomwest; 11-27-2015 at 07:20 PM.
 
Old 11-27-2015, 07:51 PM   #6
Fred Caro
Senior Member
 
Registered: May 2007
Posts: 1,006

Rep: Reputation: 166Reputation: 166
Also,
check:
Quote:
ls /media
you may find the user name after it.
so the mount point might be:
Quote:
sudo mount -t iso9660 /dev/scd0 /media/fred/so-and-so
Does it play music/video cd's/dvd's ok? If yes, put one in and see where it mounts it with:
Quote:
mount
Fred.
 
Old 11-28-2015, 02:19 AM   #7
learnin2cocatinate
Member
 
Registered: Nov 2015
Posts: 41

Rep: Reputation: Disabled
not sure if this applies to your situation but i know on debian (which linuxmint is based on) theres an automount feature which is a default app thats called disks that will allow you to automount.
 
Old 11-28-2015, 11:19 AM   #8
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 193

Original Poster
Blog Entries: 16

Rep: Reputation: 33
Quote:
Originally Posted by crazy-yiuf View Post
post edited a bunch because I'm dumb:
please post your /etc/fstab. here's the line for my cd:
Code:
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto 0 0
Because I'm stupid, I'm not thinking what command to use to run fstab to get this. I definitely have fstab, and it's definitely in my /etc directory, but the stupid things I'm trying are not resulting in a listing.
 
Old 11-28-2015, 11:23 AM   #9
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 193

Original Poster
Blog Entries: 16

Rep: Reputation: 33
Quote:
Originally Posted by Fred Caro View Post
Does it play music/video cd's/dvd's ok? If yes, put one in and see where it mounts it with:


Fred.
Some gaps in that, but yes, it plays CDs and DVDs fine. Where it mounts it with? Not precise enough English for my morning parser.

I started this with the idea that the problem was with K3b, and it still may be. The computer reports the blank DVD's existence, but K3b doesn't register it. The stupidest thing would be that I only had a CD/DVD-R, but no, the computer reports it as a DVD +/-.
 
Old 11-28-2015, 11:29 AM   #10
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 193

Original Poster
Blog Entries: 16

Rep: Reputation: 33
I have new information. What may be happening is that D3B detects that the file is too large for the medium. How sad. "Capacity exceeded by 178.4 MiB." I don't know why, as the download was supposedly created for the express purpose of being a multiple live CD.

So the problem is not with my computer, drive, or OS, but with the downloaded file being too large.

Just FYI, the file is the latest linuxaio-ubuntu14043-mix.iso
 
Old 11-28-2015, 11:47 AM   #11
crazy-yiuf
Member
 
Registered: Nov 2015
Distribution: Debian Sid
Posts: 119

Rep: Reputation: 51
Edit: ah, yes, I've had that happen. CDs come in different sizes, I believe. There may be a netinst option available, assuming you'll have an ethernet connection available when you're doing the install.

To get your fstab run:
Code:
sudo cat /etc/fstab
To get your currently mounted drives just run
Code:
sudo mount
If you can play music then the drive is definitely mounted, it's just a matter of making sure k3b can find it, and that the blank disk doesn't have any scratches, etc. I haven't used k3b but from googling there is a setting that looks like this:

Readonly Devices: none
Writer Devices: none

Do you see that settings? If so, tell us what they are set to, and the results of:

Code:
sudo ls -l /media
sudo cat /etc/fstab
ls -1 /dev | grep ^[^t]

Last edited by crazy-yiuf; 11-28-2015 at 11:49 AM.
 
Old 11-28-2015, 11:59 AM   #12
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 17
Posts: 5,845
Blog Entries: 21

Rep: Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923Reputation: 2923
Code:
groups
to make sure cdrom is in there?
 
Old 11-28-2015, 11:51 PM   #13
zaivala
Member
 
Registered: Mar 2008
Location: Blaine TN USA
Distribution: Linux Mint 19.1, Bodhi 5, Ubuntu Budgie 19.04, others
Posts: 193

Original Poster
Blog Entries: 16

Rep: Reputation: 33
zaivala@zaivala-Inspiron-518:~ > sudo ls -l /media
total 4
drwxr-x---+ 5 root root 4096 Nov 29 00:09 zaivala
zaivala@zaivala-Inspiron-518:~ >


zaivala@zaivala-Inspiron-518:~ > sudo cat /etc/fstab
[sudo] password for zaivala:
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
# / was on /dev/sda1 during installation
UUID=d1bec1bd-7a15-4f9b-886b-ded74e2bc71e / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=152c2903-d386-4b62-a05a-564ba26a867d none swap sw 0 0
zaivala@zaivala-Inspiron-518:~ >

the third one is quite long...

zaivala@zaivala-Inspiron-518:~ > ls -1 /dev | grep ^[^t]
autofs
block
bsg
btrfs-control
bus
cdrom
char
console
core
cpu
cpu_dma_latency
cuse
disk
dri
ecryptfs
fb0
fd
full
fuse
fw0
hidraw0
hidraw1
hidraw2
hidraw3
hidraw4
hidraw5
hidraw6
hpet
input
kmsg
kvm
log
loop0
loop1
loop2
loop3
loop4
loop5
loop6
loop7
loop-control
mapper
mcelog
mem
net
network_latency
network_throughput
null
port
ppp
psaux
ptmx
pts
ram0
ram1
ram10
ram11
ram12
ram13
ram14
ram15
ram2
ram3
ram4
ram5
ram6
ram7
ram8
ram9
random
rfkill
rtc
rtc0
sda
sda1
sda2
sda5
sdb
sdb1
sdc
sdc1
sg0
sg1
sg2
sg3
shm
snapshot
snd
sr0
stderr
stdin
stdout
uhid
uinput
urandom
usb
v4l
vcs
vcs1
vcs2
vcs3
vcs4
vcs5
vcs6
vcs63
vcs7
vcs8
vcsa
vcsa1
vcsa2
vcsa3
vcsa4
vcsa5
vcsa6
vcsa63
vcsa7
vcsa8
vga_arbiter
vhci
vhost-net
video0
zero
zaivala@zaivala-Inspiron-518:~ >

Last edited by zaivala; 11-28-2015 at 11:52 PM.
 
Old 11-29-2015, 12:56 AM   #14
crazy-yiuf
Member
 
Registered: Nov 2015
Distribution: Debian Sid
Posts: 119

Rep: Reputation: 51
Ah, sorry, I had posted that before I saw your other post. I left it there just in case you were still curious, since the device does seem to be mounting. There's nothing you can do other than use a smaller file or a bigger storage medium.

The interesting bits, if you were still having problems mounting, is that your cd drive is named /dev/sr0, that your fstab isn't set up to mount it the usual way (or at least the way I'm used to), and that it's not mounted to the usual spot.

Last edited by crazy-yiuf; 11-29-2015 at 12:59 AM.
 
Old 11-29-2015, 07:55 PM   #15
Fred Caro
Senior Member
 
Registered: May 2007
Posts: 1,006

Rep: Reputation: 166Reputation: 166
wrong post

Last edited by Fred Caro; 11-29-2015 at 08:06 PM. Reason: confused posts
 
  


Reply

Tags
linuxmint, mount


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dvd rom drive won't mount under FC14 after installing from dvdrom drive bgovan Linux - Newbie 5 06-13-2011 04:48 PM
Mount DVD RW drive sparckis Linux - Newbie 2 01-21-2007 09:22 PM
Cant mount Dvd-Drive(s) DeanAL Linux - Hardware 1 03-12-2006 03:41 PM
DVD Drive and CDRW Drive Will not mount on Slackware 10.1 Kernel 2.6.1 necrozen Linux - Hardware 1 09-13-2005 08:21 PM
can't mount a dvd on a cd burner/dvd rom drive dr_zayus69 Linux - Hardware 7 12-09-2004 08:56 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration