LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-25-2003, 04:26 PM   #16
Shachaf
Member
 
Registered: Sep 2003
Location: Port Townsend, WA
Posts: 30

Rep: Reputation: 15

You can switch to another tty from X with the switchto command as root (sudo switchto 1, for example). See if that works.

P.S. See http://lfs.oregonstate.edu/hints/dow...AT/numlock.txt for details on changing numlock when starting X.
 
Old 10-27-2003, 06:41 PM   #17
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
I don't seem to have that command....

I've tried switching to root and running it, and nothing, and "sudo swictchto 1" asks me for a password, but when I type root's password, it just says to "try again", and it doesn't work.. (I use "su" and type root's pass, and it works, so... is it a different pass??? I think I haven't set up any other pass for root than the login one....)
 
Old 10-27-2003, 07:15 PM   #18
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
what if you just su, and then use the command switchto?

Also, I found in the man page of XF86Config:
ServerFlags:
Option N'34'DontVTSwitchN'34' N'34'booleanN'34'
This disallows the use of the Ctrl+Alt+Fn sequence (where Fn refers to one of the numbered function keys). That sequence is normally used to switch to another oqvirtual terminal)cq on operating systems that have this feature. When this option is enabled, that key sequence has no special meaning and is passed to clients. Default: off.

So maybe there is something in your XF86Config XF86Config-4 that disallows swichting to a VT. Look for a line that contains "Don'tVTSwitch". If you find it, just delete it (after backing up your config file, of course). Since the default is off, if this is the cause of the problem, you should be fine again.
 
Old 10-28-2003, 12:02 PM   #19
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
I don't have that line either... I've tried "su" first, and then the command, but it says I don't have it... That's why I'm going crazy... I look and I look, and I don't see nowhere a line that suggests this thing is disabled... When I start X, i don't have the numlock led turned on, but the keypad just types numbers, no matter if I press the NumLock key or not (it always stays off, but prints numbers) and I cant use the period (".") of the keypad, as it's like a dead key... it does nothing... I tried looking at Xmodmap or xbd, to see if inside those files I could find a line disabling the Ctrl-Alt-Fn sequence, and mapping all numpad keys to numbers always (and disabling the period-key...), but I haven't found any!!!
 
Old 10-28-2003, 05:05 PM   #20
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
hmmmmm. it's really odd. Have you tried using a different desktop environment? Say KDE instead of redhat's version of gnome? Maybe it's not X but one of the DE's since you say at the login screen it's all right (X is already running at that point).
 
Old 10-29-2003, 08:13 PM   #21
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
quatsch, I hadn't tried that.... and it worked!! from KDE (I use GNOME) Ctrl-Alt-Fn does work!! So I think I must've messed up with GNOME config files, and that is something I don't know anything about... maybe downloading the latest GNOME and reinstalling will do... Unless you know what files could I check (in my home dir, I've searched all folders and the files they contain, which start with .gnome* (.gnome, .gnome2, .gnome2_private)


Thanks for the idea of checking other DE's!!!!
 
Old 10-29-2003, 09:05 PM   #22
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
If you don't mind reconfiguring Gnome, I think all you need to do is to remove the .gnome* files/directories (or just move them somwhere else). I'm pretty sure next time you start gnome, gnome will recreate them with all the default settings.
 
Old 10-29-2003, 10:19 PM   #23
Joey.Dale
Member
 
Registered: Jun 2003
Location: Tampa, Fl
Distribution: Gentoo, Slackware
Posts: 828

Rep: Reputation: 30
Quote:
you could delete all the .x and .X files in your home dir
Or you could delete them all as root. not really

Edit your initab file so it starts inrunlevel 3, them after you login just type startx

Last edited by Joey.Dale; 10-29-2003 at 10:22 PM.
 
Old 10-29-2003, 11:20 PM   #24
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
???

what's wrong with deleting some of the config files in a user's home directory? they'll get recreated automatically... I do it all the time to save annoying editing.
 
Old 11-01-2003, 07:17 AM   #25
kn0t
LQ Newbie
 
Registered: Oct 2003
Location: Madrid
Distribution: Red Hat 9
Posts: 14

Original Poster
Rep: Reputation: 0
Smile

Thanks a lot quatsch!!!!!!!!!

I tried what you told me from KDE, and it worked... and somehow, that must've changed something.... and now it works again from GNOME!!!!

I'm still trying to figure out why my Num Lock led is always off, and even though NumLock is activated (I only can use the numpad for numbers), but I can't use the period (which I use a lot to type IP's, and numbers....)
 
Old 11-01-2003, 07:57 AM   #26
dragos_avram
LQ Newbie
 
Registered: Nov 2003
Location: Bucharest, Romania
Distribution: RH 9
Posts: 3

Rep: Reputation: 0
Hi,

I had the same problem you described... but when I set to the romanian keyboard (as I live in Romania) it worked switching to the console. When I set the US keyboad back, the problem appears again

When I set the RO keyboard, the num lock key gets active, too :-)

I think there may be a problem with the US keyboard layout in gnome, either itself or the combination with the second layout.

Dragos
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Run Win32 Console App in linux Console Lokie Linux - Software 2 08-12-2004 11:00 PM
console term789 Red Hat 2 09-30-2003 01:11 PM
X server in console 1 crashes on return from console 2 fieldmethods Red Hat 4 09-05-2003 01:12 AM
Getting into console Pixel Linux - Newbie 2 03-01-2003 02:22 PM
console jayakrishnan Linux - General 3 08-24-2002 12:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration