LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-22-2002, 09:06 PM   #1
newbix
Member
 
Registered: Oct 2002
Distribution: RedHat 9
Posts: 43

Rep: Reputation: 15
can't get CD player to work


Hi,

I'm sloooowly winning the battle to get sound under my Linux partition, I've downloaded a test driver from 4Front and I'm able to play short .wav files using xmms, so I know I can get some sound.

I'd like to be able to play CD's next, but so far I haven't been able to. I know the CD player itself works fine because I can use it under the windows partition. The default GNOME player pops up when I insert an audio CD, the tracks appear and remaining time counts down, but no sound. I've checked the sound levels using the GNOME audio mixer and everything looks fine.

I've looked around other posts on this subject in the forums, and I tried "depmod -ae", but that didn't help.

does anyone out there know how to get the GNOME default CD player to work properly?

Many thanks in advance
 
Old 10-23-2002, 04:06 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975Reputation: 1975
do you have an audio cable connected? linux doesn't use digital audio extraction yet, so the sound needs to go direct from the drive to the sound card
 
Old 10-23-2002, 04:30 AM   #3
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Most of the mixers available in Linux have a seperate volume control for the cd player.Its usually turned down by default in some distros.Try turning it up.
lynch
 
Old 10-23-2002, 03:10 PM   #4
lopoetve
Member
 
Registered: Aug 2001
Distribution: Too many.
Posts: 102

Rep: Reputation: 15
Quote:
Originally posted by lynch
Most of the mixers available in Linux have a seperate volume control for the cd player.Its usually turned down by default in some distros.Try turning it up.
lynch
Where is this found? I've had a similar problem, even with the right cable connected.
 
Old 10-23-2002, 11:01 PM   #5
newbix
Member
 
Registered: Oct 2002
Distribution: RedHat 9
Posts: 43

Original Poster
Rep: Reputation: 15
Thank you for your replies,

now let's see if I can show off my ignorance.

Regarding the cable issue, I'm not really sure if that applies in my case, I don't have an actual sound card, rather (as far as I can tell) I have an integrated sound chip which is part of the intel 845 chipset. In other words, I'm not sure exactly where I'd plug the cable in since there is no sound card in any expansion slot. On the other hand, since I'm not completely hardware-literate yet, a missing audio cable may very well be the problem. Is there a HOW-TO or a web site I can go to that might have pictures so I can see where to connect it on the motherboard?

As to the mixer volume problem, I've raised all the volumes in the mixer, including the CD's, but no joy .

Thanks for your help, looking forward to your suggestions

P.S.: I don't know if this is relevant, but the CD player in question is an internal CD-RW drive

Last edited by newbix; 10-23-2002 at 11:20 PM.
 
Old 10-24-2002, 07:50 AM   #6
newbix
Member
 
Registered: Oct 2002
Distribution: RedHat 9
Posts: 43

Original Poster
Rep: Reputation: 15
one more thought...

To lynch just to make sure I haven't missed your point, and to lopoetve although I don't think this will be much help, but here goes:

The volume settings I've been playing with are the ones in the audio mixer under the Programs>Multimedia menu in the GNOME window manager. It's essentially the gmix program which I can also bring up from a terminal window. The graphical interface in the program has sliders to set the volumes on various devices, including sliders for the CD. I've moved up all the sliders near the middle position and verified that the "mute" option is not clicked in for anything. I've also tried using the mixer (ossxmix) that came with the 4front sound driver I downloaded but that didn't help....

Is there a separate program specifically for the CD that overrides this?

Thanks
 
Old 10-24-2002, 09:35 AM   #7
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
Ok, make sure /dev/cdrom points to /dev/hdX where X is your cdrom device. Then chmod 666 /dev/audio. (All as root)
Then type locate *.au
and cat /path/to/anyfile.au > /dev/audio
If that gives you sound output then the cdrom should work too, if it doesnt then most likely your integrated sound card isn't conected to the cdrom directly. Get a appropriate cable and connect it, if the sound card at all has a socket to connect to cdrom directly. If it doesnt i dunno how to help...
HTH
NSKL
 
Old 10-24-2002, 04:25 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
http://masterc.freeservers.com/Projects/PCBuild.html

Head over there and click the picture of the motherboard. The white plug near the midi port (the yellow port on the sound card) is one of the sound plugs for the sound card. You might see a green one, or black one as well. You need to plug a cable from the back of your ROM to that point on the board. The cables usually come with both a motherboard and a soundcard. If you don't have one, take your drive to a computer store, and say you need an audio cable to connect to your soundcard. They SHOULD know what you need, especially if you show them the back of your drive. It's the plug marked audio

Cool
 
Old 10-24-2002, 04:47 PM   #9
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Yeah,you got it. There's also a volume control on some of the cd playing apps for Linux but they're usually already cranked up
I'm inclined to agree on the audio cable.
lynch

Last edited by lynch; 10-24-2002 at 04:49 PM.
 
Old 10-24-2002, 08:14 PM   #10
newbix
Member
 
Registered: Oct 2002
Distribution: RedHat 9
Posts: 43

Original Poster
Rep: Reputation: 15
outstanding

Thanks MasterC, I've located the (4-pin) plug on my motherboard and first thing this weekend I'll invest in an audio cable and give it another try.

To NSKL, I tried your test and it worked right off the bat; implying that the CDROM device is properly linked. So as you suggested, that seems to further support the missing cable theory.
I did have a question just for my own education: in my case the cd rom device is linked to /dev/scd0, which I'm guessing stands for a scsi device. If that link hadn't already been there, how would I have known what the right link is? Is there a program that will help me identify the right device or is it just a question of going down the list of usual suspects until I get sound?

In any case, I'll try the cable next and report back. Many thanks!
 
Old 10-24-2002, 08:41 PM   #11
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Cool, actually it was Acid who correctly identified this with the first response, I just clarified what he said more

As for knowing what your device is called, it's actually not a guess at all...

/dev/hdx is all your drives that aren't using scsi emulation or aren't actually scsi's (well at least on a standard system). The chart goes:

/dev/hda = Primary Master
hdb = Primary Slave
hdc = Secondary Master
hdd = Secondary Slave

So Master and Slave are set with the jumpers on the back of the drive itself, and Primary and Secondary are the channels which the IDE cables plug into on the mobo.

For SCSI, it's pretty much the same, except numbered. So it starts scd0 then scd1 and so on, at least that's my understanding. I only use scsi as emulation for my IDE burner, and I can specify that in my LILO file as to which scsi device I want to be my burner and which to be my CDROM, so my SCSI knowledge ends there.

Cool
 
Old 10-26-2002, 06:36 PM   #12
newbix
Member
 
Registered: Oct 2002
Distribution: RedHat 9
Posts: 43

Original Poster
Rep: Reputation: 15
success!

I plugged the cable in, slipped a music CD into the drive, and it worked like a charm.

Many thanks once again to everyone who replied

On to the next thread...
 
Old 10-26-2002, 07:06 PM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Cool, glad you got it working
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apollon Player doesn't work Lier Linux - Software 4 04-10-2006 12:00 AM
Gnome cd player won't work srcosmo Debian 2 07-06-2005 05:21 PM
'Use external player:' in kcontrol doesn't work?!? nostromo Mandriva 2 09-19-2004 09:08 AM
need help getting a media player 2 work on my pc Dro Linux - Software 4 05-16-2004 12:26 PM
Cd PLAYER doesn't work.... oicdn Linux - Software 3 01-22-2004 06:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration