LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-25-2005, 03:17 PM   #1
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Rep: Reputation: 15
Can't disable XMMS opengl spectrum analyzer plugin


Whenever I try to close the opengl spectrum analyzer window or uncheck activate plugin box for it (under options->preferences-visualization plugins), xmms closes and the pluggin is still on when I restart. Is there any way I can disable that pluggin?

(sorry if this belongs under the general forum or somenhere else)
 
Old 05-25-2005, 04:07 PM   #2
mugstar
Member
 
Registered: Jun 2004
Location: Scotland
Distribution: Anything that'll install...
Posts: 305

Rep: Reputation: 30
In a console, do
Code:
ps ax | grep xmms
- you should see output similar to
Code:
24801 ?        Sl     0:00 xmms
24855 pts/1    S+     0:00 grep xmms
Then do
Code:
kill 24801
replacing 24801 with whatever number you get.

What you're doing is identifying the process ID belonging to xmms, and then sending the system a direct command to kill it.

To prevent it happening again, right click on the xmms player, -->visualisation--> visualisation plugins, highlight the relevant plugin and uncheck the 'enable' box.

Last edited by mugstar; 05-25-2005 at 04:10 PM.
 
Old 05-25-2005, 04:25 PM   #3
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
That doesn't work.

Quote:
Originally posted by mugstar
What you're doing is identifying the process ID belonging to xmms, and then sending the system a direct command to kill it.
Why would I need to do that? XMMS closes fine.

Quote:
Originally posted by mugstar To prevent it happening again, right click on the xmms player, -->visualisation--> visualisation plugins, highlight the relevant plugin and uncheck the 'enable' box. [/B]
Like I said, I already tried that and when I do the whole of xmms closes.
 
Old 05-25-2005, 04:39 PM   #4
Boow
Member
 
Registered: Feb 2004
Distribution: Slackware 10.2
Posts: 669

Rep: Reputation: 32
try editing the .xmms/config file
 
Old 05-25-2005, 04:55 PM   #5
undeaf
Member
 
Registered: Feb 2005
Distribution: Suse Suse 10.1, Xubuntu 7.1
Posts: 44

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Boow
try editing the .xmms/config file
I couldn't find it.

I managed to deactivate it another way: temporarily renaming the file:/usr/lib/xmms/Visualization/libogl_spectrum.so file.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how can i create a simple frequency spectrum from a sound playing like in XMMS dipumurti Programming 1 05-07-2004 05:36 AM
xmms spectrum analyser question edM Slackware 0 03-25-2004 06:28 PM
Xmms Plugin 1.2.8 [xmms-config problem] MDMA Mandriva 2 01-29-2004 09:55 AM
XMMS Open GL Spectrum analyzer not working... Bensoft Kill MS Linux - Software 0 11-21-2003 03:04 PM
XMMS analyzer LandRoverMan Linux - Software 0 06-09-2003 12:43 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 11:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration