LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-06-2017, 09:13 AM   #1
vbmark
Member
 
Registered: Nov 2004
Distribution: Mandrake 10.1
Posts: 59

Rep: Reputation: 15
Can't disable autologin


I am using KDE on Ubuntu and would like to try Gnome but I cannot disable autologin.

Unchecking the box in system settings won't stick. It just changes back.

I created a lightdm.conf file and added

Code:
[SeatDefaults]
autologin-user=
But no change.

I also tried running:

Code:
kdesudo systemsettings
But nothing starts.

Why else can I try?

Thank you.
 
Old 04-06-2017, 12:35 PM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 4,003
Blog Entries: 1

Rep: Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847Reputation: 847
$ sudo -s
# echo "false" > /etc/X11/default-display-manager
# exit
(disables the gui login)

$ sudo systemctl --set-default multi-user.target
(where graphical.target is the default)
(also disables the gui login)

not sure if that's what you want, but an option.

Last edited by Shadow_7; 04-06-2017 at 12:37 PM.
 
Old 04-07-2017, 06:05 AM   #3
beroal
LQ Newbie
 
Registered: Feb 2016
Location: Ukraine
Distribution: ArchLinux
Posts: 26

Rep: Reputation: Disabled
This is what I have in my "/etc/lightdm/lightdm.conf".
Code:
[Seat:*]
allow-guest=false
autologin-guest=false
 
Old 04-07-2017, 09:43 AM   #4
cepheus11
Member
 
Registered: Nov 2010
Location: Germany
Distribution: Gentoo
Posts: 286

Rep: Reputation: 89
Is lightdm even active as display manager? Please post the output of

Code:
inxi -Fxxz
If command not found, install the package "inxi".
The output will tell many system configuration properties, including the active display manager.

Quote:
kdesudo systemsettings
The command is "systemsettings5".
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
parted magic disable autologin psyxos Linux - Newbie 2 06-05-2014 02:48 AM
[SOLVED] how to disable autologin in Mandriva 2010 Live zebra90210 Linux - Software 1 08-12-2012 08:07 PM
LXer: How to enable or disable autologin in Linux Mint 13 LXer Syndicated Linux News 0 07-08-2012 10:50 AM
Disable casper autologin on remastered Ubuntu 10.04 LiveCD Canadian1296 Linux - General 2 12-05-2011 10:07 PM
Autologin??? jakob_g Linux - Newbie 3 02-23-2006 07:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:05 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration