LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2005, 04:16 PM   #1
Tristan9669
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Rep: Reputation: 15
Can't delete folders made by XP under unbunu on fat32 partition


I created a fat32 partition and I moved some folders in it with XP and when I'm under ubuntu it wont let me delete the folders or its contents. It also has a lock icon on the folders made by xp
http://img361.imageshack.us/img361/1798/error8pp.png
http://img361.imageshack.us/img361/7955/lock7wl.png
 
Old 08-10-2005, 04:29 PM   #2
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
You may need to mount the partition so you have write permissions. Add "umask=000" to the mount options in /etc/fstab, and remount the drive. Or 'mount -o remout,umask=000 /media/G'.
 
Old 08-10-2005, 04:35 PM   #3
Grobbendonk
LQ Newbie
 
Registered: Jul 2004
Posts: 20

Rep: Reputation: 0
First thing to check is that the mount command you've used to mount the disk has the correct permissions.

So, just type mount to see what is mounted (and where) - I've got a FAT32 disk on my machine...

/dev/hda1 on /mnt/xp/C type vfat (rw,noexec,nosuid,nodev,gid=100,umask=0002,utf8=true)

Note the rw on the beginning of the options - it means "mount read/write"

My /etc/fstab says
/dev/hda1 /mnt/xp/C vfat users,gid=users,umask=0002,utf8=true 0 0


Second (and this is the one that I always miss!), make sure your user has write privilege on the actual mount point.

nic@avon:~> ls -l /mnt/xp
total 24
lrwxrwxrwx 1 root root 1 2005-05-27 16:19 c -> C
drwxrwxr-x 23 root users 4096 1970-01-01 01:00 C

(I've got a symbolic link because I use software that is occaisionally case sensitive)

If it's not the mount point, or the mount command, then it's a bit more difficult - let us know if it's neither of these!
 
Old 08-10-2005, 04:40 PM   #4
Tristan9669
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Matir
You may need to mount the partition so you have write permissions. Add "umask=000" to the mount options in /etc/fstab, and remount the drive. Or 'mount -o remout,umask=000 /media/G'.
didnt work, same problem

Last edited by Tristan9669; 08-10-2005 at 04:42 PM.
 
Old 08-10-2005, 04:47 PM   #5
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
Please post the output of the 'mount' command, as well as ls -l /media/G.
 
Old 08-10-2005, 04:50 PM   #6
Tristan9669
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Grobbendonk

Second (and this is the one that I always miss!), make sure your user has write privilege on the actual mount point.

nic@avon:~> ls -l /mnt/xp
total 24
lrwxrwxrwx 1 root root 1 2005-05-27 16:19 c -> C
drwxrwxr-x 23 root users 4096 1970-01-01 01:00 C

(I've got a symbolic link because I use software that is occaisionally case sensitive)

If it's not the mount point, or the mount command, then it's a bit more difficult - let us know if it's neither of these!
I don't understand what youre say here in the last part. Also, how do I check if I have write privilege on the mount
here is how my /etc/fstab looks like
/dev/hda5 /media/G vfat iocharset=utf8,umask=000 0 0
 
Old 08-10-2005, 05:04 PM   #7
Tristan9669
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Matir
Please post the output of the 'mount' command, as well as ls -l /media/G.
tristan@TRISTAN:~$ mount
/dev/hdb1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/hda5 on /media/G type vfat (rw,iocharset=utf8,umask=000)
/dev/hda1 on /media/C type ntfs (rw,nls=utf8,umask=0222)
/dev on /.dev type unknown (rw,bind)
none on /dev type tmpfs (rw,size=5M,mode=0755)
usbfs on /proc/bus/usb type usbfs (rw)
tristan@TRISTAN:~$ mount -l /media/G
mount: according to mtab, /dev/hda5 is already mounted on /media/G
mount failed
tristan@TRISTAN:~$
 
Old 08-10-2005, 09:16 PM   #8
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
ls -l /media/G, not mount -l
 
Old 08-11-2005, 04:55 PM   #9
Grobbendonk
LQ Newbie
 
Registered: Jul 2004
Posts: 20

Rep: Reputation: 0
>I don't understand what youre say here in the last part.
No problem, I'm not great at explaining stuff!

Anyway, you've given us more to go on - this line from your "mount" display is useful and tells us that there's nothing wrong with your fstab (although many would recommend changing the umask to 002). The rw on the /dev/hda5 line means "this partition accepts read and write access". So it's not that, it must be permissions on something else.

The next one - as Matir says, we need to see the result from ls -l /media

What we're looking for is the permissions on the mount point. The mount point is an existing directory which is effectively overlaid with the root of the partition when the mount command is issued. The problem I was trying to explain was that when the mount happens, the permissions of the mount point apply to the newly mounted partition.

When you created the mount point ( /media/G ) it's quite likely that it was created with read-only permissions (except for the root user), and to allow the user tristan to write/delete, you need to open these up a bit!
 
Old 08-11-2005, 06:20 PM   #10
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
Actually, mount point permissions are completely overriden by mount options (and, on *nix filesystems, the filesystem itself). But still, seeing permissions for the top-level directory and contents would be useful.
 
Old 08-11-2005, 07:17 PM   #11
Tristan9669
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
I got everything to work, thanks for the help
 
Old 08-11-2005, 07:39 PM   #12
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
Tristan9669: Glad to hear that you got it to work. Mind sharing your solution that we and others may be enlightened by it?
 
Old 08-11-2005, 08:02 PM   #13
Tristan9669
LQ Newbie
 
Registered: Jun 2005
Posts: 23

Original Poster
Rep: Reputation: 15
I can't belive I didn't think of it before, I boot up xp and deleted the folders that were locked (some wren't) and then I boot back in ubuntu and mounted the fat32 partition and then mounted the ntfs partition that I originally copied the files from under xp and I then copied the files from the ntfs partition to the fat32 partition.
 
Old 08-11-2005, 08:08 PM   #14
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 124Reputation: 124
A bit of a workaround, but hey, whatever works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux made HD ext3...trying to get it back to FAT32... Superion Linux - Newbie 6 09-27-2005 01:15 PM
Can't delete Folders. duffmckagan SUSE / openSUSE 1 09-19-2005 12:09 PM
Made a new fat32 partition but cant see it in Linux PenguinMolester Linux - General 2 02-27-2004 03:05 PM
Can you delete folders after ./configure ? iLLuSionZ Linux - Newbie 2 11-19-2003 08:39 PM
Am I able to delete folders after install? SuSE_Surfer Linux - General 6 10-18-2003 12:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration