LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-12-2013, 07:05 PM   #1
Farkuldi
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Rep: Reputation: Disabled
Can't boot Ubuntu, new install with GMA600 graphics


I have a Viewsonic tablet with an Intel Oaktrail processor the GMA600 graphics processor. I read here that as of the 12.04 release, the driver for this processor would be included in Ubuntu, and it should work. However, after I installed 12.10, it will not boot.

First it gave me this error:

Code:
[   <bunch of numbers>] ieee80211 phy0: uap0: changing to 2 not supported
[   <bunch of numbers>] ieee80211 phy0: uap0: changing to 2 not supported
[   <bunch of numbers>] ieee80211 phy0: uap0: changing to 2 not supported
[   <bunch of numbers>] ieee80211 phy0: uap0: changing to 2 not supported
The only thing I was able to find through Google about this was a document I don't understand. It's here:

http://dev.laptop.org/ticket/12197

Then I tried to boot it in recovery mode, and it did the strange graphics thing which is described in the above document about the Poulsbo graphics where half the screen is distorted.

Thanks for any help.

Last edited by Farkuldi; 04-13-2013 at 09:45 AM. Reason: correct GPU (600 not 500)
 
Old 04-12-2013, 11:02 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,988

Rep: Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217
The GMA500 is junk but I managed to get it working (2D only) on prior versions of Ubuntu with the (then) new in-kernel support. Try adding the "console=tty1" to the boot line manually from the boot screen. Then if that fixes it, do the update mentioned in the Ubuntu wiki.
I can't find that old netbook at the moment, but if/when I find it I'll do some testing.

I suspect those messages are informational only - may be a problem with the network, or not. Sort the screen out and see what you get.

Edit: See this for how-to on grub2 - go down to the "Editing the GRUB 2 Menu During Boot" section.

Last edited by syg00; 04-12-2013 at 11:27 PM.
 
Old 04-13-2013, 10:04 AM   #3
Farkuldi
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
The GMA500 is junk but I managed to get it working (2D only) on prior versions of Ubuntu with the (then) new in-kernel support. Try adding the "console=tty1" to the boot line manually from the boot screen. Then if that fixes it, do the update mentioned in the Ubuntu wiki.
I can't find that old netbook at the moment, but if/when I find it I'll do some testing.

I suspect those messages are informational only - may be a problem with the network, or not. Sort the screen out and see what you get.

Edit: See this for how-to on grub2 - go down to the "Editing the GRUB 2 Menu During Boot" section.
Thanks for your reply. I'm sorry, I realized when I read your post that I listed the wrong GPU. It's the GMA600, not GMA500. I edited my post to correct this. From what I have read, though, I don't think there would be a difference.

I tried adding

Code:
console=tty1
to the grub menu, on a line of its own right between "setparams 'Ubuntu'" and "recordfail." I've never edited the grub boot menu before so I hope this is right. I read the link but I didn't see examples, just instructions that assume you know what you're doing.

Anyway, it didn't work. It is still telling me over and over about 80211 and changing to 2 not supported. I'm not sure it is informational, since it says it over and over and just hangs there. It will say

Code:
[   <bunch of numbers>] ieee80211 phy0: uap0: changing to 2 not supported
[   12.??????] ieee80211 phy0: uap0: changing to 2 not supported
[   14.??????] ieee80211 phy0: uap0: changing to 2 not supported
[   15.??????] ieee80211 phy0: uap0: changing to 2 not supported
. . .
about 25 times or so, and then it will hang for a while. If I let it be for about 3 or 4 minutes, it will start saying the same thing again, but this time with higher numbers, like 337.?????? . . . 360.??????. If I let it go even longer it will do the same thing again with 661.?????? + numbers.

Is there a way to disable the network adapter so it doesn't even try to load and maybe avoid the problem? Or does that not make sense?

Thanks.
 
Old 04-13-2013, 07:25 PM   #4
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,988

Rep: Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217
Quote:
Originally Posted by Farkuldi View Post
I tried adding

Code:
console=tty1
to the grub menu, on a line of its own right between "setparams 'Ubuntu'" and "recordfail." I've never edited the grub boot menu before so I hope this is right. I read the link but I didn't see examples, just instructions that assume you know what you're doing.
That's a kernel parameter - simply add it to the end of the "kernel" line. While you're at it, remove the "quiet" and "splash". That should allow you to see (all) the boot messages, but didn't work on my only (old, 11.04) remaining Ubuntu system.
Quote:
Is there a way to disable the network adapter so it doesn't even try to load and maybe avoid the problem? Or does that not make sense?
It's not something the kernel support (yet) as the module loading is done as part of the init scripts - I think you can disable module loading in Ubuntu by adding "some-module-name.blacklist=yes" to the kernel line.
But of course you have to know "some-module-name" in advance.

Not much help.
 
Old 04-13-2013, 08:32 PM   #5
Farkuldi
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by syg00 View Post
That's a kernel parameter - simply add it to the end of the "kernel" line. While you're at it, remove the "quiet" and "splash". That should allow you to see (all) the boot messages, but didn't work on my only (old, 11.04) remaining Ubuntu system.It's not something the kernel support (yet) as the module loading is done as part of the init scripts - I think you can disable module loading in Ubuntu by adding "some-module-name.blacklist=yes" to the kernel line.
But of course you have to know "some-module-name" in advance.

Not much help.
Sorry, I don't have a line that says "kernel." This is what I have:

Code:
setparams 'Ubuntu'

recordfail
	gfxmode	$linux_gfx_mode
	insmod gzio
	insmod part_msdos
	insmod ext2
	setroot='hd0,msdos7'
	if [ x$feature_platform_search_hint = xy ]; then
		search --no floppy --fs uuid --set=root --hint-bios=hd0,msdos7 --hint-efi=hd0, msdos7 --hint-baremetal=ahci\0, msdos 9cd0fc57-d63e-4cd4-bab4-d115ad639c07
	else
		search --no floppy --fs-uuid --set=root 9cd0fc57-d63e-4cd4-bab4-d115ad639c07
	fi
	linux	/boot/vmlinuz-3.5.0-17-generic root=UUID=9cd0fc57-d63e-4cd4-bab4-d115ad639c07 ro   quiet splash\
   $vt_handoff
	initrd	/boot/initrd.img-3.5.0-17-generic
Thanks for your help.
 
Old 04-13-2013, 08:52 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,988

Rep: Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217Reputation: 2217


Grub2 ... add it to the "linux" line after the "$vt_handoff.
 
Old 04-25-2013, 09:46 AM   #7
Farkuldi
LQ Newbie
 
Registered: Nov 2012
Posts: 17

Original Poster
Rep: Reputation: Disabled
I'm sorry I went so long without updating. I am a student and this is the end of the semester, so I got rather caught up preparing for finals. But anyway, I was not able to make this work. I just haven't had time to write down all the error messages. I will revisit this thread when my finals are over and I have time to deal with the matter again.

Thank you very much for your assistance. I really appreciate it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Graphics Driver Install 2nd boot issue litruv Linux - Desktop 9 08-18-2012 11:17 AM
Help! Install Intel GMA500 driver on a Puppy USB yaliyada Puppy 2 10-15-2010 02:11 PM
install Poulsbo Linux driver GMA500 pegazo Slackware 2 07-15-2010 07:58 AM
Ubuntu 9.04 doesn't boot to graphics screen chevalier Linux - Software 1 05-20-2009 04:36 PM
How to install graphics drivers on Ubuntu kader911 Linux - Software 4 03-16-2007 04:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration