LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2015, 10:51 PM   #16
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Windows share method


Quote:
Originally Posted by frankbell View Post
What method did you use on Windows to share the Windows share? I ask because Windows "homegroup" sharing does not work with anything but other Windows devices.
I did recently turn on Homegroup because i thought i could do streaming audio from Windows to Linux but now i know that won't work. I'm not sure what you mean by what method did i use. I have the word WORKGROUP in my smb.conf file so i guess i address the win share as a workgroup. Not sure that's the answer you're looking for.
 
Old 02-17-2015, 01:06 AM   #17
zafar_dandoti
Member
 
Registered: Dec 2005
Location: India
Distribution: centos
Posts: 178

Rep: Reputation: 13
Post

Turn off password protected sharing on ur windows system. That will turn on guest account automatically. Now right clicking the folder u want to share click on sharing -advanced share-permissions click full control on check box infront fo user everyone.
Now using guest account u can connect to share. Do this if u dont bother about share permissions.
Code:
mount.cifs //computer/share /mount/point -o user=garyz97\guest

Last edited by zafar_dandoti; 02-17-2015 at 08:15 AM.
 
Old 02-17-2015, 06:34 AM   #18
wpeckham
Senior Member
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, Fedora, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, Vsido, tinycore, Q4OS
Posts: 2,402

Rep: Reputation: 970Reputation: 970Reputation: 970Reputation: 970Reputation: 970Reputation: 970Reputation: 970Reputation: 970
homegrouplessness

Homegroup is a poor, inefficient, slow Microsoft take on mesh networking that is pretty much useless for any business environment, and can slow your overall network performance terribly. Nice and handy if speed makes no difference on a very limited home network. I recommend turning it off. AFAIK linux never uses it.

While I have never resorted to using the guest account, the above post seems a reasonable troubleshooting attempt. It will verify or eliminate permissions as the core issue. Please let us know the result.
 
Old 02-17-2015, 07:56 AM   #19
zafar_dandoti
Member
 
Registered: Dec 2005
Location: India
Distribution: centos
Posts: 178

Rep: Reputation: 13
I had a very bad experience connecting to share on windows system post windows xp. Windows xp allowd to connect to share with domainname/username or computername/username but windows 7 and windows 8 never.Though it asks to enter password for share but never allowd the connection. So i ended up enabling guest account on windows 7 systems.
 
Old 02-17-2015, 09:56 AM   #20
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
password protection has been turned off

Quote:
Originally Posted by zafar_dandoti View Post
Turn off password protected sharing on ur windows system. That will turn on guest account automatically. Now right clicking the folder u want to share click on sharing -advanced share-permissions click full control on check box infront fo user everyone.
Now using guest account u can connect to share. Do this if u dont bother about share permissions.
Code:
mount.cifs //computer/share /mount/point -o user=garyz97\guest
I do have password protection turned off. That was the first thing is did about a week ago.
 
Old 02-17-2015, 10:01 AM   #21
Ihatewindows522
Member
 
Registered: Oct 2014
Location: Fort Wayne
Distribution: Ubuntu 16.04 LTS
Posts: 616
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
I had the EXACT same issue using a WinXP box for file sharing. All I could think of is a slight variation in the SMB protocol. Using Mint as a file server works just fine as one would expect.

And yes, append | tee /path/to/text/file.txt to capture the output of commands to a file.
 
Old 02-17-2015, 10:12 AM   #22
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ihatewindows522 View Post
I had the EXACT same issue using a WinXP box for file sharing. All I could think of is a slight variation in the SMB protocol. Using Mint as a file server works just fine as one would expect.

And yes, append | tee /path/to/text/file.txt to capture the output of commands to a file.
Ok. Thanks for the text capture info. I love Linux but i've only had this box running for a few months. I'll get up to speed eventually. I'm glad to finally see someone else had this inability to access Windows. I gotta believe there's a way to do this though.
 
Old 02-17-2015, 10:58 AM   #23
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
It's working!

It's working now! I just entered $ sudo mount.cifs //192.168.1.9 /home/gary/share -o user=Administrator and now i'm seeing a share icon on my desktop. Maybe it's been there before but i just now noticed it. So i'm guessing that the problem, maybe all along, has been accessing the share once i've connected to it. Much thanks to all you guys for all the help and patience with me. Now i should be able to link to my fairly extensive windows music library while enjoying fast, stable Linux. Thanks again everyone!
 
Old 02-17-2015, 12:01 PM   #24
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,557

Rep: Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116
It's been working for a while now. You can see it in the df and mount output you posted yesterday. I'm very surprised nobody bothered to look at it or mention it, I was asleep...

Code:
$ dh -h
//192.168.1.9/asm 1.9T 659G 1.2T 36% /home/gary/share

$ mount
//192.168.1.9/asm on /home/gary/share type cifs (rw)
That's why you were getting the "Device or resource busy" error, it was already mounted.
 
Old 02-17-2015, 12:40 PM   #25
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
It's been working for a while now. You can see it in the df and mount output you posted yesterday. I'm very surprised nobody bothered to look at it or mention it, I was asleep...

Code:
$ dh -h
//192.168.1.9/asm 1.9T 659G 1.2T 36% /home/gary/share

$ mount
//192.168.1.9/asm on /home/gary/share type cifs (rw)
That's why you were getting the "Device or resource busy" error, it was already mounted.
Now i just added Rush as a win share, but it was 'greyed out'. I added the user Everyone, and now i i'm listening to my win Rush share - Farewell To Kings - on my Linux box. So wonderful. I was assuming (any everyone knows what it means when people assume) that i should see a smb> prompt, instead of seeing if i could access that share through Nemo. Thank you everyone!
 
Old 02-17-2015, 12:50 PM   #26
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,557

Rep: Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116
Quote:
Originally Posted by garwhi View Post
I was assuming (any everyone knows what it means when people assume) that i should see a smb> prompt, instead of seeing if i could access that share through Nemo.
When you mount something in Linux, be it a local hard drive, USB disk, or even a network share via CIFS/NFS, it shows up on your filesystem at the mount location as if it's local.

It's sort of similar to Windows "drive mapping", but much more seamless. Once you run the mount command (provided it was successful), all you need to do is navigate to the mount location in the terminal or a file browser, and you can see and access all of the files and directories on the mounted drive just like any other file on your computer.
 
Old 02-17-2015, 01:36 PM   #27
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
When you mount something in Linux, be it a local hard drive, USB disk, or even a network share via CIFS/NFS, it shows up on your filesystem at the mount location as if it's local.

It's sort of similar to Windows "drive mapping", but much more seamless. Once you run the mount command (provided it was successful), all you need to do is navigate to the mount location in the terminal or a file browser, and you can see and access all of the files and directories on the mounted drive just like any other file on your computer.
I feel a little silly asking this, but i assume that if i want to access some other share i either have to first unmount that one and then mount the second one, or create a different share folder for another, different, share. Right? I think i'm starting to get the knack of this. I'm very grateful for all the help all you guys have given me.
 
Old 02-17-2015, 01:56 PM   #28
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,557

Rep: Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116Reputation: 2116
Just create a new directory for the new mount location.

If you really wanted to, you could unmount the first and then mount the second at the same spot, but that would be kind of pointless except for a few niche applications.
 
Old 02-17-2015, 02:11 PM   #29
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by suicidaleggroll View Post
Just create a new directory for the new mount location.

If you really wanted to, you could unmount the first and then mount the second at the same spot, but that would be kind of pointless except for a few niche applications.
OK. I think i've got it now. Thanks a million suicidaleggroll, wpeckham, and others.
 
Old 02-17-2015, 04:58 PM   #30
garwhi
LQ Newbie
 
Registered: Feb 2015
Posts: 17

Original Poster
Rep: Reputation: Disabled
access Windows shares from Linux

I saw a different n00b post here marked SOLVED. My question here is definitely solved but i don't know how to mark it as such. Or maybe someone else does that.
 
  


Reply

Tags
linux, samba, smb, windows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Share Linux Dir and access through windows rajes4india General 5 04-12-2012 07:02 AM
Can't access the linux share from windows 2008 server cbc Linux - Newbie 3 07-01-2011 07:08 PM
windows share to access from linux pc salimshahzad Linux - Server 2 12-12-2009 08:49 AM
Access linux SAMBA share from windows pengu Linux - Software 6 02-17-2007 12:55 PM
cannot access my Linux share from Windows va7hg Linux - Networking 6 12-13-2005 09:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 01:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration