Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 12-27-2007, 04:58 PM   #1
LQ Newbie
Registered: Dec 2007
Posts: 3

Rep: Reputation: 0
C Shell issue

I have a c shell quesion. I am currently using HP-UX. In a c shell if I type the letter @ the whole line disappears. how do I fix that and why does that happen?

Old 12-28-2007, 02:47 PM   #2
harry edwards
Registered: Nov 2007
Location: Lincolnshire, UK
Distribution: CentOS, Fedora, and Suse
Posts: 365

Rep: Reputation: 48
It sounds like your terminal settings are mis-configured. What output do you get from:

 stty -a
Old 12-28-2007, 11:18 PM   #3
LQ Newbie
Registered: Dec 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Originally Posted by harry edwards View Post
It sounds like your terminal settings are mis-configured. What output do you get from:

 stty -a
[2] % stty -a
speed 9600 baud; line = 0;
rows = 40; columns = 120
min = 1; time = 1;
intr = DEL; quit = ^\; erase = ^H; kill = @
eof = ^D; eol = ^@; eol2 <undef>; swtch <undef>
stop = ^S; start = ^Q; susp <undef>; dsusp <undef>
werase <undef>; lnext <undef>
parenb -parodd cs7 -cstopb hupcl -cread -clocal -loblk -crts
-ignbrk brkint ignpar -parmrk -inpck istrip -inlcr -igncr icrnl -iuclc
ixon -ixany -ixoff -imaxbel -rtsxoff -ctsxon -ienqak
isig icanon -iexten -xcase echo -echoe -echok -echonl -noflsh
-echoctl -echoprt -echoke -flusho -pendin
opost -olcuc onlcr -ocrnl -onocr -onlret -ofill -ofdel -tostop tab3

I see that kill = @
so how do i get rid of that
Thanks for your time

Old 12-28-2007, 11:21 PM   #4
Senior Member
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
Looks at the 5th line. @ is assigned as the kill interrupt.
Old 12-29-2007, 06:01 AM   #5
Registered: Aug 2006
Location: Saint Paul, MN, USA
Distribution: {Free,Open}BSD, CentOS, Debian, Fedora, Solaris, SuSE
Posts: 735

Rep: Reputation: 76

Most often I see control-U used as the "kill" character. This is the "line kill" behavior, not the "job kill" behavior that is more often used, as with "kill %1", or the similar process signal kill.

To reset it, use the literal 4 characters, '^u', then look at the assignment with stty -a again:
stty kill '^u'
stty -a
I am not certain that this will work in an xterm session, but give it a try and let us know. (In my xterm, stty reported the change, but it did not actually change the behavior. Perhaps someone will stop by with the usually-simple explanation . It will likely be some arcane command or setting in an X configuration file.)

I have not seen this character assignment to kill in a long time; it once was the default with (real) TTYs.

Best wishes ... cheers, makyo

Last edited by makyo; 12-29-2007 at 06:10 AM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
What will actually happen if i issue rm -rf / in Shell? hkl8324 General 7 06-27-2005 10:35 PM
Shell grep issue philipz Programming 8 05-05-2004 01:50 PM
issue with shell script chupacabra Linux - General 3 10-18-2002 08:12 PM
Out of guesses! (shell Script issue) chris Linux - General 2 12-10-2001 04:20 PM
issue with shell cgi JustinHoMi Programming 0 11-07-2001 01:54 AM > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 12:00 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration