LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (https://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   Burning with cdrecord (https://www.linuxquestions.org/questions/linux-newbie-8/burning-with-cdrecord-504245/)

philips217 11-23-2006 10:29 AM

Burning with cdrecord
 
Hi guys,
I am having some trouble when trying to burn some files onto a CD in vmware. When I type:
Code:

cdrecord dev=ATAPI –scanbus
I get:
Code:


scsibus0:
        0,0,0        0) ‘LITE-ON ‘ ‘DVDRW SHW-1635S ‘ ‘YSON’ Removable CD-ROM
        0,1,0        1) *

So I am suspsoe to use 0,0,0
When I try:
Code:

cdrecord –v –eject speed=8 dev=ATAPI:0,0,0 /path/to/my/file/
I get some stuff at the start then:
Code:


cdrecord: WARNING: Total disk size unknown , Data may not fit on disk.
Forcespeed is OFF.
Starting to write CD/DVD at speed 8 in real TAO mode for single session.
Last chance to quit, starting real write        0 seconds. Operation starts.
Waiting for reader to fill input buffer … input buffer ready.
BURN-Free is OFF.
Performing OPC…
Starting new track at sector: 0
Track 01:        0 MB written.cdrecord: Is a directory. Read error on input file
Writing time:        0.204s
Cdrecord: fifo had 1 puts and 1 gets.
Cdrecord: fifo was 0 times empty and 0 times full, min fill was 100%.

Do I need to mount the cdrom?
if I try:
Code:

mount /dev/hdc –t iso9660 –w /cdrom
I get:
Code:

mount: block device /dev/hdc is write-protected but explicit ‘-w’ flag given
Are the permissions wrong?
when I do:
Code:

ls –l /dev/hdc
ls –l /cdrom

I get:
Code:

brw-rw----
drwxr-xr-x

Any help would be greatly appreciated.
Thanks in advance.

Lenard 11-23-2006 10:50 AM

Try using; cdrecord device=/dev/hdc /path/to/the/files/

For mounting, no need to specify the '-w' writing switch (does not apply or work anyhow in this case). If the drive is already known in the /etc/fstab file the just use something like;

mount -t auto /dev/hdc

philips217 11-23-2006 11:08 AM

Thanks for the reply.

However, I get:
...
cdrecord: Is a directory. read error on input file

Any ideas?

Tinkster 11-23-2006 11:15 AM

Yah ... you need to use mkisofs to create an ISO-image of your files
and then burn THAT using cdrecord (or do it on the fly as the man-page
explains).
Code:

example:
mkisofs -R -o cdimage.raw /home/joerg/master/tree
cdrecord -v speed=2 dev=2,0 cdimage.raw


example:
mkisofs -R /master/tree | cdrecord  -v  fs=6m  speed=2 dev=2,0 -


Cheers,
Tink

philips217 11-23-2006 12:09 PM

Thanks, I think it started working but now a vmware box showed up saying:
Quote:

Your virtual machine has send an ATAPI (CD-ROM) command that is supported only when
programming the drive via DMA. You will need to configure your guest operating system
to use DMA when communicating with DVD/CD-ROM devices.
Note that some operating systems will report DMA is available without actually using it. In
those cases, normal CD-ROM operations will still be available, but special features will
only be available if you reconfigure the virtual device as a SCSI device.
Do I need to recompile my kernel? Just to burn CDs?

Any ideas or links for help?

philips217 11-24-2006 07:45 AM

Okay, I figured it out.
Thanks a lot guys!

markkeegan17 03-24-2007 06:52 AM

you said you figured it out (the dma thing in VMware)...
 
may I ask HOW?

I have the same problem and (even though) DMA is enabled on my linux machine, I still get the same VMware error message when booting Windows 2000.

Thanks.

philips217 03-26-2007 06:59 AM

In your wmware settings for the machine change your cdrom from IDE to SCSI.


All times are GMT -5. The time now is 09:22 PM.