-   Linux - Newbie (
-   -   Bumblebee Project (

geshuni 02-16-2013 03:02 AM

Bumblebee Project
Greetings all,
As you can see, from where I am posting this thread, I am new to arch, I've been following the installation guide for beginners in arch linux, however I am stuck on bumblebee - the optimus technology for linux. In the bumblebee wiki page ( it is very good explained how to install it. Everything looks fine:

pacman -U path/to/pkg.tar.xz
does not give me errors, as well as

pacman -Qm
displays the 3 packages that are foreign - lib32-nvidia-utils-bumblebee, nvidia-bumblebee, nvidia-utils-bumblebee.
Here is the problem, when I try to add my user to the group bumblebee it says there is no group, moreover, I cannot even start bumblebee, as it says there is not such file/directory. Which kind of disappoints me - the AUR completely explains how to build a package (extract, makepkg -s, pacman -U pkg.tar.xz), however it indirectly says there is no such thing as bumblebee. Every help is appreciated.
Thank you very much for your time spent reading/answering my question.

onebuck 02-16-2013 10:05 AM

Member Response

I do not use 'arch but as root in a general sense;

#create group
groupadd bumblebee
#add user to group
usermod -G bumblebee -a USERNAME

You will need to re-login as user to have things take effect.

Do not forget to be sure 'bumblebeed' is enable at start/boot. You should be able start 'bumblebeed' via init do it arch way;Bumblebee - ArchWiki ;

Start Bumblebee In order to use Bumblebee it is necessary add yourself (and other users) to the bumblebee group:
# gpasswd -a $USER bumblebee ##where $USER is the login name of the user to be added. Then log off and on again to apply the group changes.

To start bumblebee automatically at startup, enable bumblebeed service:
# systemctl enable bumblebeed.service ##Finished - reboot system and use the shell program optirun for Optimus NVIDIA rendering!
You might want to look through the Bumblebee - ArchWiki to understand fully.
Hope this helps!

geshuni 02-16-2013 12:32 PM

Thank you for the fast reply! I thought bumblebee will create his own usergroup whenever it is installed, moreover, i cannot start the service daemon, because it says it is not installed, that is why I am turning to you here:

[asd@asd ~]$ sudo systemctl enable bumblebeed.service
Failed to issue method call: No such file or directory

I know i can fix the problem by creating a group, however I think it is not installed properly, or I am missing something out.

onebuck 02-16-2013 03:07 PM

Member Response

You did follow Bumblebee - ArchWiki for installation? Not that I am aware of, you need to create the group then add the user to group and start the service after you have installed the bumblebee and available util package for your Intel-Nvidea or Intel-nouveau device.
If you follow Bumblebee - ArchWiki then there should be no problem. Don't for forget to log off and reboot the system.

geshuni 02-17-2013 07:17 AM

Greetings once again,
I installed packer and thus managed to completely install bumblebee, however when I try to run

optirun glxspheres
it comes up with this error

[ 2266.268207] [ERROR]Cannot access secondary GPU - error: [XORG] (EE) No devices detected.

[ 2266.268247] [ERROR]Aborting because fallback start is disabled.

Tried to google it out and found out that linux headers is the case in ubuntu (, however I have that installed, also here are my bumblebee.conf

# Configuration file for Bumblebee. Values should **not** be put between quotes

## Server options. Any change made in this section will need a server restart
# to take effect.
# The secondary Xorg server DISPLAY number
# Should the unused Xorg server be kept running? Set this to true if waiting
# for X to be ready is too long and don't need power management at all.
# The name of the Bumbleblee server group name (GID name)
# Card power state at exit. Set to false if the card shoud be ON when Bumblebee
# server exits.
# The default behavior of '-f' option on optirun. If set to "true", '-f' will
# be ignored.
# The Driver used by Bumblebee server. If this value is not set (or empty),
# auto-detection is performed. The available drivers are nvidia and nouveau
# (See also the driver-specific sections below)

## Client options. Will take effect on the next optirun executed.
# The method used for VirtualGL to transport frames between X servers.
# Possible values are proxy, jpeg, rgb, xv and yuv.
# Should the program run under optirun even if Bumblebee server or nvidia card
# is not available?

# Driver-specific settings are grouped under [driver-NAME]. The sections are
# parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
# detection resolves to NAME).
# PMMethod: method to use for saving power by disabling the nvidia card, valid
# values are: auto - automatically detect which PM method to use
#        bbswitch - new in BB 3, recommended if available
#      switcheroo - vga_switcheroo method, use at your own risk
#            none - disable PM completely

## Section with nvidia driver specific options, only parsed if Driver=nvidia
# Module name to load, defaults to Driver if empty or unset
# colon-separated path to the nvidia libraries
# comma-separated path of the directory containing and the
# default Xorg modules path

## Section with nouveau driver specific options, only parsed if Driver=nouveau

and my /etc/bumblebee/xorg.conf.nvidia

Section "ServerLayout"
    Identifier "Layout0"
    Option "AutoAddDevices" "false"

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "ConnectedMonitor" "DFP"

I appreciate your time spent on this topic. Thank you in advance!

geshuni 02-17-2013 01:59 PM

P.S. I am not sure whether or not I need to install an official nvidia driver, however I am sure I have installed bumblebee-nvidia.

geshuni 02-18-2013 02:44 AM solved the case, thank you!

All times are GMT -5. The time now is 02:01 AM.