-   Linux - Newbie (
-   -   buffer underrun with cdrecord (

GT_Onizuka 09-05-2003 11:03 PM

buffer underrun with cdrecord
okay i've been having some problems making duplicates of data cds using the CLI cdrecord. I can do it fine in xcdroast, but i figure i can just make an alias for duping data cds so i dont hafta load a gui just to do something that simple. needless to say i never have gotten a bufferrun in xcdroast or gnometoaster (i use that also) but i haven't been able to burn a cd (a duplicate that is) using cdrecord. i use either the command

cdrecord -v dev=0,0,0 speed=24 -isosize /dev/hdc
cdrecord -v dev=0,0,0 speed=24 -isosize /dev/cdrom
(the second one was what the guy whose tutorial i was reading said, i figured my first drive, my dvd-rom, is located on /dev/hdc so i tried that instead, same results, burns like 3 or 4 MB and fails.)

here's the message it gives me... /dev/cdrom
i also tried slowing the speed down to 20 and then 16 (even though on Windows and while using xcdroast and gtoaster, i used 24X) and still my discs failed. any ideas?

dalek 09-06-2003 04:20 AM

I'm no expert on this but
I think you have to write to the SCSI listing. You should have SCSI emulation working with the GUI one. My CD is /dev/scd0. You may want to try this. Look in your fstab and see what yours is and try that instead of /dev/hdc.

I'm no expert but I hope this helps.

:D :D :D :D

gundelgauk 09-06-2003 10:17 AM


Unfortunately I can't offer you a solution as I'm no expert on this either. But as you seem to be reading the data directly from another cdrom drive during burn time, I thought I'd contribute the following:

I'm not sure where exactly I read this but it was some tutorial on cdrecord. It strongly advised not to connect the two drives to the same ide channel as cdrecord doesn't support some function or another with the result that the ide bus can't handle the data stream anymore and you are left with a buffer underrun.

For example this would be wrong:
primary master: hdd1
primary slave: hdd2
secondary master: cdrom (source drive)
secondary slave: cdrw (writer)

Rather do this:
primary master: hdd1
primary slave: cdrom (source drive)
secondary master: hdd2
secondary slave: cdrw (writer)

Same goes for a hdd as a source, for example in the second example one would use hdd1 as a source for burning and not hdd2.

This is only general advice however, I cannot make much sense out of the fact that you can successfully copy a cdrom with xcdroast (which is only a frontend to cdrecord!) and not with cdrecord itself. :confused:

My last guess would be that xcdroast enables your burnproof feature (if you have any) and the command line call of cdrecord leaves it disabled.

I hope you'll find a solution!

Good luck!

GT_Onizuka 09-06-2003 02:00 PM

okay yeah, i just had to add -driveropts=burnproof and it worked out, thanks guys ^_^

gundelgauk 09-06-2003 05:04 PM


Happy toasting :D

All times are GMT -5. The time now is 09:13 PM.