-   Linux - Newbie (
-   -   Broken links? (

danthehat 02-03-2005 09:21 AM

Broken links?
Well here's the deal. I run a server program that I put together myself (doesn't really matter what it does) and I need it to start up in runlevel 3. Sooo, I made a symlink from the script I use to start it to /etc/rc.d/rc3.d/S99server, right? Well, the thing won't start up and I can't figure out why!

When I go to /etc/rc.d/rc3.d and do an ls, I see the link to my script appears t o be broken (ie, the background is red and flashing). This cannot be. The script is located on the root filesystem, the folder its in should not be a problem to get to (unless permissions matter...?)

So in the end, I need to figure out what the hell is going on because I've never seen this kind of behaviour before.

I run mandrake 10, if you need to know, and thank you for your time.

justin_p 02-03-2005 11:11 AM

Not sure..but have you looked at the /etc/inittab? File. Post its contents. If the server only runs in run level, then shouldn't you always be running in run level 3 in order to run the server?

danthehat 02-03-2005 11:15 AM

Yeah, that's the way of it. No worries there, I'm always running at level 3.

LasseW 02-03-2005 02:18 PM

Did you use a full path for the script, ie

ln -s /home/myscripts/server ...

The first argument of the ln command will be the contents of the link.

danthehat 02-03-2005 03:06 PM

Yes, the script path is complete.

It is interesting though, when I actually went to investigate the first time to see if the script was still in tact and where it was supposed to be, i checked the link again and it seemed complete, as in no more flashing red background.

All times are GMT -5. The time now is 04:25 AM.