LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-31-2004, 09:57 AM   #1
Jay-eye
LQ Newbie
 
Registered: Jan 2004
Location: Birmingham - City of Sunshine
Distribution: SuSe 9.0
Posts: 14

Rep: Reputation: 0
Unhappy broadband setup


Hi there fellow adventurers!

I was SO pleased when I tried the Knoppix Live-Evaluation cd that not only did it load and run but also evrything worked! I could surf the net no probs.

Seeing as that went so well I thought I'd give Linux a go (after much deliberation) and have opted for SuSE Personal 9.0. Installation has gone fine, dual-booting with XP and both seem to work as normal.

During the installation I let it do what it wanted (I don't know any better..... I'm a converted Luddite, now determined to learn more) and in the main it installed ok. I want to tweak my mouse settings (scroll wheel not working) and try to get the scanner working (hp3570c - I don't think it's supported) but the MAIN PROBLEM is getting internet access sorted.

Under SuSE it's NOT working. It detected the network card at installation and the test failed, several times. As I wasn't sure what to change I aborted that bit and let it carry on installing the rest.

Here are my questions:
1) How do I get back to tweak the settings? I presume I use the YaST KDE thingy from the start menu (whoops! Is that Windows speak?) but which bit, I don't seem to be navigating my way round very successfully.
2) I'm using Telewest's (Blueyonder) broadband connection. That means the onboard Network card isn't used, instead they supply their own internal card as well as a lighty-up modem box thingy. I'm pretty sure I've specified the right card (out of the two fitted) but it said something like: 'DHCP already running on eth 0'

The trouble is that after many years of Windows I'm sure my brain has atrophied and I'm struggling to understand any of the techno speak. I've read and re-read the manual but it's not helping.

Anybody got any advice for me? Bear in mind you'll have to speak very slowly and SHOUT!!! That's what I find works with stupid people, anyway.

Thanks in advance,

Jay-eye
 
Old 01-31-2004, 10:08 AM   #2
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
ok first to get the scroll wheel working open the file /etc/X11/XF86Config as root with a text editor and add/change the following:
Option"Protocol""ImPS/2"
Option"ZAxisMapping""4 5"

in the end your mouse section should look a bit like this but dont change other things than the both above :=) :

Section "InputDevice"
Identifier"USB Mouse"
Driver"mouse"
Option"SendCoreEvents""true"
Option"Device""/dev/input/mice"
Option"Protocol""ImPS/2"
Option"Emulate3Buttons""true"
Option"ZAxisMapping""4 5"
EndSection

ok go to your console and perform a dmesg then have a look for eth0 and post us what it says for it then check if you have rpppoe installed by performing adsl-status and or adsl-setup in console with adsl-setup you can setup adsl broadband connections there you can change the network card it should use if you find out which one is the right one in dmesg i mean if it is eth0, eth1 ... the card your modem is connected too ...
then after you did a adsl-setup you can start and stop your internet by performing adsl-start and adsl-stop in your console
 
Old 01-31-2004, 11:18 AM   #3
Jay-eye
LQ Newbie
 
Registered: Jan 2004
Location: Birmingham - City of Sunshine
Distribution: SuSe 9.0
Posts: 14

Original Poster
Rep: Reputation: 0
Phew! Glad to be back in one piece!

Thanks for responding Kasperhans, sorry for the delay. First of all my printer had stopped working (due to linux installation?). I followed your instructions about the mouse settings and it worked beautifully. Thank you.

Then, I logged out of root and back into user for the next bit and it took me into some "Window Manager" zone and I couldn't get out of it nor back to the regular SuSE desktop I've been using so far. What's that about?

Having performed dmesg I think it's picked up the wrong network card. I couldn't work out how to cut & paste from Konsole to this with a restart in between but what it said in essence was:
eth0: VIA 6103 PHY tranceiver found at address 1
eth0: using tranceiver found at address 1
eth0: SIS 900 PCI blah blah blah (that's the inboard one I think)
0xd400, IRQ 12, 00:0a:e6:3b:f1:5b
eth0: Media link off.

Then it went eth1: and mentioned the RTL 8139 card I think it should be using.

So I tried adsl and adsl-status and adsl-setup in Konsole but it said bad command so what do I do?

ps: every time I resart to get out of Linux and back to XP windows says terrible things have happened to the HD and I have to stop it doing a disk check. Can I do anything about that? Switch it off or let it do it once or something?

Thanks
Jay-eye
 
Old 01-31-2004, 12:46 PM   #4
kasperhans
Member
 
Registered: Oct 2003
Location: right behind the moon
Distribution: gentoo
Posts: 466

Rep: Reputation: 30
ok you have to perform adsl-setup in root modus if it still says bad command search rpppoe and install it maybe youll find it on your suse cd or with google a special suse package , install it and perform adsl-setup then chose eth1 during setup as network card and fill in your adsl informations i mean follow the menu its documentated well hmm maybe just dont mount your ntfs hard disk every time in linux just mount it if its needed
 
Old 01-31-2004, 01:13 PM   #5
gazza
Member
 
Registered: Jun 2003
Distribution: Mandrake 10.1 Official
Posts: 157

Rep: Reputation: 30
Go here http://eciadsl.flashtux.org this should help you get sorted, I think that you should be using dls0 and eth0 or 1, that is how i have my bt broadband configured, they use pppoatm.

hope this helps ( I run suse too and it works a treat )
 
Old 01-31-2004, 02:58 PM   #6
Jay-eye
LQ Newbie
 
Registered: Jan 2004
Location: Birmingham - City of Sunshine
Distribution: SuSe 9.0
Posts: 14

Original Poster
Rep: Reputation: 0
Wink

OK Guys
Thanks very much for your help. This is now a SuSE posting! No windows were opened in the making of this post!

I found a SuSE.com page entitled 'Setting up an Internet connection via Cable Modem' and although I couldn't follow those intructions either (I'm trying, honest I am) I knocked out the eth0 card and it then kinda reconfigured using the eth1 and suddenly I was on!!!

I'm so chuffed, plus I'm impressed by the speed you guys came up with advice. Well done.
Thanks again
Jay-eye
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to setup Tiscali Broadband? jonty-comp Fedora 3 11-14-2005 10:37 AM
Broadband & Setup Email Server redman_8888 Linux - Networking 5 06-02-2005 02:04 PM
broadband setup for Linux... dawn_angel Linux - Networking 1 02-04-2005 02:00 AM
NTL Broadband Setup beethamd Linux - Networking 4 07-03-2003 06:05 PM
Smoothwall Setup with BroadBand Phantom2002 Linux - Networking 0 08-30-2002 03:53 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 05:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration