-   Linux - Newbie (
-   -   bringin up interface eth0 [failed] (

paulo 10-18-2002 03:39 PM

bringin up interface eth0 [failed]
big time newbie here. I just bought a linux desktop (redhat 7.3) and I am trying to connect to the internet. I have the ethernet wire connected in the back (don't know what kind of card it is - don't know the command to find out). I have google searched eth0 failed, and countless other keywords all day. I have man'd ifconfig (no man entry for eth0). I have searched the linuxquestions forums and came up with a thread from april that said to check the file: /etc/sysconfig/network-scripts/ifcfg-eth0
I did and I feel like I should put in lines for the DNS, GATEWAY, SUBNET MASK, SMTP server, computer name, IPADDRESS that were given to me by the computer (windows guy) person here. I am logged in as root (I know this to be a dangerous thing) and I am worried about saving this file as the same name and then typing

ifconfig eth0 up

because I don't want to reinstall redhat or do something bad while logged in as root. (I want to setup me as a user or power user or something but let me research that on the web before I post a question about setting up accounts - obviously this requires internet access - currently I am posting with my win2k laptop)

I was almost to scared to post after reading the guidelines for newbies asking questions here from acid_kewpie's signature. I also tried the linux documentation project site and got stuff similar to the google search links to threads (from newbies to linux gurus) that are similar enough to match a search but not similar enough for me to understand how to actually accomplish my particular problem.

thanks in advance - my goal is to be taught to fish

ps I tried entering my computer name and ip address with the network configurator in KDE and it didn't seem to "take".

Mara 10-18-2002 03:51 PM

Before you bring your eth0 up, you need to have the right kernel module loaded. If you have a PCI card it should be detected automatically. Use
cat /proc/pci
All PCI devices will be listed. There should be you card among them. Then you need to find the right module. It's not obvoious which one to use, so please post your cat /proc/pci result and someone will tell you which module it is.

paulo 10-18-2002 03:54 PM

I tried to use netconfig program. It looked promising but again no yahoo no google.
If I try to start netscape I get a weird error (in addition to name not found check it and try again). I get the following:
hosts are unknown:
perhaps there is a problem with the name server?
a non-root name server may be required.
you may need to do something with $SOCKS_NS

contact your sys admin
end of error

unfortunately, I have no sys administrator -er I am the sys admin - and that is a little scary.

paulo 10-18-2002 03:59 PM

results of cat /proc/pci
A long list of devices came up (too many to type) but I see matroX graphics card, audio controller, USB,... and ... Bus 2 device 12, ethernet controller: PCI device 8086:100e (Intel Corp.)
that's gotta be it right?
other info under this device is (rev 2) IRQ 9 Master Capable

I don't know what you mean by the right kernel module loaded but I will look it up.

Mara 10-20-2002 04:09 AM

Check if you have /etc/resolv.conf. It should look like this:

domain your_domain_here
nameserver nameserver_IP
nameserver nameserver_IP2

paulo 10-23-2002 09:35 AM

only nameserver

Originally posted by Mara
Check if you have /etc/resolv.conf. It should look like this:

domain your_domain_here
nameserver nameserver_IP
nameserver nameserver_IP2

I only have:

Of course, I have real numbers for x's
actually integers not "real"

I will try to add the domain now - don't you think.
ps - thanks for helping a noob I feel like I am learning.

neo77777 10-23-2002 09:40 AM

And now is the main question, how do you connect to the Net? xDSL through PPPoE,xDSL or cable through DHCP,static IP xDSL, cable, other?

paulo 10-23-2002 09:48 AM

I don't think we use domains here. We all get assigned static ip addresses. We have numbers for subnet mask, DNS, and gateway. I am hesitant about putting forth alot of network information publically on the web, though.

I added a line into /etc/resov.conf
with my best guess at a domain name and kept the nameserver the same.

still no google no yahoo (browser says hostname not found)

I tried the KDE network configurator again. with and without a domain name and same result.

Should the name server be my assigned name and ip address or should it be the gateway?

paulo 10-23-2002 09:55 AM


Originally posted by neo77777
And now is the main question, how do you connect to the Net? xDSL through PPPoE,xDSL or cable through DHCP,static IP xDSL, cable, other?
I am only familiar with half of these acronymns. But, I am at work (a research lab at a University). I get assigned a unique name and ip address (it is different than the one I am currently connected to the net with my win2k laptop). I bet that it is some kind of LAN for the department. The computer guy is not linux savvy (and a little surly and unapproachable).

neo and mara:
am I giving out too much network information is the department's network going to get hacked from me posting the specifics of this stuff - I generally trust people who believe in open source - but I worry (there are alot of people working on their PhD theses around here and we don't want them destroyed)

Mara 10-23-2002 12:46 PM

Ok, so it you use static IPs, LAN means with a default gateway. Have you set it up? Default gateway seems to be the main thing in your case. When you type
ifconfig eth0
you should get a few lines of info, your IP, netmask etc (no errors). Then, when you type
you should get, among other lines something like
default gateway_ip_here UG 0 0 0 eth0
(it may not me identical, but should be similar).
Check them.

paulo 10-24-2002 09:44 AM

route results
First, I do not get an ip address when I type "ifconfig eth0" what I do get is: Link encap: Ethernet, my HW address (looks like a MAC address) UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 # of received packets # of transmitted packets 0 errors, 0 overruns, 0 collisions, or the like. transmission queue length:100

When I type route I do not get default gateway_ip_here UG
etc. what I do get is

Destination Gateway Genmask Flag Metric Ref Use Iface*_____ U___0____0___ 0___ lo

So, I am not sure what to think. I may have made the problem worse by trying to get my machine online using the KDE netconfigurator and command line entries.

The gateway should probably not be an asterisk (*) if you think that is my problem. It is definitely one of my problems. But, shouldn't I have information for Iface eth0 by using route? I think the routing info on my machine is only for the local loop (lo), no?

paulo 10-24-2002 10:07 AM

I man'd route and carefully read the man for ifconfig. I think I need to use my static ip address in ifconfig eth0 and then use route to configure the gateway. If this is true I am olny currently having problems with the syntax because I have tried
ifconfig eth0 address ip_address_here
route add -net ip_address_here dev eth0

I will try some more combinations with the man pages open.

paulo 10-24-2002 10:46 AM

some success
I still cannot "see" the net. But, I looked in /etc/sysconfig and found some scripts that I guess the company I bought the machine from (ASLabs) wrote. I edited my network file to include the hostname of my machine and then I entered the network-scripts directory and ran network start. It brought up eth0 and when I typed ifconfig-a again it showed the static ip address for my eth0. PReviously, the ip address would not show up under eth0 using ifconfig. I don't know why I couldn't get eth0 to "take" my static ip address. I looked at the network script (242 lines) and from what I could follow I was using the same commands.

Now, I will try and get that route to work. I wish that I could understand why my commands did not work.

paulo 10-24-2002 11:12 AM

errors using route
okay I need some real help here.

what we know:
1) I have been assigned a static ip address
2) I can see this ip address when I type: ifconfig eth0

what I am unsure about:
1) How to setup the gateway using route (after reading man and trying all of the examples I get network is unreachable)
2) I am most unsure about when to use my assigned ip_address (123.456.789.123) and when to use the number that is similar (123.456.789.0).
3) Are the scripts I am using only on my machine (factory installed redhat linux) or do all linux distributions have the same scripts?

1) Is my eth0 properly configured for my network? I think it is - but as I have no internet access I cannot be sure that the problem does not lie in the configuration of eth0 (I get an [OK] when I run the network start script.
2) Is a netmask the same as a Genmask and the same as a Mask (in my network-script ifcfg-eth0)?
3) Using route what should be the Destination? my hostname or the network that my assigned IP address is on?

I am getting confused

skoorbj 10-24-2002 12:02 PM

Do you have a utility called linuxconf?

I'm not sure if it was released with RH7.3 - but I would suggest you
take a look in there at the network config tab. There you should put
your netmask (or something like that), your gateway
typically this is of the form a.b.c.d where a, b, c are the same as the
numbers in your static IP addr, and d could be either 1 or 254. Your
windows machine should be able to tell you this. The rest is pretty obvious,
you will need to specify domain name servers (same as for windows), and
that should so it.

if you can see your IP addr with ifconfig then I guess you're almost there.

One last thing -you don't use a proxy server to access the internet by
any chance do you? IF so, then those settings will have to be transferred as well.

Good luck,


All times are GMT -5. The time now is 07:05 PM.