LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-15-2010, 10:46 PM   #1
GrubbySeismic
Member
 
Registered: Jan 2010
Location: Twickenham, UK
Distribution: OpenSolaris2009.06x86 || Linpus Lite 1.2 ||Debian (Lenny kernel 2.6 && Gnome 2)
Posts: 43

Rep: Reputation: 15
Red face Both my Windows Partitions are still RO, even after reformat.


I have been trying to DL the version of DOS-box I prefer to C:\, but I made both the Win-lose partitions RO when I first installed / (call me crazy, but I was paranoid it might mess with an already broken install from nearly a decade ago with an OS that-shall-remain-nameless that's even older). Oops!

Incidentally, I have learned from shenanigans with Linux-drivers from nVidia that /home partition is definitely a good idea (another post for another time)...

Anyway: even though I specifically made sure I turned the RO flag off but definitely made both Win' part's "usable" in the Installer from the NETINST live-CD.

I had to format because GParted ("Partition Editor" under System -> Administration) wouldn't allow me to edit RW/RO thingy... Even when I logged in as /

I checked in fstab, but there's no RO flags listed.

I ar Stuck!

P.S. I may be using the word "flag" when I mean something else. When you run the Lenny graphical installer, and choose to manually partition-edit, and then choose to "use" your [I chose] FAT-32 partitions, there's a few setup choices that become available. Including "its mount-point shall be..." and these Extra Choices I'm referring to as flags, that are "RO", "Quiet?" and a third one I can't remember... Time for sleeping!

P.P.S. This is in Newbie because I'm convinced it's something really simple that I'm missing.
 
Old 01-15-2010, 11:05 PM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
It's probably the mount options. Something like the following should work for ntfs

Code:
/dev/sda1   /foo            ntfs defaults,nls=utf8,umask=007,gid=46  0  1
Evo2
 
Old 01-15-2010, 11:26 PM   #3
GrubbySeismic
Member
 
Registered: Jan 2010
Location: Twickenham, UK
Distribution: OpenSolaris2009.06x86 || Linpus Lite 1.2 ||Debian (Lenny kernel 2.6 && Gnome 2)
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks for the speedy response; does that differ much for FAT32? Both part's are definitely formatted with a file allocation table...
 
Old 01-15-2010, 11:32 PM   #4
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Give it a try (adjust the fstab line: s/ntfs/fat32).

Evo2.
 
Old 01-16-2010, 02:17 AM   #5
lupusarcanus
Senior Member
 
Registered: Mar 2009
Location: USA
Distribution: Arch
Posts: 1,022
Blog Entries: 19

Rep: Reputation: 146Reputation: 146
You have to *unmount* the Winblows partition first before editing. Mounting is simply mounting the file system so it can be read, not wrote too.

If all you gotta do is delete it, unmount and format.
 
1 members found this post helpful.
Old 01-17-2010, 06:19 PM   #6
GrubbySeismic
Member
 
Registered: Jan 2010
Location: Twickenham, UK
Distribution: OpenSolaris2009.06x86 || Linpus Lite 1.2 ||Debian (Lenny kernel 2.6 && Gnome 2)
Posts: 43

Original Poster
Rep: Reputation: 15
Question

Quote:
Originally Posted by evo2 View Post
Give it a try (adjust the fstab line: s/ntfs/fat32).

Evo2.
Mine's in columns: so you don't mean add the rw flag to the options list?...

Example output from my fstab (as in gedit /etc/fstab):

/dev/hda1 /windows vfat utf8 0 0

I realise interpreting a vfat partition with utf8 dictionary is a bad idea (really didn't know what it was about when I first built it and now the startup tells me so every time)...
 
Old 01-17-2010, 07:13 PM   #7
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,753

Rep: Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288Reputation: 1288
Quote:
Originally Posted by GrubbySeismic View Post
Mine's in columns:
Columns? Yes, well I guess you could say there are six columns.

Quote:
so you don't mean add the rw flag to the options list?...
No I don't. The "defaults" option should take care of that.


Quote:
Example output from my fstab (as in gedit /etc/fstab):

/dev/hda1 /windows vfat utf8 0 0

I realise interpreting a vfat partition with utf8 dictionary is a bad idea (really didn't know what it was about when I first built it and now the startup tells me so every time)...
Ok, I so the s/ntfs/vfat explicitly, and even match your device and mountpoint:
Code:
/dev/hda1   /windows          vfat defaults,nls=utf8,umask=007,gid=46  0  1
Where the gid=46 is assuming the plugdev group and may not be needed.

Evo2.

Last edited by evo2; 01-17-2010 at 07:13 PM. Reason: typo
 
1 members found this post helpful.
Old 02-04-2010, 08:43 AM   #8
GrubbySeismic
Member
 
Registered: Jan 2010
Location: Twickenham, UK
Distribution: OpenSolaris2009.06x86 || Linpus Lite 1.2 ||Debian (Lenny kernel 2.6 && Gnome 2)
Posts: 43

Original Poster
Rep: Reputation: 15
Unhappy

Sorry this took a while, but I've been playing with it

Following the boot-options advice: I have used the line:

Code:
/dev/hda1   /windows          vfat defaults,nls=utf8,umask=007,gid=46  0  1
but changed only the Pass order (so root gets checked first, then /windows then /home).

However: there is a fail next to the fscheck during boot-time citing "nls=utf8" as an incompatible argument for FAT systems. Using only the defaults option means nothing new happens, but the [UTF8 / FAT case-sensitivity warning! Grrr!] text is gone from the printout during boot.

There is no mount-point available to my non-priveledged user-account when I log in (i.e. when I am logged in as a "normal" user I get no icon on the Desktop to /windows). When I am in as Root however, I get both my Windows partitions and rw access. This appears to be the case no matter what boot options I use...

When I attempt to mount /dev/hda1 using Root Terminal (not in as Root again) I get this:

Code:
Debian-Evesham:/home/nick# mount /dev/hda1
Code:
mount: wrong fs type, bad option, bad superblock on /dev/hda1, missing codepage or helper program, or other error
It also notes "In some cases useful info is found in syslog - try dmesg | tail or so" (which I assume should read ending "...or some [other thing]")...

When I have time I will try out fstab with "nls=" missing from boot-options an find out where the System Log is...
 
Old 02-04-2010, 09:16 AM   #9
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
Which version of windows do you have? Check the file system. It could be fat32 or ntfs.
sudo file -s /dev/hda1

Read though the man pages for mount and fstab. You can change the ownership of a mounted ntfs or vfat filesystem by mounting them with the "uid=" and "gid=" options. You can use your username and primary group name. Use "fmask=" and "dmask=" to change the permissions when it is mounted.

If this is an installed Windows system, then don't save to the system parts of Windows. Save to your users "My Documents" or a similar directory in your own area.
 
1 members found this post helpful.
Old 02-04-2010, 06:17 PM   #10
GrubbySeismic
Member
 
Registered: Jan 2010
Location: Twickenham, UK
Distribution: OpenSolaris2009.06x86 || Linpus Lite 1.2 ||Debian (Lenny kernel 2.6 && Gnome 2)
Posts: 43

Original Poster
Rep: Reputation: 15
Lightbulb Ta!

The FS' definitely Fat32, as the logo.sys proudly states "Windows Millenium Edition" (I can feel your shock and horror).

I didn't know that the MAN page had a separate section for FAT and VFAT... I like whoever added the note:

Quote:
Various misguided attempts to force Unix or DOS conventions
onto a FAT file system.
Anyway:

I have no idea what the right parameter for umask is meant to be (in case you were wondering) I'm just using what Evo2 suggested (see above)...
I'm not even sure what is meant by a bitmask. Sad, but true; but I do know not to write to System32 or even anywhere in C:\Windows ...

As stated, they have been RO since the beginning, even when I tried re-running the NETINST from CD.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Protecting the bootloader from a windows reformat ethics Linux - Newbie 12 05-04-2005 04:49 PM
how do I reformat particular partitions fatblueduck Linux - Software 3 11-01-2004 05:11 AM
uninstall mandrkae 9.2 & bootloader & reformat partitions jkibbe Linux - Newbie 3 08-24-2004 09:36 PM
reformat for Windows Kees Linux - Software 2 07-04-2002 07:26 PM
reformat from Linux to NT or Windows donsung Linux - General 5 11-04-2001 11:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 03:50 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration