LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 05-15-2013, 02:32 PM   #1
vinothk91
LQ Newbie
 
Registered: May 2013
Location: Chennai,India
Posts: 4

Rep: Reputation: Disabled
BOSS Linux


Does anyone have used BOSS Linux?.It is a debian based linux.when i try to install something it throws dependency problems.i tried manythings to solve this.but i could not get..

I tried to install flareget download manager..flareget_1.4-7_i386.deb i used dpkg --install flareget_1.4-7_i386.deb command.i attached the screenshot of the installation process with this..it is as below..

(Reading database ... 162735 files and directories currently installed.)
Preparing to replace flareget 1.4-7 (using flareget_1.4-7_i386.deb) ...
Unpacking replacement flareget ...
dpkg: dependency problems prevent configuration of flareget:
flareget depends on libc6 (>= 2.13); however:
Version of libc6 on system is 2.11.2-6boss1.
flareget depends on libqt4-network (>= 4:4.8.1); however:
Version of libqt4-network on system is 4:4.6.3-4.
flareget depends on libqtcore4 (>= 4:4.8.1); however:
Version of libqtcore4 on system is 4:4.6.3-4.
flareget depends on libqtgui4 (>= 4:4.8.1); however:
Version of libqtgui4 on system is 4:4.6.3-4.
dpkg: error processing flareget (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
flareget



i downloadd it from internet.After this installation process i can see the "flarege" menu and icon in the Appliatio->internet menu.But i could not open that
Attached Images
File Type: png Screenshot.png (61.8 KB, 10 views)

Last edited by vinothk91; 05-17-2013 at 09:29 AM. Reason: Updated probelm details
 
Old 05-15-2013, 02:36 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,548

Rep: Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815
Quote:
Originally Posted by vinothk91 View Post
Does anyone have used BOSS Linux?
Probably the folks at the BOSS Forums have:
http://bosslinux.in/
 
Old 05-16-2013, 11:48 AM   #3
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,320

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
When I tried it, it seemed fine. But it's only Debian Stable with extra support for Indian languages and a few extra programs, so I expect a Debian user could help.

When you ask a question, you need to explain what happened. I gather that you've installed BOSS and now you're having trouble adding a program. So,
1. What were you trying to install?
2. Were you using Synaptic or apt-get in the command line?
3. Exactly what happened: what message did you get?
 
Old 05-16-2013, 11:54 AM   #4
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Dehradun, Uttarakhand, India
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,413

Rep: Reputation: 303Reputation: 303Reputation: 303Reputation: 303
Can you please post where did you struck, problems you got? That may help solving the problem.
 
Old 05-16-2013, 12:53 PM   #5
vinothk91
LQ Newbie
 
Registered: May 2013
Location: Chennai,India
Posts: 4

Original Poster
Rep: Reputation: Disabled
I tried to install flareget download manager..flareget_1.4-7_i386.deb i used dpkg --install flareget_1.4-7_i386.deb command.i attached the screenshot of the installation process with this..it is as below..

(Reading database ... 162735 files and directories currently installed.)
Preparing to replace flareget 1.4-7 (using flareget_1.4-7_i386.deb) ...
Unpacking replacement flareget ...
dpkg: dependency problems prevent configuration of flareget:
flareget depends on libc6 (>= 2.13); however:
Version of libc6 on system is 2.11.2-6boss1.
flareget depends on libqt4-network (>= 4:4.8.1); however:
Version of libqt4-network on system is 4:4.6.3-4.
flareget depends on libqtcore4 (>= 4:4.8.1); however:
Version of libqtcore4 on system is 4:4.6.3-4.
flareget depends on libqtgui4 (>= 4:4.8.1); however:
Version of libqtgui4 on system is 4:4.6.3-4.
dpkg: error processing flareget (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for gnome-menus ...
Processing triggers for desktop-file-utils ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
flareget
Attached Images
File Type: png Screenshot.png (61.8 KB, 13 views)
 
Old 05-17-2013, 03:12 AM   #6
Satyaveer Arya
Senior Member
 
Registered: May 2010
Location: Dehradun, Uttarakhand, India
Distribution: RHEL, CentOS, Debian, Oracle Solaris 10
Posts: 1,413

Rep: Reputation: 303Reputation: 303Reputation: 303Reputation: 303
You must check the logs files also, that may help you catching the problem.
 
Old 05-17-2013, 03:15 AM   #7
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and Scientific Linux
Posts: 5,658

Rep: Reputation: 1261Reputation: 1261Reputation: 1261Reputation: 1261Reputation: 1261Reputation: 1261Reputation: 1261Reputation: 1261Reputation: 1261
Hi,

where did you get that .deb file from? It is clearly not compatible with your os.

Evo2.
 
Old 05-17-2013, 06:03 AM   #8
vinothk91
LQ Newbie
 
Registered: May 2013
Location: Chennai,India
Posts: 4

Original Poster
Rep: Reputation: Disabled
i downloadd it from internet.After this installation process i can see the "flarege" menu and icon in the Appliatio->internet menu.But i could not open that
 
Old 05-17-2013, 09:38 AM   #9
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,548

Rep: Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815Reputation: 2815
Quote:
Originally Posted by vinothk91 View Post
i downloadd it from internet.After this installation process i can see the "flarege" menu and icon in the Appliatio->internet menu.But i could not open that
Just saying you got it "from internet" tells us nothing. Which site did you get it from? And the messages you got when you installed it are there because each one is a package dependency, which ALSO needs to be downloaded/installed.

Remove the package, and try to reinstall it with apt-get instead.
 
1 members found this post helpful.
Old 05-17-2013, 10:39 AM   #10
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
Why will you try to use dpkg like that in the first place?

Use apt-get, aptitude or synaptic.

If you cannot install a random package from Internet with no support for apt-get, then it would be a better idea to compile from source.
 
Old 05-17-2013, 11:38 AM   #11
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 3,320

Rep: Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881Reputation: 881
There are two problems here.

1. Using dpkg instead of apt-get. If you use apt-get, it will retrieve any missing dependencies from the repository, but dpkg will only complain.

2. Using a package from the developer instead of getting it from your repository. In the error messages I see
flareget depends on libc6 (>= 2.13); however: Version of libc6 on system is 2.11.2-6boss1.
In other words, flareget has been packaged to look for a more recent version of the library than the one you've got. This is because BOSS is based on Debian Stable, which uses older versions whose stability is known. The Flareget website says that it's for "distributions based on Debian like Mint or Ubuntu". These are based on Tebian Testing, with more recent software.

It could be that Flareget doesn't actually need the latest versions. When a package is made up, the metadata lists the dependencies that have been used, but older versions may work well. To test that, try
a) making sure all the dependencies are installed, regardless of version
b) installing with the dependency checking turned off (see man apt-get for the command)

If the installed program doesn't work,
a) uninstall it
b) get the source code (tar ball) and compile it. It may compile with the libraries you've got.

If that fails, you'll just have to put up with the download manager(s) that are in Debian!

Last edited by DavidMcCann; 05-17-2013 at 11:39 AM.
 
1 members found this post helpful.
Old 05-17-2013, 01:13 PM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2015, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,688

Rep: Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760Reputation: 2760
The easy solution : There is a standalone package "For older systems":
http://flareget.com/download/
32bits http://www.flareget.com/files/flareg...stable).tar.gz
>> flareget_1.4-9_x86_32(stable).tar.gz

64bits http://www.flareget.com/files/flareg...stable).tar.gz
>> flareget_1.4-9_x86_64(stable).tar.gz

-
 
1 members found this post helpful.
  


Reply

Tags
flareget


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Grub error on linux boss nagaraj.irock Linux - Newbie 4 04-25-2012 07:48 AM
LXer: Linux boss: We're number one where it counts LXer Syndicated Linux News 0 04-04-2012 10:20 AM
How to convince your boss and his boss? mikedeatworld General 8 10-09-2004 01:04 PM


All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration